none
DPM 2010 daily backups on separate tapes RRS feed

  • Question

  • Forums,

    We very recently (this week) began daily tape backups using DPM 2010.  We had previously been backing up to tape on a weekly basis (Friday nights) with no problems.  The 1st nightly backup ran successfully with no issues to a single tape in our HP 1/8 G2 autoloader.  However, the 2nd night's backup continued to write data to that first tape then wrote another 900GB to a 2nd tape.  What would cause this and is there a resolution?

    Thanks in advance,

    Joe

    Thursday, June 27, 2013 3:15 PM

Answers

  • Hi

    Yes, when co-location is enabled, offsite ready is controlled by theTapeWritePeriodRatio which by default is 15% of the retention period for the protection group.

    TapeWritePeriodRatio is a property that can be set when colocation is enabled on tape.  In case of non-colocation, the tape becomes marked as “offsite ready” as and when it is written on to.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.


    Friday, June 28, 2013 1:56 AM
    Moderator
  • Hi,

    You can answer your own question by looking at scheduled jobs - if it's scheduled it will run.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, June 28, 2013 2:48 PM
    Moderator

All replies

  • Forums,

    BTW, I had previously enabled Co-Location of Data on Tape while trying to troubleshoot a previous issue.  It was still enabled and I was wondering why the "offsite ready" green checkmark was not appearing on the tape cartridges in the autoloader slots like it used to.

    I just disabled Co-Location of Data on Tape and the green checkmark appeared on the 2nd cartridge (that contained the remainder of data from last night's backup).  Could Co-Location of Data on Tape being enabled have caused last night's backup to write data on Tuesday night's cartridge and finish the rest on the 2nd cartridge.

    I notice that both cartridges are now listed as "offsite ready" in DPM.

    Thoughts?

    Joe

    Thursday, June 27, 2013 3:38 PM
  • Hi

    Yes, when co-location is enabled, offsite ready is controlled by theTapeWritePeriodRatio which by default is 15% of the retention period for the protection group.

    TapeWritePeriodRatio is a property that can be set when colocation is enabled on tape.  In case of non-colocation, the tape becomes marked as “offsite ready” as and when it is written on to.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.


    Friday, June 28, 2013 1:56 AM
    Moderator
  • Mike,

    Thanks for the reply and answer!  Yes, after I disabled co-location and added more tapes to the autoloader, the backup ran last night with no issues and marked the tape as "offsite ready".  Nice!!!

    Another quick question: we have the rotation scheme set to run daily backups to tape and monthly backups to tape (I also need to experiment with weekly tapes).  The monthly backup is set to run on the last day of the month.  However, since we do not have Saturday and Sunday selected as "backup days", will the monthly backup (for June) run tonight (June 28th) or will it be skipped because Sat/Sun are not selected (end of month is on Sunday)?  It is not a problem, just gathering information.  Thank you, again, for your expertise!

    Joe

    Friday, June 28, 2013 2:03 PM
  • Hi,

    You can answer your own question by looking at scheduled jobs - if it's scheduled it will run.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, June 28, 2013 2:48 PM
    Moderator
  • Mike,

    OK, thanks.  However, when I look at the Scheduled Jobs for today, the backup jobs for this evening are listed (along with recovery points and synchronizations).  In the list, I can't determine which "label" will be applied to tonight's backup.  I think, though, that I found the answer.  In the Customize Recovery Goals Options, the "Specify the action DPM should take..." option is set to "Run backup only for the recovery goal with the longest retention range".

    I have only 2 Recovery Goals configured (1 for daily backups and 1 for monthly backups).  Since the daily backup is scheduled for this evening, the 2nd recovery goal may not override it as the monthly backup schedule is set to perform a backup on the "Last Day" of every month and there is no "daily" backup schedule set for that day.

    If I am correct, the monthly backup will kick off just fine on Sunday evening and a daily will occur tonight.  I will then add a 3rd recovery goal to perform "weekly" backups.  You had earlier told me this on another thread but it didn't make sense until now... :-)

    Can you coroborate this thinking?

    Thanks,

    Joe

    Friday, June 28, 2013 3:04 PM
  • Mike,

    That thinking was correct.  Last night's DPM backup to tape (to tape) ran for month-end (June 30th) due to the Recovery Goals set.  Even though Sunday was not selected in the backup schedule, the monthly backup ran due to the 2nd Recovery Goal being configured for the last day of the month.

    Thanks again for all of your help!

    Joe

    Monday, July 1, 2013 11:21 AM