locked
Pinned items corrupt after crash. RRS feed

  • Question

  • Hi,

    We had a power cut at work last week which seems to have messed up my profile. One of the annoying things is the pinned items aren't showing up even though they are appearing in the correct folder... this is happening to the start menu pinned items and the taskabr pinned items.  The permissions are correct.

    When I create a new pinned item it appears in the correct folder but adds a (2) at the end so it knows they are there. I did find an article regarding a file called iconcache.db but its nowhere to be found.

    Anyone have any ideas or pointers? Its more of an annoyance than anything else.. I don't use system restore so won't be restoring.

    Thanks in advance.

    Simon

    Monday, June 7, 2010 9:04 AM

Answers

  • Hi Simon,

     

    Please unpin the icons from Start menu and Taskbar first. After that, delete the files in the following folders:

     

    C:\Users\%USERNAME%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar

    C:\Users\%USERNAME%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\StartMenu

     

    Once the files are deleted, re-pin the icons.

     

    If the issue persists, rebuild the icon cache to see if the issue can be resolved:

     

    1.     Click Start, and open Computer.

    2.     On the Tool bar, click Organize and choose Folder and Search Options.

    3.     Click the View tab, and check to select the Show hidden files and folders option, and click OK.

    4.     Then, enter the following directory:

     

    %USERPROFILE%\AppData\Local

     

    5.     Find the IconCache.db file, and rename it as IconCache.db.old.

    6.     Close the window, and restart the computer.

     

    Note: If the IconCache.db cannot be found, move on to the following steps to show hidden files:

     

    a)    Click Start, and open Computer.

    b)    Click Organize -> Folder and search options.

    c)     Click View tab.

    d)    Choose "Show hidden files, folders, and drives".

    e)    Click OK.

     

    Hope this helps.

     

    Regards,

    Linda

     

     

     

    • Marked as answer by Linda Yan Monday, June 14, 2010 2:00 AM
    Tuesday, June 8, 2010 7:02 AM