locked
Error found: Code 0x8024402c RRS feed

  • Question

  • Hi,

    I successfully installed FCS on my laptop without any errors except a warning about hardware requirement.

    I successfully installed FCS as one-server topology on Windows Server 2003 Standard Edition on my laptop without any errors except a warning regarding hardware requirement, I can Manage server & a Windows XP client with FCS Console, the FCS agent is working fine on same Server with Green-Right Check mark in windows System Tray.

    But I am facing problem with FCS agent on Windows XP machine which I installed on Virtual Server 2005 R2. The FCS agent icon is showing as yellow/arrange exclamation mark in System Tray, when I double click on FCS agent icon in System Tray it opens FCS window, there is a message it says "Updated definitions enable detections of the latest harmful or unwanted software and prevent it from running on your computer." and there is a button too "Check for Updates Now", when I click on this button I am getting this error (Err found: Code 0x8024402c).

    Please help to find out where I am doing wrong.

    Majid

    Wednesday, December 6, 2006 8:15 AM

All replies

  • Hi Majid

    Thanks for posting!

    The error code you are seeing states that the machine cannot resolve the HTTP name it's attempting to contact.  So there a few things you can do to investigate and successfully deploy signatures to your client

    1. Verify that the client computer is configured to point to the WSUS server

    (To learn more about how to configure your client to communicate with WSUS, please take a look at the online WSUS documentation)

        2.  You can also install signatures directly from Microsoft Update

    Open a broswer window on the client and point it to: http://update.microsoft.com/microsoftupdate.  Follow the prompts and you can also manually install the signatures (just like installing a patch or other update via Microsoft Update)

    If the client computer is properly configure to point to your WSUS server, make sure the WSUS server sees the client (open the WSUS admin console on the server) and that network connectivity between the server and the client is verified

    Thanks

    Chris

    Forefront Client Security PM

    Wednesday, December 6, 2006 2:38 PM
  • Thanks for the question Majid.

     

    Error 0x8024402c is WU_E_PT_WINHTTP_NAME_NOT_RESOLVED – “the proxy server or target server name cannot be resolved.”

     

    The antimalware client calls into the Automatic Updates service to download the most recent definitions.  The Automatic Update service can be configured to use MicrosoftUpdate or an internal WSUS server(FCS Distribution role).  You mention that you are using a 1-server topology which should include the Distribution role.  Therefore, the XP client machine you are experiencing an issue with should be configured to pull definitions from that server.

     

    Did you perform the steps in the FCS Deployment guide under the topic ‘To change the automatic update location source ?  That should tell the XP client to contact the FCS server for its definitions.  If you did do this, can you resolve the machine name that you used in the policy from the XP client machine? 

     

    If the name you used is a fully-qualified name and you are using a proxy server you may need to tell Windows to bypass the proxy server when it contacts this machine.  The easiest way to do this is to make sure that you can browse to that machine via Internet Explorer(e.g. http://FcsServer/WsusAdmin) and then at a command prompt run “proxycfg -u”.  This will import the current user settings from IE into the machine settings for WinHTTP that services like Automatic Updates use.

     

    If these suggestions do not work, and you fell comfortable doing so, please provide the %windir%\windowsupdate.log file which will tell us more.

     

    Thanks,

    Craig

     

    Microsoft Forefront Client Security Support

    Wednesday, December 6, 2006 2:43 PM
  •  

    Hi, just to add on Craigs comment;

    We were having the same problem, we use a proxy server but needed to bypass proxy to our WSUS server.

    Fixed it by configuring WPAD in DHCP and DNS, or by "proxycfg.exe -u" with exceptions already set in IE

    Hope this helps

     

    Thursday, December 14, 2006 6:07 AM
  • Method 1: Remove characters from the proxy exception list, and then clear the proxy cache
    To do this, follow these steps, as appropriate for the operating system that you are running.
    Windows 2000, Windows XP, and Windows Server 2003
    Open Internet Explorer.
    On the Tools menu, click Internet Options.

    Note If the menu is not available in the Internet Explorer window, press the ALT key on the keyboard to display the menu.
    Click the Connections tab, click LAN Settings, and then click Advanced.
    Delete any entries in the Exceptions section, and then click OK.
    Close Internet Explorer.
    Click Start, click Run, type cmd, and then click OK.
    Type the following commands. Press ENTER after each command.
    proxycfg -d
    net stop wuauserv
    net start wuauserv
    Try to install the updates again.
    Windows Vista and Windows Server 2008
    Open Internet Explorer.
    On the Tools menu, click Internet Options.

    Note If the menu is not available in the Internet Explorer window, press the ALT key on the keyboard to display the menu.
    On the Connections tab, click LAN Settings, and then click Advanced.
    Delete any entries in the Exceptions section, and then click OK.
    Close Internet Explorer.
    Click StartCollapse this imageExpand this image, and then type cmd in the Start Search box.
    In the search results list, right-click Cmd.exe, and then click Run as Administrator.

    Collapse this imageExpand this imageIf you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
    Type the following commands. Press ENTER after each command.
    netsh winhttp reset proxy
    net stop wuauserv
    net start wuauserv
    Try to install the updates again.
    Back to the top
    Method 2: Enable the "Automatically detect settings" option in Internet Explorer
    To do this, follow these steps:
    Open Internet Explorer.
    On the Tools menu, click Internet Options.

    Note If the Tools menu is unavailable in Internet Explorer, press the ALT key to display the menu.
    On the Connections tab, click LAN Settings.
    Click to select the Automatically detect settings check box, and then click OK.
    Try to install updates again.

    • Proposed as answer by Peter Mcain Thursday, July 15, 2010 11:09 AM
    Wednesday, July 14, 2010 10:44 PM