locked
Team Foundation Server 2010 Management Pack could not be imported RRS feed

  • Question

  • I want to upgrade the Team Foundation Server 2010 Management Pack from 1.0.0.0 to 1.0.0.7, but I'm getting errors. Can someone help me with that please?

    Team Foundation Server 2010 Management Pack could not be imported.

    If any management packs in the Import list are dependent on this management pack, the installation of the dependent management packs will fail.

    Verification failed with 3 errors:

    -------------------------------------------------------

    Error 1:

    Found error in 2|TeamFoundationServer2010|1.0.0.0|TeamFoundationServer2010|| with message:

    Version 1.0.0.7 of the management pack is not upgrade compatible with older version 1.0.0.0. Compatibility check failed with 2 errors:

    -------------------------------------------------------

    Error 2:

    Found error in 1|TeamFoundationServer2010/31bf3856ad364e35|1.0.0.0|TeamFoundationServer2010.TFS2010ATTierDiscoveryDataSource|| with message:

    Generated XML sample:

    <Configuration xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

      <ScriptDebugEnabled>true</ScriptDebugEnabled>

      <IntervalSeconds>1</IntervalSeconds>

      <AddBuildConfig>true</AddBuildConfig>

      <sslOnly>true</sslOnly>

      <NonDefaultPort>1</NonDefaultPort>

    </Configuration>

    did not pass schema validation against the new Configuration schema.

    : Schema validation failed.

    The element 'Configuration' has incomplete content. List of possible elements expected: 'VirtualDirectory'.

    -------------------------------------------------------

    Error 3:

    Found error in 1|TeamFoundationServer2010/31bf3856ad364e35|1.0.0.0|TeamFoundationServer2010.TFS2010ATTierDiscoveryDataSource|| with message:

    Generated XML sample:

    <Configuration xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

      <ScriptDebugEnabled>true</ScriptDebugEnabled>

      <IntervalSeconds>1</IntervalSeconds>

      <AddBuildConfig>true</AddBuildConfig>

      <sslOnly>true</sslOnly>

      <NonDefaultPort>1</NonDefaultPort>

    </Configuration>

    did not pass schema validation against the new Configuration schema.

    : Schema validation failed.

    The element 'Configuration' has incomplete content. List of possible elements expected: 'VirtualDirectory'.

    -------------------------------------------------------

    Thursday, March 27, 2014 6:52 PM

Answers

  • Please see the update, the requirement page doesn't mention 2012 r2 for the 2010 pack either.... I've included a link to the page http://www.microsoft.com/en-gb/download/details.aspx?id=6325 Sorry for the confusion! :)

    Obviously most packs should work but as the 2013 pack doesn't and it isn't explicitly defined. I'll double check the mp guide...

    The error seems to indicate its an issue between the versions so it might be worth removing the older version of the pack and installing the latest version.

    • Edited by Chunky.1 Thursday, March 27, 2014 10:14 PM
    • Proposed as answer by Chunky.1 Monday, March 31, 2014 7:46 AM
    • Marked as answer by Juke Chou Monday, April 7, 2014 4:43 PM
    Thursday, March 27, 2014 9:57 PM
  • Hi,

    Form the download page, we can see the supported system is System Center Operations Manager 2007 or System Center Operations Manager 2012 but SCOM 2012 R2 is not listed there.

    http://www.microsoft.com/en-hk/download/details.aspx?id=6325#

    Regards,

    Yan Li


    Regards, Yan Li

    • Marked as answer by Juke Chou Monday, April 7, 2014 4:43 PM
    Monday, March 31, 2014 6:23 AM

All replies

  • Which version of SCOM are you running? This pack doesn't appear to be supported on 2012 R2, see the following for more detail. http://kevingreeneitblog.blogspot.co.uk/2014/02/scom-download-new-management-pack-for.html This seems to be backed up b the error message you seeing.
    That link refers to the 2013 version the 2010 says the following as well. System Requirements Supported Operating System Windows Server 2003, Windows Server 2008, Windows Server 2008 R2, Windows Server 2012 Other Software: Team Foundation Server 2010 System Center Operations Manager 2007 or System Center Operations Manager 2012
    • Edited by Chunky.1 Thursday, March 27, 2014 9:48 PM
    Thursday, March 27, 2014 9:38 PM
  • I'm actually running SCOM 2012 R2, but it's not TFS 2013 MP I'm talking about, but rather TFS 2010 MP.
    Thursday, March 27, 2014 9:49 PM
  • Please see the update, the requirement page doesn't mention 2012 r2 for the 2010 pack either.... I've included a link to the page http://www.microsoft.com/en-gb/download/details.aspx?id=6325 Sorry for the confusion! :)

    Obviously most packs should work but as the 2013 pack doesn't and it isn't explicitly defined. I'll double check the mp guide...

    The error seems to indicate its an issue between the versions so it might be worth removing the older version of the pack and installing the latest version.

    • Edited by Chunky.1 Thursday, March 27, 2014 10:14 PM
    • Proposed as answer by Chunky.1 Monday, March 31, 2014 7:46 AM
    • Marked as answer by Juke Chou Monday, April 7, 2014 4:43 PM
    Thursday, March 27, 2014 9:57 PM
  • Hi,

    Form the download page, we can see the supported system is System Center Operations Manager 2007 or System Center Operations Manager 2012 but SCOM 2012 R2 is not listed there.

    http://www.microsoft.com/en-hk/download/details.aspx?id=6325#

    Regards,

    Yan Li


    Regards, Yan Li

    • Marked as answer by Juke Chou Monday, April 7, 2014 4:43 PM
    Monday, March 31, 2014 6:23 AM