none
Power BI publishing and data refresh failure against SQL Server 2016 AlwaysOn Cluster data source through Microsoft Data Gateway RRS feed

  • Question

  • Hi Everyone,

    We have configured SQL Server 2016 AlwaysOn  (With 2 node) and when we trying to connect the database through  Power Bi desktop it's getting connected when we unchecked "encrypt Connection" and If its checked "encrypt Connection" option,  We are getting below error.

    Same issue happening when Refreshing the Power BI report on the web ..

    Note: Recently we have done windows patching on the Power Bi dekstop server (Not on SQL Server) post that we are getting beloe error.

    Microsoft.Data.Mashup.ValueError.Message: A connection was successfully established with the server, but then an error occurred during the login process. (provider: SSL Provider, error: 0 - The received certificate has expired.)

    I would request you to suggest on the same, How can we proceed further.

    Thanks,

    Nagendra N

    Wednesday, November 21, 2018 4:03 AM

Answers

  • Please refer to the following steps to renew it:

    1. Get a certificate which can meet the SQL Server Certificate Requirements.

    2. Add this certificate with Microsoft Management Console.

    3. In SQL Server Configuration Manager, first disable the ForceEncryption, then in the Certificate tab, select the certificate you want to use, after that, enable ForceEncryption again,then restart the database engine after operating these.

    4. Configure the SQL Server clients, including the machine running PowerBI desktop.

    Wednesday, November 21, 2018 7:15 PM

All replies

  • From the error message, it looks like the certificate you deployed for the SQL server has expired. Did you try renew the certificate?
    Wednesday, November 21, 2018 7:12 PM
  • Please refer to the following steps to renew it:

    1. Get a certificate which can meet the SQL Server Certificate Requirements.

    2. Add this certificate with Microsoft Management Console.

    3. In SQL Server Configuration Manager, first disable the ForceEncryption, then in the Certificate tab, select the certificate you want to use, after that, enable ForceEncryption again,then restart the database engine after operating these.

    4. Configure the SQL Server clients, including the machine running PowerBI desktop.

    Wednesday, November 21, 2018 7:15 PM