locked
One way audio silence on LYNC voip call RRS feed

  • Question

  • Hi guys.

    We have Lync SIP Trunk with our provider. Recently we have "strange" issues with some calls (but not with all of them), when we call a persons number, we hear a ringing tone, but after the customer answers we are unable to hear them, but they are able to hear us.

    Our SIP-TRUNK provider says (and he has sent us lower Picture) that there is everything ok on their side.

    Any hints how to solve this?


    bostjanc

    Monday, January 11, 2016 12:10 PM

Answers

  • Hi Bostjac,

    Please check if you have multiple NICs on the mediation server.  Typically you will have 2 IPs if you want to use separate IP for PSTN Interface. In such set up the 2 IPs should be from different subnets so that media stream between GW and Mediation always uses the PSTN interface.

    -Santosh

    • Proposed as answer by Eason Huang Thursday, February 11, 2016 9:52 AM
    • Marked as answer by Eason Huang Monday, February 15, 2016 7:55 AM
    Thursday, January 14, 2016 6:47 AM

All replies

  • HI

    I have seen these issue several times, if you take about on prem setup & Sip trunk with Local pstn gateway/PBX it usually comes issue with codec, another  example is if we are integrating Lync with Avaya without SM & doing integration with Call manager, this issue  arrives,  so we require Session manager to rectify this issue, here the issue in with SIP trunk what i saw in the picture that G711A codec is used with Alaw, ask your vendor change it to Alaw & check,U law is used in europe & Ulaw in America.

    Regards

    • Proposed as answer by Eason Huang Tuesday, January 12, 2016 6:45 AM
    • Unproposed as answer by B_C_R Tuesday, January 12, 2016 6:51 AM
    Monday, January 11, 2016 1:22 PM
  • Zahoor thanks, I Will ask my provider if he can check.

    bostjanc

    Tuesday, January 12, 2016 6:51 AM
  • Hi,

    Please also try to disable the RTCPACtivecalls and Session timers on trunks by the Lync Server Management Shell below:

    Disabled RTCPACtivecalls on trunkSet-CsTrunkConfiguration -Identity “Service:” -RTCPActiveCalls $False -EnableSessionTimer $TrueSet-CsTrunkConfiguration -Identity Global -RTCPActiveCalls $False -EnableSessionTimer $True

    Disabled session timersSet-CsTrunkConfiguration -Identity Global -EnableSessionTimer $FalseSet-CsTrunkConfiguration -Identity Service: -EnableSessionTimer $False

    Also if there is any firewall between Mediation Service and the PSTN Provider, try to disable it temporarily to test the issue.

    Best Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Eason Huang
    TechNet Community Support

    Tuesday, January 12, 2016 7:01 AM
  • Eason, thank you for your reply.

    Could you please try to explain what Disabling RTCPActivecalls and disabling sessions timers does really?


    bostjanc


    • Edited by B_C_R Tuesday, January 12, 2016 7:19 AM
    Tuesday, January 12, 2016 7:19 AM
  • We have ran:
    Set-CsTrunkConfiguration -RTCPActiveCalls $False -EnableSessionTimer $True

    Restarted the mediaton service on Lync frontend and the issue remains :( :(


    The provider said that "G711 Alaw codec" is used also in phone conversation which Works, so that is not the reason for this problem.
    Any other hints what can we do?


    bostjanc

    Wednesday, January 13, 2016 9:22 AM
  • Please check Lync log on issue pc with Snooper tool.

    Seems like ports are blocking, what kind of fw are you using?

    Any changes done until this problem started?

    Does it happen to everyone or just one specific user? Same issue with internal and external network?

    Does meeting and Skype to Skype call work?


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Wednesday, January 13, 2016 11:08 AM
  • We Will check Lync log with Snooper tool.

    Seems like ports are blocking, what kind of fw are you using? - cisco ASA (but couldnt be ports if only some of the phone conversations having this issue).

    Any changes done until this problem started? ---> none

    Does it happen to everyone or just one specific user? Same issue with internal and external network? -> it happens to everyone, tested only from internal

    Does meeting and Skype to Skype call work? -> it Works.

    with best regards,


    bostjanc

    Wednesday, January 13, 2016 11:57 AM
  • Hi Bostjac,

    Please check if you have multiple NICs on the mediation server.  Typically you will have 2 IPs if you want to use separate IP for PSTN Interface. In such set up the 2 IPs should be from different subnets so that media stream between GW and Mediation always uses the PSTN interface.

    -Santosh

    • Proposed as answer by Eason Huang Thursday, February 11, 2016 9:52 AM
    • Marked as answer by Eason Huang Monday, February 15, 2016 7:55 AM
    Thursday, January 14, 2016 6:47 AM