locked
Could not connect to the Active Directory. Active Directory Certificate Services will retry when processing requires Active Directory access RRS feed

  • Question

  • Event properties – Event 91, Level Error, Event ID 91, Date and time 5/10/2012 11:29:48AM, Service CertificationAuthority

    -------

    General: 

    Could not connect to the Active Directory.

    Active Directory Certificate Services will retry when processing requires Active Directory access.

    --------

    We have a Windows 2008 Server Enterprise with AD . I would like to enable the service  "Certificate Services"  that allow me to enable radius to authenticate users wireless with the active directory.


    Thursday, May 10, 2012 5:42 PM

Answers

All replies

  • Regarding the error please check this http://technet.microsoft.com/en-us/library/cc774525(v=ws.10).aspx

    /Hasain

    • Proposed as answer by Elytis Cheng Friday, May 11, 2012 6:54 AM
    • Marked as answer by Elytis Cheng Monday, May 21, 2012 9:45 AM
    Thursday, May 10, 2012 6:04 PM
  • I know it's an old topic, but I have the same issue so I don't really want to open a new one.

    I get the exact same error message, but here, the CA is actually on the DC. The message appears at every boot but after that everything works fine. So it seems like for some reasons the domain is not available yet when the CA service tries to connect to it.

    I'm actually trying to migrate the domain and the CA to new servers and it happens there as well. If I install a clean domain + CA on the new server, no error, but if I move the data, I get the message.

    I would just ignore it but there is an other service that depends on the CA and it fails to start at every boot because of this. If I enable delayed start for the services, it seems to be fine but I'm afraid it's not a proper solution. There must be a reason why this happens and there has to be a solution.

    Any ideas how to fix it, please?

    Thursday, May 2, 2013 3:08 PM
  • The same problem. We have the CA on the DC as well and after updating and restarting this W2012 server I've got the same error message.

    I've run "nltest /sc_verify:[domainname]" on CA/DC server and I got "I_NetLogonControl failed: Status = 1355 0x54b ERROR_NO_SUCH_DOMAIN" error message. But the same command works well on other Windows servers in the domain.:

    Flags: b0 HAS_IP  HAS_TIMESERV
    Trusted DC Name \\ad.[domainname]
    Trusted DC Connection Status Status
    Trust Verification Status = 0 0x0 N
    The command completed successfully

    I've checked permissions along to http://technet.microsoft.com/en-us/library/cc774525(v=ws.10).aspx and all looks well.

    Any idea, please?


    • Edited by Racom NMNM Friday, October 18, 2013 2:33 PM
    Friday, October 18, 2013 2:17 PM
  • Hi, 

    Can you please check this forum or someone from Microsoft, as we have post here dating back from October that are not being answered.

    Everything for us is exactly the same as szucsati and Racom NMNM

    Please give us an answer on this as the link provided is absolutely useless.



    Thank you.

    Saturday, March 22, 2014 4:58 PM