none
Problem with logs and SQL-based settings RRS feed

  • Question

  • Hi,

    I'm trying to set up a pretty basic configuration for a MDT deployment. The main goal is to have the computer name taken from the SQL database, so that the names are reused instead of half-randomized.

    Here's my configuration.ini

    [Settings]
    Priority=CSettings, ByLaptop, ByDesktop, Default
    Properties=ComputerType, MyCustomProperty
    
    [ByLaptop]
    SubSection=Laptop-%IsLaptop%
    ComputerType=NTB
    
    [ByDesktop]
    SubSection=Desktop-%IsDesktop%
    ComputerType=DST
    
    [Default]
    ;Set computer name
    OSDComputerName=%ComputerType%-#left(replace("%Make%"," ",""),4)#-#left(replace("%SerialNumber%","-",""),6)#
    
    OSInstall=Y
    SkipAdminPassword=YES
    SkipApplications=YES
    SkipAppsOnUpgrade=YES
    SkipBDDWelcome=YES
    SkipBitLocker=YES
    BDEInstallSuppress=NO
    BDEWaitForEncryption=False
    BDEDriveLetter=S:
    BDEDriveSize=2000
    BDEInstall=TPM
    BDERecoveryKey=AD
    BDEKeyLocation=
    SkipCapture=YES
    SkipComputerName=NO
    SkipComputerBackup=YES
    SkipDeploymentType=YES
    DeploymentType=NEWCOMPUTER
    SkipDomainMembership=YES
    JoinDomain=ARP.LOCAL
    DomainAdmin=administrator
    DomainAdminDomain=ARP.LOCAL
    SkipFinalSummary=YES
    SkipLocaleSelection=YES
    KeyboardLocale=pl-PL
    UserLocale=pl-PL
    SkipPackageDisplay=YES
    SkipProductKey=YES
    SkipSummary=NO
    SkipTaskSequence=NO
    ;TaskSequenceID=WIN10ENT-001
    SkipTimeZone=YES
    TimeZoneName=Central European Standard Time
    SkipUserData=YES
    MachineObjectOU=OU=CLT,OU=Comps,OU=ARP,DC=arp,DC=local
    EventService=http://SRV-SVC-P01.arp.local:9800
    FinishAction=REBOOT
    SLShare=\\srv-svc-p01.arp.local\DeploymentLogs$
    ;SLShareDynamicLogging=\\srv-svc-p01.arp.local\DeploymentLogs$\%OSDComputername%
    
    [CSettings]
    SQLServer=srv-sql-p05.arp.local
    Instance=instance01
    Database=MDT
    Netlib=DBNMPNTW
    SQLShare=\\srv-svc-p01.arp.local\SQLLogs$
    Table=ComputerSettings
    Parameters=UUID, AssetTag, SerialNumber, MacAddress
    ParameterCondition=OR
    


    I feel like I can share the internal DNS names without risk, so nothing in the file above has been modified. All the shares are accessible (i.e. I can type in the shares from another computer into Explorer and have the relevant folder come up). I've also set up all the log-based shares so that "Everyone" has write permissions.

    However, two things are happening:

    1) despite setting up the SLShare, no files are ever created in the folder

    2) despite setting up and configuring the SQL connection, the WindowsPE gets slightly "stuck" on the CSettings stage and the computer name isn't downloaded from the SQL. Since I have no logs, I cannot say if there's a connection issue or if this is a configuration issue. Named Pipes are turned on and the MDT console has no problems working on the SQL database.

    Finally - yes, I've commented out the SLShareDynamicLogging - I first want to get the basic logs working before I go for the more detailed.

    Could someone point me in the right direction please?


    Monday, November 5, 2018 11:58 AM