locked
Throttling policy assistance RRS feed

  • Question

  • We have a default throttling policy which is configured as follows, for RCA

    RCAMaxConcurrency                         : 40
    RCAPercentTimeInAD                        : 5
    RCAPercentTimeInCAS                       : 205
    RCAPercentTimeInMailboxRPC                : 200

    A user, who has no explicitly defined policy has 105 MSExchangeRPC connections.  I see all the throttling information in our RCA logs, but no exceeded messages or the like.  Can someone point me in the right direction?

    This is what I'm running to get the connection count

    Get-LogonStatistics -Identity <alias> | ?{$_.ApplicationID -like "*MSExchangeRPC"} | Group-Object Identity | Select-Object Name,Count

    Name                                                                                                              Count
    ----                                                                                                              -----
    <exchangedn>                                                         105

    Saturday, October 4, 2014 4:12 PM

Answers

  • This is the default policy - there is no scope.

    After reviewing the issue further, it does not appear that the powershell command recommended to get RPC utilization is getting the same information that is used by RCAMaxConcurrency.  I have seen some users get throttled, finally, but they have never been as close to the one user with 100+ connections.  And the one user with 100+ connections never is throttled by the policy.

    Tuesday, October 14, 2014 2:13 PM

All replies

  • Hello,

    You can use the Store Limits:

    http://technet.microsoft.com/en-us/library/ff477612(v=exchg.141).aspx

    Thanks,

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Simon Wu
    TechNet Community Support

    Monday, October 6, 2014 2:58 AM
    Moderator
  • Thanks for the link, I'm going to review this.  Are you saying that the store limits are what is allowing the one user to make 105 connections to the Exchange server over RPC even though the throttling policy says to only allow 40?

    If the throttling policy is supposed to limit RPC connections than why is it not working?

    Monday, October 6, 2014 11:47 AM
  • Hello David,

    The “Throttling policy” is for CAS level and the store limitation is store level. Therefore, if you would like to limit the user’s MAPI sessions, you can also use the store limitation. If the user’s session is over, you can see a 9646 event ID in application log.

    For more reference, if you have interests to have more research on the “Throttling policy”, you can enable additional logging for the RPC Client Access logs:

    1. Edit the following config file in a text editor: C:\Program Files\Microsoft\Exchange Server\V14\Bin\Microsoft.Exchange.RpcClientAccess.Service.exe.config

    2. Find <add key=”LoggingTag” value=”… section.

    3. Here you must add Throttling to the comma separated string as shown in the description within the file.

    <add key="LoggingTag" value="ConnectDisconnect, Logon, Failures, ApplicationData, Warnings, Throttling " />

    4. Then restart the RPC Client Access service to pick up this change.

    After this change, the RPC client access log will include throttling information.  For example:

    /o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=test,,OUTLOOK.EXE,14.0.4760.1000,Cached,,,ncacn_ip_tcp,,,,00:00:00.1399752,"BS=Conn:2,HangingConn:0,AD:3000/3000/0%,CAS:123000/122722/1%,AB:3000/3000/0%,RPC:120000/120000/0%,FC:1000/0,Policy:DefaultThrottlingPolicy_766c8f13-bb90-4fee-912d-e1aec48df1ab,Norm",

    Thanks,

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Simon Wu
    TechNet Community Support

    Tuesday, October 7, 2014 6:52 AM
    Moderator
  • Yes I understand the two options/settings.  However I have a throttle configured and it does not appear to be working.  I do not think that adding a store limit would be appropriate as it seems there is something wrong with the policy engine (if that is the correct word).

    When throttling is enabled in the logs nothing ever being blocked/throttled.  So I can only assume that the policy level is not being hit, or that it is not being enforced.  Since the policy is configured for 40 and statistics show over 100, than I must assume that it is not being enforced. (or the statistics are wrong)

    Tuesday, October 7, 2014 5:41 PM
  • Hello,

    Check the scope of the policy by :

    http://technet.microsoft.com/en-us/library/jj150503(v=exchg.150).aspx


    Thanks,

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Simon Wu
    TechNet Community Support

    Tuesday, October 14, 2014 2:42 AM
    Moderator
  • This is the default policy - there is no scope.

    After reviewing the issue further, it does not appear that the powershell command recommended to get RPC utilization is getting the same information that is used by RCAMaxConcurrency.  I have seen some users get throttled, finally, but they have never been as close to the one user with 100+ connections.  And the one user with 100+ connections never is throttled by the policy.

    Tuesday, October 14, 2014 2:13 PM