locked
JDBC Connector crawls populated table, results in "null" value for managed properties in Sharepoint 2010 RRS feed

  • Question

  • I'm having trouble with the FAST for Sharepoint (F4SP) JDBC connector yet again.

    I used this guide for creating an XML configuration to run the JDBC Connector:  http://technet.microsoft.com/en-us/library/ff381259.aspx

    Changing only the 7 fields listed in the guide as mandatory for my config, I am able to successfully connect to a MS SQL Server 2008 R2 database and pull documents into F4SP.  However, each document contains little to no content.  Most troubling are the managed properties in Sharepoint 2010 -- these fields contain "null".  Doing the same select that is run via the connector right on SQL Server results in all 78 rows returned with data.  New crawled properties appear in Sharepoint 2010 and are successfully mapped to their respective managed properties.  If I query the index on the query node HTTP interface (http://localhost:13280/), I see the following output for each document:

    <FIELD NAME="jdbccontent">null</FIELD>

      <FIELD NAME="jdbcsource">null</FIELD>
      <FIELD NAME="jdbcuser">null</FIELD>
      <FIELD NAME="jdbcclient">null</FIELD>
      <FIELD NAME="jdbcserver">null</FIELD>

    The fields above are managed properties.  After creation I reran the connector to ensure values get populated.  The database columns that correspond to these managed properties definitely contain data other than "null".

    I've tried deleting my managed properties and remapping manually.  I've tried tinkering with the XML config, publishing the results of the SELECT statement to XML -- these files also contain nulls in the above fields.  It seems as though the JDBC connector is performing the select but loses the resultset when mapping to crawled properties, resulting in nothing going into the managed properties for query.

    Can anyone shed some light on a possible problem here?  The most frustrating aspect of this problem is that the same select and XML configuration was previously functioning.  No changes have been made to F4SP or Sharepoint 2010.  Thanks in advance.


    John Lenker
    Friday, January 7, 2011 5:49 AM

All replies

  • I would recomemnd following steps

    1. make sure that these are being extracted from database

    set ExportToXML in the connector config to true. This will create XML files with all data coming from database. These FASTXML is stored in the %FASTSEARCH%\var\jdbcconnector\<collection name>\fastxml folder. Make sure you see these values in those files. If not, there is issue with your SQL statement

    2. Make sure that these are being mapped properly

    You can use spy to analyze wht is coming into FAST using spy http://nuggets.comperiosearch.com/2011/01/spy-data-custom-pipeline-extensibility-stage-fs4sp/

    Thanks,

    Sreedhar

    Friday, March 11, 2011 9:25 PM
  • Sreedhar,

    Thanks for your reply, however I don't think this is the answer.  I've already tried exporting to XML which resulted in the XML files also containing "null" for the fields in question.  I doubt there is a problem with the SELECT statement either, please see my original post:
    "I've tried tinkering with the XML config, publishing the results of the SELECT statement to XML -- these files also contain nulls in the above fields. "

    " Doing the same select that is run via the connector right on SQL Server results in all 78 rows returned with data."

    Since the native JDBC connector was completely unreliable in F4SP, we wrote our own solution and abandoned any further pursuit of this.  I haven't revisited it as a result, but if I do I will try the spy stage.

    Thanks,

    John


    John Lenker
    Monday, March 14, 2011 3:11 PM
  • Hi John,

    I am not sure how much spy stage will help, as you are not getting data from the connector itself.

     I am sure you must have already tried this.

    1. Did you execute the query on SQL server with the same user that you used in the conenctor configuration?

    2. Can you set ChangeDetection -->enabled as false and run the conenctor again. This will do full crawl.

    If you found the root cause, can you please update this page with that.

     

    Thanks

    Sreedhar

    Monday, March 28, 2011 3:14 AM