none
Differences Report - Failed to generate

    Question

  • Just installed this great tool, but one item is not working: Differences Report.

    Neither HTML or XML. Both give the same error when comparing two items:

    "Failed to generate a HTML GPO difference report.

    The following error occured:

    Value cannot be null.

    Parameter name: input

    System.ArgumentNullException (80004003)

    My account is in the admin role. 

    Tried uninstalling/reinstalling client.

    Rebooting client.

    The items I'm choosing do have differences and running Settings reports gives me no issues.

    Any thoughts?

    Wednesday, August 19, 2015 8:11 PM

Answers

All replies

  • Update:

    Created two new GPOs with AGPM. 

    Compared these two GPOs with Differences Report and it worked.

    Then started choosing GPOs at random. Some work and some give the 'null' error above.

    Appears something about certain GPOs it doesn't like but I have no idea what it is. Kind of annoying....


    Wednesday, August 19, 2015 8:48 PM
  • Have the same issue on fresh install of AGPM 4.0 SP3. I could not find a resolution on the net so opened up a case with MS, will post results when they get back with me.

    UPDATE:

    Worked with MS on issue yesterday, they contacted me today to let me know they are able to reproduce the problem in their lab and are working on a fix, they are going to contact me on Monday.

    UPDATE 2:

    MS Support just called (8/26), they are having to escalate the issue to the AGPM product team, he informed me it may take some time to resolve, will update when I hear back from them.

    • Edited by Chief F-15 Wednesday, August 26, 2015 2:33 PM
    Thursday, August 20, 2015 1:46 PM
  • An MS case. How novel!

    Thanks, Chief.

    Thursday, August 20, 2015 6:45 PM
  • Progress!

    I eagerly await the result.

    Thanks!

    Tuesday, August 25, 2015 6:15 PM
  • Anything new from Microsoft Support?

    Brandon
    MDOP for IT Professionals on TechNet

    Tuesday, September 1, 2015 7:59 PM
    Moderator
  • MS just called me on 9/3 to let me know they are still working on it, nothing new yet :( 
    Friday, September 4, 2015 1:19 PM
  • Thanks for keeping us updated.
    Tuesday, September 8, 2015 9:16 PM
  • 9/11 FYI MS called to "give me an update that they have no update at this time and will call me back when they have an update" lmao sad but funny...
    Friday, September 11, 2015 2:59 PM
  • 9/11 FYI MS called to "give me an update that they have no update at this time and will call me back when they have an update" lmao sad but funny...
    I'm laughing and crying at the same time....on the inside.
    Friday, September 11, 2015 3:07 PM
  • Received the weekly we are still working on the issue email from MS, will post as I get updates :(
    Friday, September 18, 2015 11:01 AM
  • Indeed, we are actively investigating this.   Currently we're root causing the customer data we've received thus far.   I'll update here as I have new status to report.
    Wednesday, September 30, 2015 1:38 PM
  • Just received an update from Microsoft, below is a temp fix, I have not tried it yet but will in the next couple days. Hope this helps!!

    I wanted to update you that we have filed an internal Bug for the issue you are facing, however there is a workaround to fix this.

    You need to rollback to AGPM Client to sp2 and this can be done as written below :-

    1. Recorded configuration information for the service and server

    2. Stop the AGPM service

    3. Copy the archive folder for backup purposes - Back Up the Archive

    4. Uninstall AGPM Client and Server components installed on the server

    5. Install the AGPM Server giving it the configuration information saved earlier and use the same Archive location

    6. Install the Client specifying the AGPM server information and archive location used for the previous install - Move the AGPM Server and the Archive.

    7. On other client machines need to uninstall AGPM Client for SP3 and put back on the SP2 one and configure for server

    Post this the state of the archive should be maintained and you should be able to run the Differences report successfully again.


    • Edited by Chief F-15 Wednesday, October 7, 2015 7:43 PM
    Wednesday, October 7, 2015 5:46 PM
  • Thanks, Chief!

    I have to say that is rather disappointing. At least there is a way to resolve it. I will likely hold on doing that as SP3 is now spread too far to make sense to roll it back just for this feature. 

    Wednesday, October 7, 2015 8:49 PM
  • Well that's pretty depressing...

    I found this page having done a clean install of AGPMsp3 to a test domain. It only has 6 group policies in it, and we ran into this exception straight away.

    Wow.. it's not like this domain has been around since NT4 or anything, so I'm pretty stunned.

    Here's hoping they fix it soon! Could do with a bit of testing before releasing next time, eh folks?

    Thursday, October 8, 2015 3:54 PM
  • Would seem like a fairly basic functional test was missed :)
    Wednesday, October 14, 2015 11:00 AM
  • Would seem like a fairly basic functional test was missed :)
    Agreed, it took me a couple hours of testing to find this bug. Is there a link to the bug report from Microsoft? It would be great to know as soon as there is a fix released for this. Thanks.
    Thursday, October 15, 2015 2:22 PM
  • The bug report is internal only.

    We will update this thread as soon as we have more information to ETA for a fix.

    Friday, October 16, 2015 8:33 PM
  • Hi,

    I have the same issue and I am wondering if you need more customers reporting this to Premier Support?

    Regards

    Anderz

    Monday, October 19, 2015 9:26 AM
  • @Anderz

    We actually have multiple customers who have opened cases with us regarding this issue, so data is plentiful.

    Thanks for reaching out!

    Monday, October 19, 2015 12:16 PM
  • Same issue here with SP3.  I was also getting an ACCESS_DENIED error of some sort when trying to check in a GPO.  Reverting to SP2 was very easy.  The service even retained the user account info I was running it as.
    Tuesday, October 27, 2015 8:03 PM
  • Any update on this?
    Wednesday, November 11, 2015 8:45 PM
  • Having the same issue here, affecting a large university hospital installation. Can't rollback hundreds of GPO's.

    Any further word?

    Thursday, November 12, 2015 1:36 PM
  • A candidate fix has been identified and is under review.

    We have no ETA as of yet.

    Friday, November 13, 2015 8:09 PM
  • Test fix is currently being tested internally.
    Tuesday, November 24, 2015 6:56 PM
  • Hi,

    I have the same issue

    Thursday, December 3, 2015 1:13 PM
  • Test fix has been verified to fix diff report failures.  

    Now fix is undergoing full integrated test suite.  This should be completed within a week.

    After this we should have ETA on a public release.

    Stay tuned.

    Monday, December 7, 2015 3:17 PM
  • Test fix has been verified to fix diff report failures.  

    Now fix is undergoing full integrated test suite.  This should be completed within a week.

    After this we should have ETA on a public release.

    Stay tuned.

    Monday, December 7, 2015 3:18 PM
  • This sounds great!
    Tuesday, December 8, 2015 7:08 AM
  • Any word on this yet?  I need something quick or will have to start my rollback this afternoon.

    Alexis Bor

    Wednesday, December 16, 2015 6:54 PM
  •  I try to install the Hotfix on Windows 2012 R2 and I get a error "The package is supported on window server 2008,windows server 2008R2"  any idea ?

    Ronen

    Thursday, December 17, 2015 1:01 PM
  • Testing is now complete.

    KB is being written up and run through our content review process.

    The new version is imminent, although I can still not provide an exact date.

    Please continue to watch this thread for updates.  

    I will certainly notify as soon as this goes public.

    Again, thanks for everybody's patience!

    Thursday, December 17, 2015 9:33 PM
  • The fix is now available at

    https://support.microsoft.com/en-us/kb/3127165

    Folks, thanks again for your patience and understanding!

    Monday, December 21, 2015 6:40 PM
  • Thanks a lot!

    It works great on Server 2012!

    Happy new year!

    Tuesday, December 22, 2015 8:58 AM
  • Great, Thank You!

    Prerequisites:

    To apply this hotfix, you must already have Microsoft Advanced Group Policy Management 4.0 SP3 installed on the server.

    First, uninstall Microsoft Advanced Group Policy Management 4.0 SP3, and then install this hotfix.

    Now, what's that supposed to mean? Do I first install 4.0 SP3 and then uninstall it before installation of HF?


    • Edited by woodrapp Tuesday, December 22, 2015 9:30 AM
    Tuesday, December 22, 2015 9:28 AM
  • Uninstall first AGPM 4.0 SP3 is not necessary. We just install hotfix and it works.... with no reboot

    Tuesday, December 22, 2015 10:46 AM
  • Ugh!

    Working on clarifying that KB.

    Either way should work (uninstall and reinstall, or install on top).

    But recommend just uninstall any existing AGPM and installing from hotfix URL given above.   The hotfix is really the entire AGPM package.

    Sorry for the confusion!

    Tuesday, December 22, 2015 5:26 PM
  • Thanks for the post and clarification.

    Will try after the holidays. In "read only" mode until then.

    One note, it would great if the Build number for AGPM 4.0 SP3 is mentioned in the article (and will that iterate to an new build number?). I assume it's 4.3.160.0, but a quick search doesn't make that obvious. Only found that SP2 was 4.2.22.0.

    Tuesday, December 22, 2015 5:44 PM
  • New build is 4.3.166 on this hotfix, BTW.

    Installed and Difference Reports are now working for me.

    Thanks, tfair!

    Wednesday, January 6, 2016 4:20 PM
  • Hi,

    Thx, installed and Difference Reports work here as well!

    Best regards

    Monday, January 18, 2016 7:43 AM
  • Link is no longer available. Can you send another link pls? Thanks!
    Tuesday, May 3, 2016 2:16 PM
  • What happened to the hotfix? Link no longer works...
    Wednesday, May 4, 2016 6:04 PM
  • Link is now working today
    Monday, May 9, 2016 3:40 PM
  • Link is still not working. Anyone have a working link? Thx.
    Thursday, July 7, 2016 6:46 PM
  • Here's a temporary link. All I have is the x64 copy still.

    https://www.dropbox.com/s/zk50poly1qtt6oe/agpm4.0-Server-KB3127165-x64.exe?dl=0

    Thursday, July 7, 2016 6:51 PM
  • This Hotfix when you click to download says "This page cannot be found". Do they have a newer one? We just applied SP3 and now our differences are BROKEN and we use them daily. Please let me know.

    https://support.microsoft.com/en-us/hotfix/kbhotfix?kbnum=3127165&kbln=en-us

    Sorry, the page you requested is not available.

    The page you were looking for is currently not available. The address may not be correct, or there may be a temporary problem with this site. Please try one of the following options:
    • Check the address for typing errors.
    • Click the Back button and try a different option from the navigation menu.
    • Try this page again later.


    lforbes

    Friday, July 8, 2016 4:13 PM
  • This Hotfix is not available when you click on the link? It says Page cannot be displayed? Can you post the correct one?

    lforbes

    Friday, July 8, 2016 4:19 PM
  • I got the same error (page not found), but then tried again and it worked.

    So something weird *is* going on, but, you should be able to get it.

    The final page where I enter my email address is:

    https://support.microsoft.com/en-us/hotfix/kbhotfix?kbnum=3127165&kbln=en-US

    Wednesday, March 15, 2017 11:19 AM
  • Hi, sorry to bother you, but i'm facing this same issue rigth now and the link provided by MS is not working anymore. So, do you still have a copy of this file? Thx
    Monday, September 17, 2018 8:34 PM
  • https://blogs.technet.microsoft.com/yongrhee/2017/12/08/mdop-hotfixes-agpm-4-0-sp3-app-v-5-1-mbam-2-5-sp1-ue-v-2-1-sp1/ Not sure it works still but try it. We applied it and it fixed our server but the server guys got it from Microsoft. I don’t have the file.

    lforbes


    • Edited by lforbes Tuesday, September 18, 2018 3:32 AM
    Tuesday, September 18, 2018 3:28 AM