locked
Drill to Detail greyed out for users RRS feed

  • Question

  • Hello,

     

    My end user is opening a cube via the web professional.  She can see the cube, dimensions, etc. just fine.  The problem is when she tries to right click to "Drill to Detail", the option is greyed out.  What would I need to change to enable this feature for her?  The feature works for me but I'm an admin on that server.

     

    Thank you,

    Tom Philbrick

     

    Tuesday, February 26, 2008 5:18 PM

Answers

  • I'm assuming you're using SSAS 2005, but if you happen to be working with AS 2000 things are a bit different so let us know.

     

    For SSAS, here is an excellent article on exactly what you are looking to do.  Take a look and let us know if you have questions.  http://technet.microsoft.com/en-us/library/ms345125.aspx

     

    Also, you might try adding the user explicitly to the role just to be sure you aren't running into an issue with security group resolution.

     

    If you're convinced things are set correctly on the Analysis Services side, it is possible the user may have some security set in PAS that would disallow drill to detail.  Try adding them to the PAS admin role and see if that resolves it.  This would just be a quick test to see if their role was not set to allow drill to detail.  Also, check the publishing properties for the book they're opening to be sure that book doesn't have drill to detail disallowed for it.  For more info on publishing properties, begin with page 58 in the Admin Guide.

    Tuesday, February 26, 2008 11:28 PM

All replies

  • Hi Tom,

     

    What you'll want to do for that is grant drillthrough permission on the user's SSAS security role: http://technet.microsoft.com/en-us/library/ms177198.aspx

     

    hth

    Tuesday, February 26, 2008 7:25 PM
  • Hello Sean,

     

    Sorry, no go, she still doesn't have the drill to detail enabled.

     

    In SSAS, I set the the role to have drillthrough.  The user is not in the role explicitly, I am using 'Everyone'.  Is there somewhere else I can set this?  I only restored the cube into SSAS into the server, the source tables that the cube was built from are on another server if that is of issue?

     

    Thanks.

    -Tom

     

     

    Tuesday, February 26, 2008 10:54 PM
  • I'm assuming you're using SSAS 2005, but if you happen to be working with AS 2000 things are a bit different so let us know.

     

    For SSAS, here is an excellent article on exactly what you are looking to do.  Take a look and let us know if you have questions.  http://technet.microsoft.com/en-us/library/ms345125.aspx

     

    Also, you might try adding the user explicitly to the role just to be sure you aren't running into an issue with security group resolution.

     

    If you're convinced things are set correctly on the Analysis Services side, it is possible the user may have some security set in PAS that would disallow drill to detail.  Try adding them to the PAS admin role and see if that resolves it.  This would just be a quick test to see if their role was not set to allow drill to detail.  Also, check the publishing properties for the book they're opening to be sure that book doesn't have drill to detail disallowed for it.  For more info on publishing properties, begin with page 58 in the Admin Guide.

    Tuesday, February 26, 2008 11:28 PM
  • Hello Ben,

     

    I'm not sure if adding my user explicitly resolved the problem or not, but, she can see the drill to detail... I found out she was using a different computer to get the cube data from.

     

    Thank you for your help!!

     

    -Tom

     

     

    Wednesday, February 27, 2008 12:02 AM