locked
Appv5 and Windows 10 RRS feed

  • Question

  • Hi,

    I've installed AppV5 SP3 infra all working fine with Win7/8 and W2K8R2/W2K12R2. Now i'v'e installed Win10 installed the App-V client on it with KB3060458 hotfix on top of it. When trying to sync the app-v publishing server i'm getting the following error in my network trace.

    Un-supported client OS passed in: WindowsClient_10.0_x64

    And in the eventlog i'm getting

    Getting server publishing data failed.
     URL: http://<appvmgmtsrv>:<port>/
     Error code: 0x45500D27 - 0x801901F4

    Any idea how to get this fixed?

    As said all apps works fine on other OS.

    thanks for any feedback.

    Chris


    Wednesday, August 5, 2015 9:10 AM

Answers

  • The most awaited App-V 5.1 is out now. It supports Windows 10 32/64 bit now.

    Source - https://technet.microsoft.com/en-us/library/mt346500.aspx

    It clearly states App-V 5.0 will not support Windows 10, only App-V 5.1 will do.


    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you. )

    • Proposed as answer by yuvakkr Tuesday, August 18, 2015 7:47 AM
    • Marked as answer by ChrisDJ Tuesday, August 18, 2015 11:34 AM
    Tuesday, August 18, 2015 7:11 AM
  • I've downloaded it and it is indeed working as expected.

    :-)

    • Marked as answer by ChrisDJ Tuesday, August 18, 2015 11:34 AM
    Tuesday, August 18, 2015 11:09 AM

All replies

  • Is the App-V server up to date? If not update hotfix for the App-V Server.


    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you. )

    Wednesday, August 5, 2015 11:06 AM
  • And which hotfix you refer to?

    i'm on 5.0.10.107.0 at the moment for the mgmt server.

    • Edited by ChrisDJ Wednesday, August 5, 2015 11:24 AM
    Wednesday, August 5, 2015 11:11 AM
  • yes, its the latest version.

    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you. )

    Wednesday, August 5, 2015 11:48 AM
  • This is what i've found as well.

    Viewing App-V Server Publishing Metadata (https://technet.microsoft.com/en-us/library/dn858694.aspx).

    In the table Windows 10 is missing.

    Wednesday, August 5, 2015 12:24 PM
  • The latest version supports only till win 8.1 as of now. Have to wait and see for any new updates regarding to windows 10.(Though I am not sure)

    I tried standalone method and it works fine in windows 10.


    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you. )

    • Proposed as answer by Roy Essers Wednesday, August 5, 2015 9:51 PM
    Wednesday, August 5, 2015 1:55 PM
  • Vignesh is Right. As of now there is No Official support to Windows 10 with the current versions of AppV. Though applications sequenced will work with Windows 10 when deployed standalone.

    Below is the image that I've got from MSIgnite Session which states that Windows 10 compatibility is added in the upcoming release of AppV which is 5.1. Have to wait for the next release of MDOP.

    Wednesday, August 5, 2015 5:17 PM
  • I found the root cause of why my Windows 10 client was not able to retreive the apps from my publishing server.

    It's related to KB3060458. After installing this Hotfix 2 pack for AppV 5.0 SP3 the ClientOS variable that is send towards the Publishing server (since SP3) is updated and not recognized by the Publishing serve (yet).

    See below the two Get commands i've traced via Wireshark.

    SP3 Patched with KB
    GET /?ClientVersion=5.0.10321.0&ClientOS=WindowsClient_10.0_x64 HTTP/1.1 

    SP3 Standard without KB
    GET /?ClientVersion=5.0.10107.0&ClientOS=WindowsClient_6.3_x64 HTTP/1.1

    As you can see wiht the HF2 the ClientOS variable is changed to WindowsClient_10.0_x64 while it was WindowsClient_6.3_x64 without the HF. Removing the HF on my Win10 client solves my issue and i'm able to start all my AppV based apps I have.

    Now I'm wondering if MS has a HotFix for the Publishing server to so that the new ClientOS variable WindowsClient_10.0_x64 will be accepted.

    Thanks for any feedback.

    Chris

    Thursday, August 6, 2015 12:28 PM
  • No, as of now there is no updated HF for Publishing server.Haven't heard about Microsoft releasing it too (Need to research more)

    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you. )

    Thursday, August 6, 2015 2:24 PM
  • Add this issue at the HF2 SP3 blog site as well.

    Hoping to get feedback soon.

    http://blogs.technet.com/b/appv/archive/2015/05/27/hotfix-package-2-for-microsoft-app-v-5-0-service-pack-3-is-now-available.aspx

    Thursday, August 6, 2015 2:55 PM
  • Hope Microsoft will look into this soon. Or we have to wait for App-V 5.1.

    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you. )

    Thursday, August 6, 2015 4:55 PM
  • Let's hope indeed. it seems that they not activily monitoring here :(
    Monday, August 10, 2015 9:05 AM
  • According to Michael Niehaus in yesterday’s Preparing Your Enterprise for Windows 10 as a Service, “in the coming days”.

    Brandon
    MDOP for IT Professionals on TechNet

    Friday, August 14, 2015 9:09 PM
    Moderator
  • The most awaited App-V 5.1 is out now. It supports Windows 10 32/64 bit now.

    Source - https://technet.microsoft.com/en-us/library/mt346500.aspx

    It clearly states App-V 5.0 will not support Windows 10, only App-V 5.1 will do.


    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you. )

    • Proposed as answer by yuvakkr Tuesday, August 18, 2015 7:47 AM
    • Marked as answer by ChrisDJ Tuesday, August 18, 2015 11:34 AM
    Tuesday, August 18, 2015 7:11 AM
  • I've downloaded it and it is indeed working as expected.

    :-)

    • Marked as answer by ChrisDJ Tuesday, August 18, 2015 11:34 AM
    Tuesday, August 18, 2015 11:09 AM
  • but as mentioned it all works fine until you install HF2 for Appv5 SP3.
    Tuesday, August 18, 2015 11:10 AM