locked
Vista Business and AMD Turion 64 RRS feed

  • Question

  • Trying to resolve my problem, but not sure where problem really lies.

    Have installed Vista on a Fujitsu-Siemens Amilo A 1630 notebook.   All went well and everything is working but noticed it shows processor as AMD Tution (mobile) 64 3400+ which is correct but shows frequency as 800MHZ which is not correct.

    It doesnt matter what power mode I choose it stays the same.

    You cannot install the XP AMD Powernow software which did the same thing as the vista power software and did work on XP.

    Cannot see any drivers on AMD sites or Fujitsu Siemens.

    I dont particulalrly care about power saving mode, I just want my laptop performance back.

    Any ideas anyone.

     

     

    Sunday, February 4, 2007 1:45 PM

All replies

  • Hi

    I have exactly the same laptop a fujitsu siemens A1630 but i have an athlon 64 3700+  and i'm having the same problem with windows vista home premium edition. have you found a solution yet?

    i did find a work around by downoading a program called ( crystalcpuid ) i was able to up the processor voltage to 1.50v and adjust the multiplier to 12.0 this allowed the processer to function properly but you have to load the software each time you load windows. if i can do it then surely AMD/MICROSOFT must be able to do something

    B.T.W i went into pc world and had a look at some AMD pc's that had windows vista pre-installed and they where exactly the same and they where having problems with customers bringing pc's and laptops back.

    Come on Microsoft and AMD you had the same problem with windows xp why are we still waiting for this to be sorted when it should have been sorted long before realease

    NOT A HAPPY MICROSOFT CUSTOMER AT THE MOMENT!!

    Sunday, February 11, 2007 8:18 PM