IE10 wont allow me to open FTP files in Explorer View RRS feed

  • General discussion

  • I have an FTP internally that is used to host PDF & HTML files. Previously all users could log onto this FTP site and double click on any file content to have it open within the default browser. We use FTP in explorer view so each user can set their terminals to save their passwords, hence they log straight into their root folder on the FTP - if we use the FTP list view in the browser this doesnt happen, meaning user 9999 has a long way to scroll to find their documents!
    This has always worked absolutely fine until IE10 has been installed, now any user with IE10 cant open files straight from the FTP via the Explorer view. The file doesnt download, the destination file ends up at 0KB so just doesnt open in the browser. Roll back to IE9 fixes the problem. Using Chrome as the default browser fixes the problem. Using the FTP list view also works fine (however we cant use this since it wont default to users root folder that they have access to)
    Ive attempted everything i can think of without luck, its looking like we're going to have to block IE10 or switch to Chrome. Basically opening files from any FTP site (have tested others) in explorer view with IE10 installed just isnt working. You can however copy the document to the local machine then open ok..
    Any ideas, what am i missing here!?
    Tuesday, April 2, 2013 1:55 PM

All replies

  • Hi,

    assuming windows 7....

    PDF viewers in IE are ActiveX controls. Chrome has its own native pdf plugin.

    to configure Adobe Reader not to use IE (other browsers ignore this adobe setting)

    Start>Adobe Reader>Edit>Preferences>Internet>uncheck "Display PDF in browser"

    Windows explorer uses file associations to match and opener program with a file extension.

    You can use Group Policy to ensure that the default opener for pdf extensions is adobe and not chrome.



    Wednesday, April 3, 2013 12:57 AM
  • Yes Mark, same problem. It's not the Active X PDF viewer as mentioned in this thread. We use .txt files and when you double-click on one in Windows Explorer FTP Folders, what normally just opened in IE 9 and below, now just show a blank screen.

    Uninstalled IE 10, and IE 9 was available as before and works normally.

    So to recap the issue:

    Windows Explorer - FTP Folders in use for normal FTP access.

    Double-click - in my case a txt file, a blank IE 10 screen opens.

    Uninstall IE 10, IE 9, works as expected, txt file opens in browser.

    I thought I saw the file was downloaded into the temp folder correctly, but just didn't display. That's not what Mark said but I can't confirm that at the moment.

    Sunday, April 7, 2013 10:35 PM
  • I have the same issue - any resolution



    Friday, April 19, 2013 1:37 PM
  • I have the same issue - any resolution

    FTP servers are now being locked down and no longer allowing anonymous access.  is an example.

    You could try using  explorer.exe  instead of  iexplore.exe  to access it.   Trace a problem symptom with a TCP protocol analyzer such as NetMon or WireShark and refine your symptom description. 

    BTW "same issue" doesn't give anyone much to hang new comments or suggestions on.   ; }


    Robert Aldwinckle

    Friday, April 19, 2013 3:22 PM
  • BTW - your answer doesn't help, nice try!! It is an IE10 issue not a FTP issue, since it worked fine on IE9 and not on 10

    I am trying to find an answer - we have the same exact  issue as Mark Nanason, so far all I have found is uninstall IE10 - which is not an option for us


    Friday, April 19, 2013 5:14 PM
  • It is an IE10 issue not a FTP issue, since it worked fine on IE9 and not on 10

    Then try my suggestions for diagnostics.
    Saturday, April 20, 2013 3:18 PM
  • At least we know someone is reading this...

    There has been no change in my FTP access, it works the same as always, BTW, I'm not logging in anonymously.

    The FTP login is handled by Windows Explorer (not Internet Explorer), then double-click a file (in my case a simple txt file) with IE9 installed the file opens in IE9 (and every version before), with IE10 installed I get a blank IE10 screen.

    I've gone back to IE9 for now…

    Saturday, April 20, 2013 7:07 PM
  • There has been no change in my FTP access


    is working (in IE10 on W8).   YMMV.

    However, ICIM, I first opened it in Windows Explorer.


    Saturday, April 20, 2013 10:02 PM
  • There has been no change in my FTP access


    ms ftp link...

    is working (in IE10 on W8).   YMMV.

    However, ICIM, I first opened it in Windows Explorer.

    I think as Mark said:

    "if we use the FTP list view in the browser this doesnt happen, meaning user 9999 has a long way to scroll to find their documents!"

    Clicking the ftp link to Microsoft brings up a view similar to the 'list view' in the browser and then it does work. But when you use Windows Explorer as if you were simply looking at your files on your hard-drive (called 'web folders') we get the non-working behaviour.

    To get the behaviour we see when using your link, see "TOOLS/INTERNET OPTIONS/Advanced (Uncheck: Enable FTP folder view (outside of Internet Explorer)"


    Sunday, April 21, 2013 7:08 AM
  • Is this the same topic that was discussed a while back

    Apparently.  My FTP access problems and previous related problems just listing files using it made me miss that this is about opening a file from those directory views.


    So now, with the option 
         Enable FTP folder view (outside of Internet Explorer)
    checked  (which I had originally)

    I have seen the problem symptom trying to open

    I suspect this will be more security/obscurity.   I have captured a ProcMon trace of it but don't see anything which clearly explains the symptom.  One odd thing is that the length changes by the time that IE gets it.   E.g.  explorer.exe writes it, then MsMpEng.exe glances at it (doesn't read it?), then SearchProtocolHost.exe does read it but somehow when iexplore.exe gets it the length is 8,192?  And when I navigate to that TIF subfolder (in a cmd window) and do a dir there the length is 0:

    2013-04-21  10:07                 0 CBCP[1].TXT

    ProcMon only detected 1 WriteFile?  How is the length getting changed or where is a second write being done?


    As noted in the earlier thread, right-click Copy to Folder is a workaround.



    Sunday, April 21, 2013 3:02 PM
  • It's still ok with Vista+IE8.

    Then that might give us a useful comparison trace.  I didn't trace the Copy to Folder case but may do that some time in case there are some clues there.
    Monday, April 22, 2013 2:28 PM
  • Hi Dimitri and Robert,

    Thanks for your time.

    This may be a similar problem, but I don't think it is the same.

    This is a working Windows 7 machine, not Windows 8 first of all.

    This has been working for years also in XP too.

    Using the Add a Network Location wizard to create 'custom' location of my own website which I can access via FTP. Put in the server name, user name and password. This ends up giving you a network 'place' (Listed on My Computer under Network Locations,) when you click the link in My Computer (or Windows Explorer) it opens the site / network location in the normal file view you have with Windows Explorer, just like you were looking at your C: drive.

    You can double-click a file in the right-hand side panel, and it opens the file. I'm talking a simple TXT file.

    In ie:9 and below, Windows 7 (or XP) the file opens in a browser. (It may have opened in Notepad in XP, can't remember for sure) Anyway, Win7 is in IE.

    Simple problem, once IE 10 was installed, the file no longer displays, just a blank IE10 tab.

    I can't duplicate anymore as I uninstalled IE 10, and the problem went away, same as Mark the OP did.

    I'll keep watching this thread.


    Sunday, April 28, 2013 5:11 AM
  • "IE10 wont allow me to open FTP files in Explorer View"

    True! In IE7/8/9 this was enable in the toolbar in the upper right side of the screen, click Page > Open FTP site in Windows Explorer
    OR you could open Windows Explorer and type your ftp-address in the addressbar.

    Alternative for Windows 8:

    • [Windowsflag + R]
    • type "explorer"
    • Windows Explorer will open and show your ftp-folders once you've logged in

    I guess Dimitri Nickolas was the first to answer this


    • You could make a shortcut to open this FTP-view at once by making a batchfile
    • Open Notepad and type the command "explorer"
    • Save this file and close the file
    • Select the txt-file and rename the extension txt to 'bat'
    • From now on, when double click on this file, Windows Explorer will open and ask for your ftp-login
    • When you want to include your username and/or password, use the command "explorer" in your batchfile
    Wednesday, May 15, 2013 10:54 AM
  • OK Dimitri,

    So I now have IE:10 on my laptop. As I said previously, I reverted to IE:9 on my desktop as it works fine and as always. (Win7 btw)

    So I can confirm that setting up a Windows Explorer shortcut, then viewing the site/folders in Windows Explorer. When I double-click a .txt file in the right-hand pane, it opens notepad with the file to view which has been 'downloaded' to:

    "Users/Bubbi/AppData/Local/Microsoft/Windows/Temporary Internet Files/Content.IE5/YSAJRGCD/File Name.txt"

    That file has ZERO bytes.

    So that's what I'm confirming. I was unsure of that, as I couldn't test before, but that is confirmed from above.

    So this is not solved, still does not work.

    Here's how you can create the FTP shortcut:

    (I'm not allowed to include links

    "http://" +

    thanks very much,


    PS: Casa, no idea what question you are answering. I don't currently see the Open FTP site option (or the Page menu) in my IE:9. I don't think this has anything to do with the problem. And discussion of shortcuts and how to make them be everyone else here is not relevant either. We are not having problems getting to the FTP site, we have shortcuts and it opens in WINDOWS Explorer (not Internet Explorer) just fine. No different win7, ie:7,8,9.10

    But once IE:10 is installed, when the normal process above is being used, and you double-click a file to view it's contents, the window opens (as normal) (Notepad or whatever is the default program for viewing that file) and a blank window opens.

    Now looking at the temporary downloaded file, it has zero bytes in it. So instead of the file contents being downloaded, a file is created by that name in the temporary folder, but no file contents are there.

    Thursday, May 30, 2013 7:58 PM
  • I had started another thread  because my problem is like yours   BUT  you are wasting time with client setting..   I too thought it was a client settings problem  BUT its not....   here is my  question

    to Microsoft 

    Within the last 5 months  something has changed  where the FTP Server  running on my 2008 R2 Standard no longer works correctly..    At first I thought it was because  I upgraded the clients to IE10 ...  I can connect to FTP SERVER and can switch WINDOWS EXPLORER View   BUT   It does not open the files correctly in View,  I can copy   and paste into the folder though...  

    I then tried Firefox, Safari, Chrome   these browsers  used to work  BUT they NO LONGER work...  So I have concluded that  some update from Microsoft  changed  some settings on my server between Jan 1/2013   and   5/30/2013..    Because  Jan 1/2013  was last time  I used my FTP server...  I have seen on web where people are experiencing problems with FTP   and help would be great!


    Sunday, June 2, 2013 2:14 PM
  • Please ignore Ron's post as far as this thread goes. It is not something to do with the 'server' (or some MS conspiricy it sounds like! ?)

    This is a Internet Explorer 10 problem.

    All was working well with IE9, upgraded to IE10, problem was there. Uninstall IE10, IE9 is immediatly available and all works well.

    Nothing at all to do with the 'server'

    Monday, June 10, 2013 7:45 PM
  • I recently ran into this issue, but I was able to fix it.  As far as I can tell, on certain machines when IE 10 gets upgraded it fails to properly update the registry.  I found two areas where there were missing keys.

    The first area and most important is:


    The second area is:


    If you grab the keys from a working machine and import it you should no longer have the problem you have.

    If you need working reg files just respond.  Otherwise a positive vote would be appreciated!

    Friday, June 28, 2013 6:47 PM
  • Can you send the .reg files? - I have no machines that work, all have IE10 and all cannot open FTP from the folder view
    Saturday, June 29, 2013 2:33 PM
  • @ ABC123456789abc

    Alternatively could you tell us where you got the exports?  E.g. Dimitri has already shown it is not just an IE10 or W7 or W8 issue.  So, perhaps it is necessary just to back off a security patch?

    Robert Aldwinckle

    Sunday, June 30, 2013 3:36 AM
  • I have no machines that work, all have IE10 and all cannot open FTP from the folder view

    Can you distinguish any difference based on the file type being opened?

    FWIW here is the simple case that I am trying to understand:

    Used like that, it works, e.g. opens in IE but doesn't if I try to navigate there using WFE.  Now in IE11 on W8.1 ICIM but previously seen with IE10 on W8 and the analogous symptom with IE10 on W7.


    Robert Aldwinckle

    Sunday, June 30, 2013 3:49 AM
  • II don't know what I'm doing wrong here?

    I'm the one keeping the conversation on track here by testing things and reporting that they don't work, and then the questions seem to be directed elsewhere? Keep in mind the OP hasn't posted since the OP.

    I just tried the .reg files from a known good (IE9 machine) added to another win7 machine with IE10 installed and the results are the same. So that did not fix the issue.

    So, once again, back to the problem. I don't know about IE11, only IE10, and Robert seems to throw the discussion off by taking Dimitri's explanation as gold?

    It IS an IE10 problem for me on three machines I've tried it one so far. Two win7 machines and a win8 machine.

    I only uninstalled IE10 on the win7 machines.

    Once again... win7, IE9, all is well, upgrade t IE10 does not work, simply uninstall IE10, which rolls you back to IE9 automatically all is well.

    Again, this starts from WINDOW Explorer (not IE). You establish an FTP login using Windows Folders and Windows Explorer. Access your FTP site (via Windows Explorer) double-click a file, like a text (.txt) file, with IE9 installed, the file opens in IE9 and all is well. With IE10 installed, with the double-click (in Windows Explorer) a zero byte file is saved to the temp folder and that file is opened in IE10. Of course there is nothing displayed as the file is empty. (With IE9 installed the full .txt file is downloaded on the double-click).

    Thanks for trying people, still looking for the fix.

    BTW: with IE10 you CAN right-click the file (from Windows Explorer (FTP)) and select "Copy To Folder..." and it downloads the full file to the folder of your choosing. I just doesn't download the file from a double-click / default type action (Windows Explorer).

    Monday, July 1, 2013 6:09 AM
  • Sorry for the delay I was on vacation.

    Here are the two reg files I used to fix the issue.

    I believe the first one is more important than the second.

    The first:

    Windows Registry Editor Version 5.00

    "Source Filter"="{E436EBB6-524F-11CE-9F53-0020AF0BA770}"
    @="URL:File Transfer Protocol"
    "URL Protocol"=""




    @="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" %1"

    The second:

    Windows Registry Editor Version 5.00

    "Use PASV"="yes"
    "Use Web Based FTP"="no"

    If that still does not get you up and running just post back here and I can help you dig into the issue further.

    Wednesday, July 10, 2013 2:28 PM
  • You can also get this issue if you have two browsers loaded. Firefox will over write the FTP registry.
    Friday, July 12, 2013 2:39 PM
  • Solved.

    Thanks.  That has been bothering me for months.

    Monday, August 19, 2013 10:35 PM
  • Which solution did you use?  Please remember to vote.


    Friday, August 23, 2013 6:50 PM
  • Solved.

    Thanks.  That has been bothering me for months.


    Still same old deal, double click a file open in FTP folders using IE:10, you download a zero byte file which then opens (and shows a blank screen)

    IE9 and below, works fine.

    Found a good write-up explaining this:

    You'll need to copy and paste this link in as even though I've had the same email address with Microsoft for 15 years, I can still not post a link on this forum so had to omit the http:// on this below:

    By the way, as that article indicates you CAN drag and drop from the very same Windows Explorer FTP Folders view onto your desktop, and the file downloads as expected, then you can double-click and on it and open the file, but that is a lot of clicking. Previously in IE9 and below, a simple double-click directly on the file in Windows Explorer FTP Folders view opened the file. (ie: downloads the file to a temp directory and then opens it in Internet Explorer)

    • Edited by Bubbi Smith Saturday, September 7, 2013 8:09 PM
    Saturday, September 7, 2013 7:48 PM
  • Has anyone solved this issue yet?
    Sunday, October 6, 2013 10:44 PM
  • Have this exact same problem after upgrading to IE10 (or IE11)

    Can't open files direct in Windows Explorer from FTP sites. Have to download them manual to my desktop to open...

    Any solution to this?

    Tuesday, October 29, 2013 11:06 AM
  • I did a few things to make this work in my office.

    1.  added my server name to the compatability view settings.

    2.  went to HKEY_CLASSES_ROOT\.TXT and changed to content type to nothing (leave this blank)

    3.  I changed the default program for .txt to use Wordpad saved and then changed it back to Notepad.

    Try each one of these seperate I have had some machines work with just the compatability setting.  Test this in IE first and then try it in Explorer.

    Tuesday, November 5, 2013 11:13 PM
  • This bug is driving me mad too. I noticed it on IE10 and was hoping that IE11 would fix it but when I downloaded it to my windows 7 machine yesterday the same problem exists. I raised the bug via MS connect and whilst they acknowledged it  they said 'no plans to fix this in the forthcoming release'. I guess they refer to IE11 but I wonder if this will ever get sorted out. Like everyone else, rolling back to IE9 all is well again.

    I detest IE10 and IE11 with a passion but we cannot stay on IE9 forever, already major players like Google are dropping support for it. So the update to IE11 is kind of pushed on us. I don't mind new versions introducing new features but when existing functionality gets broken I find it pretty unacceptable (especially when they show no interest in fixing). I'd rather the FTP explorer view worked than MS put all their efforts into trying to render a page a millisecond faster than Chrome.

    I even have issues with some web pages responding slowly (accessing internal Web UI for things like my router and NAS drive) and then as soon as I use inprivate browsing all is well. Those are in the minority but IE10/11 are pretty dissapointing in my eyes. This FTP issue being the worst offender!

    I kind of feel IE10/11 are backwards steps and really were just change for the sake of change at Microsoft. IE9 was solid and working great. Trouble is they are all it now, MS, Apple (with iOS7 and iTunes11). Messing with things that worked very nicely and breaking existing functionalities all because they think everyone wants change. If it ain't broke, don't fix it Microsoft!!!!



    Friday, November 8, 2013 10:45 AM
  • Hello,

    exactly the same issue now that IE10 (or 11) is deployed. Opening an FTP site in Windows Explorer (not iexplore.exe) is required in our environment, so you can actually create or delete files in the FTP folder.

    Double-clicking on a file in an FTP folder with IE9 just downloaded the file to the temp folder and opened the appropriate application (i.e. PDF reader for .pdf file). IE10 and IE11 download a 0kb file into the temp folder and then the application understandably cannot make much sense of an empty file.

    As an annoying workaround our users now have to copy the file onto a local/network disk (i.e. drag and drop from the FTP folder onto the desktop). From there the file can be opened by its default application again.


    IE10/IE11: Annoying and unproductive with FTP - Microsoft should really get to fix things they broke.

    Friday, January 10, 2014 10:27 AM
  • Hi MM,

    This thread has been going since April, no word AFAIK from MS on this. They broke the FTP in ie10 and ie11 continues the bad tradition. And now ie11 has really broken more FTP that is affecting clients all over the word, check this ms thread (at least for that MS has acknowleded they are looking into it)FtpOpenFile and

    I've been on this thread for almost a year, have the same MS address for 16 years, and still am not allowed to post a link: Google this, it will take you right there:

    InternetWriteFile broken/changed in IE11

    Saturday, January 11, 2014 10:07 PM
  • Works fine for me.

    Mike Ma
    Friday, March 7, 2014 5:40 AM
  • Google this, it will take you right there:

    InternetWriteFile broken/changed in IE11

    BING showed me a Connect page.  Is that what you found?

    Today, you may be able to use  Alt-H, A  and click on the maintenance level in there to find

    and do an  F3  for FTP--and Enter--twice.

    Robert Aldwinckle

    Friday, March 7, 2014 2:04 PM
  • The recent IE 10 cumulative security update appears to have fixed this "files on FTP site not opening properly when in Explorer view" issue on a Win 7 SP1 Ent x64 PC we have. Thanks to Microsoft for finally addressing the issue.
    Wednesday, March 26, 2014 4:52 PM
  • NOPE!

    I don't get why people love posting this stuff is fixed. Either you aren't bother trying what is wrong, or you have some 'issues' is the nice word, just to be the one to kiss arse to MS and be the fixer person.

    TWO THINGS ARE INVOLVED HERE - you understand that, no?

    First you log into an FTP site using WINDOWS EXPLORER. (using 'ftp folders')

    Then double-click a file, in my case it's a .txt file, someone else above reported other types.

    The file then should open in IE:(11) and display.

    This second bit, the displaying of the file works with IE:9 and was broken in IE:10 and 11.

    With any of the above the IE is opened from the double-click of WINDOWS Explorer, in 9 the file displays in 10 and 11 INCLUDING AFTER THIS LATEST UPDATE a blank page continues to be displayed.

    Friday, April 4, 2014 12:39 AM
  • I had the same issue and resolved it by using Firefox to open FTP 

    Control Panel -> Default Programs -> Associate a file type or protocol with a program

    Search FTP protocol assign Firefox or Chrome

    Tuesday, April 29, 2014 12:27 PM
  • Drag and drop the file from the explorer window to the ie window.


    delete the value name





    Wednesday, April 30, 2014 8:24 AM
  • Have just successfully tested removing the DelegateExecute registry value on 3 machines running IE10 all experiencing this issue.

    This has resolved the issue for me and my company.


    Tuesday, May 27, 2014 5:20 AM
  • It appears that removing the DelegateExecute DOES WORK! Woo-hoo...

    A solution after a year... :-)

    Thanks very much.

    Remove DelegateExecute from:

    Tuesday, May 27, 2014 11:03 PM
  • So the only downside with the current solution (and it is working so that is the main thing) but now instead of opening files in tabs a new instance of IE:11 is opened for each file.

    Other than the obvious TOOLS/Internet Options/Tabs, does anyone know a solution to this?

    Thus double-clicking an FTP folders .txt file using Windows Explorer (FTP Folders) each file opens in it's own IE. Selecting multiple .txt files and pressing Enter (in Windows Explorer FTP Folders) opens each selected file in it's own IE:

    Tuesday, June 24, 2014 6:43 PM
  • I'd agree that a series of "same issue" posts isn't all that useful and does clutter up the post, the first couple do help confirm that it's not just user error or some strange edge case when you drop into a post from a web search.  my 2 cents anyway...
    Thursday, November 20, 2014 3:31 PM
  • Just wanted to THANK you. This DOES work and has solved the problem of not being able to open individual files in ftp portal.  That was a PITA!  Again,   thank you.  Mike.
    Saturday, December 27, 2014 9:22 PM
  • How is this fixed??  Doesn't Microsoft have to fix this in IE 10 or push out an IE 10 update?  We should not push out a reg fix for this really.  Does anyone know if this was fixed in the latest cumulative updates?
    Friday, March 27, 2015 6:54 PM
  • Drag and drop the file from the explorer window to the ie window.


    delete the value name





    thank you very much!
    Thursday, April 14, 2016 1:06 PM