locked
Internet Explorer 11 won't launch on Windows 7 RRS feed

  • Question

  • I am running Windows 7 - 64bit Premium edition. 

    I was having problems with a site loading as the default in the IE browser that was considered suspicious. 

    The Norton Antivirus agent helped to get rid of that issue, but in the meantime, something happened that messed up the launching of Internet Explorer (wasn't my default browser, so it wasn't an immediate issue). 

    I uninstalled Internet Explorer 11 and reinstalled, but that did not resolve the issue. 

    I have tried to run iexplorer.exe from the Command prompt and from the start menu, and I only see a flash on my screen like it is trying to run, but then nothing happens. 

    Currently, Internet Explorer is installed in Program Files/Internet Explorer.  Should it be installed in the Windows directory? 

    I looked at all the other similar questions on this topic in this forum, so I know I am not alone.  There were some fairly sophisticated responses, but I admit I didn't understand what was being suggested.  If there is a more novice to intermediate user action I can try, I would appreciate that information. 

    Wednesday, January 29, 2014 5:53 PM

Answers

  • Hi,

    I would like to suggest you try following command:

    Dism /Online /Enable-Feature /FeatureName: Internet-Explorer-Optional-<architecture>

    Where <architecture> can be x86, amd64, or ia64.

    Example: Internet-Explorer-Optional-amd64

    Hope it helps.

    Regards,

    Blair Deng


    Blair Deng
    TechNet Community Support

    • Marked as answer by Cloud_TS Wednesday, February 5, 2014 7:28 AM
    Friday, January 31, 2014 9:45 AM
  • I have tried to run iexplorer.exe from the Command prompt and from the start menu, and I only see a flash on my screen like it is trying to run, but then nothing happens.   

    Try, in a safe mode boot, using Run... (e.g. press Win-R and enter:)

    iexplore.exe  -nohome  -extoff



    Robert Aldwinckle
    ---

    • Marked as answer by Cloud_TS Wednesday, February 5, 2014 7:28 AM
    Saturday, February 1, 2014 12:00 AM
    Answerer

All replies

  • Hi,

    I would like to suggest you try following command:

    Dism /Online /Enable-Feature /FeatureName: Internet-Explorer-Optional-<architecture>

    Where <architecture> can be x86, amd64, or ia64.

    Example: Internet-Explorer-Optional-amd64

    Hope it helps.

    Regards,

    Blair Deng


    Blair Deng
    TechNet Community Support

    • Marked as answer by Cloud_TS Wednesday, February 5, 2014 7:28 AM
    Friday, January 31, 2014 9:45 AM
  • I have tried to run iexplorer.exe from the Command prompt and from the start menu, and I only see a flash on my screen like it is trying to run, but then nothing happens.   

    Try, in a safe mode boot, using Run... (e.g. press Win-R and enter:)

    iexplore.exe  -nohome  -extoff



    Robert Aldwinckle
    ---

    • Marked as answer by Cloud_TS Wednesday, February 5, 2014 7:28 AM
    Saturday, February 1, 2014 12:00 AM
    Answerer
  • is this all in the cmd  box?
    Thursday, March 30, 2017 8:27 PM
  • I tried this but it hung up "connecting"
    Thursday, March 30, 2017 8:28 PM