locked
MSEdgeChromium launch from powershell with hwdrm options enabled. RRS feed

  • Question

  • Stuck at launching MSEdgeChromium launch from powershell with hwdrm options enabled.

    Intent is to run the below command

    Start-Process msedge.exe  --disable-features=msDisablePlayReadyHardwareDrm25668132

    Start-Process "msedge.exe --disable-features=msDisablePlayReadyHardwareDrm25668132"
    Start-Process : This command cannot be run due to the error: The system cannot find the file specified.
    At line:1 char:1
    + Start-Process "msedge.exe --disable-features=msDisablePlayReadyHardwa ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [Start-Process], InvalidOperationException
        + FullyQualifiedErrorId : InvalidOperationException,Microsoft.PowerShell.Commands.StartProcessCommand

     Start-Process msedge.exe  --disable-features=msDisablePlayReadyHardwareDrm25668132

    The above ignore hwdrm flag



    Sunday, June 14, 2020 8:53 AM

All replies

  • When you post code, error messages, sample data or console output format it as code, please. How to Use the Code Feature in a TechNet Forum Post

    What do you mean with:

    doesnt seem to work.

    What happened?

    Did you try 

    msedge.exe  --disable-features=msDisablePlayReadyHardwareDrm25668132

    Powershell is - just like CMD - a normal CLI.

    BTW: You're asking in your subject and in your text the option to be enabled. But in the command line the option is named disable!!


    Live long and prosper!

    (79,108,97,102|%{[char]$_})-join''


    Sunday, June 14, 2020 9:32 AM
  •  Start-Process msedge.exe  --disable-features=msDisablePlayReadyHardwareDrm25668132

    Disable, twice, it implies enable, modified my earlier post, added error seen


    Regards, Kishore

    Sunday, June 14, 2020 10:30 AM
  • Did you actually read my answer? Please format your code, error messages, sample data or console output AS CODE.

    The error messafe is pretty obvious. You either have to change the current directory to the directory of msedge or you specify the full path. And you do not need Start-Process. Just run the command line as it is.


    Live long and prosper!

    (79,108,97,102|%{[char]$_})-join''

    Sunday, June 14, 2020 10:45 AM

  • Hi,
    Was your issue resolved? 
    If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.
    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions.
    If no, please reply and tell us the current situation in order to provide further help.
    Best Regards,
    Yang Yang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, July 3, 2020 5:29 AM