locked
Trusting custom URI Scheme from Outlook RRS feed

  • Question

  • Hello folks,

    I'm trying to figure out how can I trust custom URI scheme (in my case its called "webkey://")

    As "http://" and "mailto:" are trusted in Outlook.

    Is there a setting or registry key to configure that I trust a custom URI scheme?

    Right now, for every link with my custom URI scheme I got the following message from inside Outlook:

    Security Notice

    Thanks alot.

    -- Idan

    
    Wednesday, August 16, 2017 9:10 AM

Answers

  • Found a solution using Office 2016 ADMX,

    You can add the custom URI scheme to the following reg key:

    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate the following registry subkey:
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\xx.0\Common\Security\Trusted Protocols\All Applications
    Note In this subkey, replace "xx.0" with 15.0 for Outlook 2013
    3. Click the All Applications subkey.
    4. On the Edit menu, point to New, and then click Key.
    5. Type the name of the protocol that you want to exclude. For example, to disable the display of a security warning for the "Notes:" protocol, type Notes:.

    Reference: http://seanofarrelll.blogspot.co.il/2014/11/outlook-security-warning-when-clicking.html 

    • Marked as answer by Idan Freiberg Wednesday, August 16, 2017 9:36 AM
    Wednesday, August 16, 2017 9:36 AM

All replies

  • Found a solution using Office 2016 ADMX,

    You can add the custom URI scheme to the following reg key:

    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate the following registry subkey:
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\xx.0\Common\Security\Trusted Protocols\All Applications
    Note In this subkey, replace "xx.0" with 15.0 for Outlook 2013
    3. Click the All Applications subkey.
    4. On the Edit menu, point to New, and then click Key.
    5. Type the name of the protocol that you want to exclude. For example, to disable the display of a security warning for the "Notes:" protocol, type Notes:.

    Reference: http://seanofarrelll.blogspot.co.il/2014/11/outlook-security-warning-when-clicking.html 

    • Marked as answer by Idan Freiberg Wednesday, August 16, 2017 9:36 AM
    Wednesday, August 16, 2017 9:36 AM
  • Good for you! Thank you for sharing the solution here. It will be helpful to others in the forum when they encounter the same issue.

    Cheers,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, August 17, 2017 1:55 AM