locked
IE8 or windows 7 deletes favorites by bypassing recycle bin RRS feed

  • General discussion

  • why is that? If i delete a file it should go to the recycle bin not just vanish.

    why was this done? and how to fix it?
    • Changed type Linda Yan Monday, November 2, 2009 2:06 AM
    Sunday, October 25, 2009 4:46 PM

All replies

  • Hi ComicConBooBoo,

     

    If you are using Windows 7 Professional, Ultimate or Enterprise, Please see the issue can be resolved by changing the Group Policy:

     

    1. Please go to Start, type gpedit.msc and then press Enter.

    2. Expand User Configuration -> Administrator Templates -> Windows Components -> Windows Explorer on the left pane.

    3. Double click "Do not move deleted files to the Recycle Bin".

    4. Choose "Disabled".

    5. Click OK.

     

    Please see if the issue can be resolved.

     

    In addition, if the issue did not occur before, you can perform System Restore to restore the system to the date before the issue occurred.


    Also, does the issue occur in other user accounts?
     

    Hope this helps.


    Regards,

    Linda

     

     

    Monday, October 26, 2009 6:24 AM
  • currently it is set to Not Configured which means it should be sent to the recycle bin by default.

    "If you disable or do not configure this setting, files and folders deleted using Windows Explorer will be placed in the Recyele Bin."

    but it only does it in Internet explorer. windows explorer it sends it to the recycle bin and changing it to disabled does nothing to stop it.

    when I right click one of my favorites it has a blue and yellow shield next to it. that is the only place I have seen it next to the delete option.

    I am the only user and I have admin rights across the board and I just noticed it the other day and as I said it only happens in Internet Explorer.

    set up a standard and admion user and it does the same in both

    if i go use windows explorer it is fine and i can go to the favorites folder and  delete favorites and they go to the recycle bin

    here is a picture of the delete menu in IE 8 - http://img193.imageshack.us/img193/668/deletek.jpg
    Monday, October 26, 2009 7:58 AM
  • Hi ComicConBooBoo,

     

    Please try the following suggestions and see if the issue can be fixed:

     

    -           Temporary remove security software such as Malwarebytes' Anti-Malware.

     

    -           Remove third party toolbars from Internet Explorer (IE).

     

    -           Reset IE

                ======

    Note: the following steps will remove all of installed add-ons and reset IE to default settings. You need to reinstall the add-ons after resetting.

     

    1. Click "Start", type "inetcpl.cpl" (without quotation marks) into “Search” bar and press "Enter" to open the “Internet Options” window.

    2. Switch to the "Advanced" tab.

    3. Click "Reset…" to reset Internet Explorer settings.

    4. Check "Delete personal settings" box and click "Reset" to confirm the operation.

    5. Click "Close" when the resetting process is complete.

    6. Close the Internet Explorer window and restart IE to check the issue.

     

    -           Test the issue in Clean Boot. If the issue disappears in the Clean Boot environment, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.

     

    -           Test the issue in a new user account with Administrator privilege.

     

    What is the result?

     

    Regards,

    Linda

     

    Tuesday, October 27, 2009 2:43 AM
  • removing malware bytes did nothing.

    dont have any 3rd party toolbars

    reseting IE changed nothing.

    new user with account privelages did nothing.

    safe mode stops it from showing.

    if I disable UAC all the way it goes away but if i use UAC default settings or even one notch up if comes back.

    so why is this glitch in IE?  most people leave UAC on by default as that is how its shipped but to permamently delete files by bypassing the recyle bin unless uac is disabled is a major issue.
    Tuesday, October 27, 2009 5:55 AM
  • Hi ComicConBooBoo,

     

    Does the issue occur in Clean Boot mode? If not, please try it first. For your reference, I have included the steps below:

     

    Check the issue in Clean Boot Mode

    ===========

    1. Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.

     

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

     

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

     

    Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.

     

    Please test this issue in the Clean Boot environment, if the issue disappears in the Clean Boot environment, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.

     

    What is the result? If the issue persists, please check if the User Account Control (UAC) policy settings are correct when set it to Default. For your reference. To check the settings, please perform the steps below:

     

    Compare the User Account Control (UAC) policy

    ===========

    1. Click Start. Go to the Search textbox. Type SECPOL.MSC, and then press Enter.
    2. Expand Local Policies by clicking the PLUS (+) sign.
    3. Open Security Options.

    4. Compare the User Account Control policies with this picture:

     



    If the issue still exists, please collect the HiJackThis log for further research:

     

    Collect HiJackThis log

    ==============

    1. Please download HijackThis from the following link:

     

    http://www.techspot.com/download317.html

    HijackThis is a tool to collect some system settings information which is useful for further troubleshooting.

     

    Please Note: The third-party products discussed here are manufactured by vendors independent of Microsoft. We make no warranty, implied or otherwise, regarding these products' performance or reliability.

     

    2. Right click the downloaded HJTInstall.exe file and choose "Run as administrator".

     

    Provide administrator password or click “Allow” if you are prompted to do so.

     

    3. Click the "Do a system scan and save a logfile" Button.

     

    4. A Notepad window will appear, please click File, Save As...” to save it as HJT.log (or other file name you like) on the Desktop and upload it to SkyDrive at www.skydrive.live.com and let me know the link.

     

     

    Wednesday, October 28, 2009 7:05 AM
  • did all that and still prompts to perm delte my favorites thus bypassing the recycle bin

    http://cid-c08b19a44a4319c0.skydrive.live.com/embedicon.aspx/.Public

    hoping i linked correcxtly. I have encluded pics of the items also and the settings

    the only time it will allow the files to go to the recycle bin from ie8's favorites menu is by disabling UAC completely
    Wednesday, October 28, 2009 9:20 AM
  • Hi ComicConBooBoo,

     

    It seems all settings are set properly.

     

    Since the issue does not occur in Safe Mode, let's try the following suggestions and see if the isuse occurs.

     

    1. Click "Start", click "Run", type "msconfig" (without the quotation marks) in the Open box, and then click OK.

    2. On the "General" tab, click "Diagnostic startup".

    3. Click "OK", and then click "Restart" to restart your computer.

    4. After Windows starts, determine whether the symptoms are still present.

     

    If the problem does not occur, please gradually narrow down the root cause by checking the items under the Services and Startup tabs one by one.

     

    Regards,

    Linda

     

    Thursday, October 29, 2009 2:37 AM
  • it still shows up in diagnostic startup.

    it has something to do with UAC as if I turn it off the option is no longer there and if i delete a favorite from the menu it goes to the recycle bin.

    if i go directly to the favorites folder and right click to delete it goes to recycle bin

    but within ie8 it only allows it to be permamently deleted when right clicked

    I noticed also that if I run IE8 as a admin I can delete it and it gets sent to the recycle bin but I shouldnt have to run IE8 as a admin if I am a admin allready

    I am using quick launch also to launch my IE
    Thursday, October 29, 2009 6:18 AM
  • Let's try the following suggestions and see if the issue can be resolved.

     

    Remove Internet Explorer 8 and reinstall it

    ========

    1.     Close all programs.

    2.     Click Start Collapse this imageExpand this image, and then click Control Panel.

    3.     Under Programs, click Uninstall a program.

    4.     In the tasks pane, click Turn Windows features on or off.

    5.     In the list of windows features, clear the check box next to Internet Explorer 8.

    6.     You receive a warning message in a pop-up window. Click Yes.

    7.     Restart the computer and then repeat step 1 to 4 to recheck Internet Explorer 8.

     

    What is the result? If the issue persists, please add Internet Explorer 8 to Windows Firewall exception list.

     

    Allow Internet Explorer 8 to communication through Windows Firewall

    ========

    1.     Please click Start, click Control Panel and then click Windows Firewall.

    2.     On the left pane, click "Allow a program or feature through Windows Firewall".

    3.     Click "Change settings" button.

    4.     Click "Allow another program…".

    5.     Click Internet Explorer and then click "Add".

     

    Friday, October 30, 2009 2:46 AM
  • neither things fixed the issue.  deleting any favorite by right clicking bypasses the recycle bin by default
    Friday, October 30, 2009 5:08 AM
  • Please use Process Explorer and see if there is any software running behind IE.

     

    Also, try perform an In-Place Upgrade and repair Windows 7 to see if the issue can be resolved.

     

    Regarding In-place Upgrade, it is a tool to repair the system. Through the special upgrade process, we will be able to repair the system. The In-place Upgrade will not affect settings like photos, movies, documents, etc. that are saved on the computer.  However, it is recommended to first backup your important information and files to other partitions or other disks. We can have a try to see if the issue works.

     

    Turn off Windows features before performing an In-place Upgrade

    =========================================

    1. Click Start, and click Control Panel.

    2. Click Classic View on the left pane, and double click Program and Features.

    3. Click "Turn Windows features on or off on the left" pane.

    4. In the Windows Features dialog box, uncheck all of the check boxes, and then click OK. 

    If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

     

    Now, let's perform the following steps to repair the corrupted files:

     

    In-place Upgrade

    ===========

    Though this operation will not remove or modify the installed programs and files, I still suggest that we backup the important files before doing this. In addition, we may have to reinstall the device drivers after this operation. Thank you for your understanding.

     

    If the Windows 7 DVD is not available, please just run setup.exe file in the Windows 7 installation package to perform the following steps.

     

    1. Insert the Windows 7 DVD in the computer's DVD drive.

    2. Click Start and choose Computer.

    3. Please find the "setup.exe" file in the DVD-ROM and double click it.

    4. Click Install now.

    5. When we are prompted to input the product key, please click Next without inputting any key. The setup wizard will prompt and ask if you agree to install Windows 7 without the key. Please choose to confirm.

    6. When you reach the "Which type of installation do you want" screen, click Upgrade to upgrade the system files of Windows 7.

     

    Note: While performing the In-place Upgrade, the system will restart automatically (several times) to merge the files and programs. Please leave the computer alone and do not configure it until In-place Upgrade is completed. The system will start Windows 7 once it is upgraded.

     

    When the In-place Upgrade finishes please check the original issue again.

     

     

    Friday, October 30, 2009 10:10 AM
  • Sorry Linda I just went to Fry's in Renton and looked at about 10 of their display systems and they have the same issue. this is not aa isolated incident and needs to be patched.

    so how do we get this bug fixed?  as when deleteing a file it should never bypass the recycle bin just incase its a needed file.

    thanks again


    I noticed if you turn on menu in ie it happens every time

    http://img251.imageshack.us/img251/8679/menufavorites.jpg
    Friday, October 30, 2009 4:48 PM
  • Hi ComicConBooBoo,

     

    I tried to reproduce this issue by deleting to the Favorites on the menu bar and the same issue occurs.

     

    However, if I click the Favorites button and then go to the Favorites bar to delete the favorites, the issue does not occur.

     

    Here are two pictures:

     

     


     

    I have reported this issue to related team and they will look into it. Your time and efforts have been taken into this issue are very much appreciated.

     

    Thank you again for your feedback!

     

    Sincerely,

    Linda

     

     

    Monday, November 2, 2009 2:04 AM
  • thanks linda. i noticed that also. I just never use the favorites bar unless I have to search for a previous website.

    hopefully a fix will be worked on as I use the menu bar for most of my browsing
    Monday, November 2, 2009 3:14 AM
  • jgjsfjgjbdfjbgirgjsf
    Monday, April 12, 2010 8:13 AM