locked
French keyboard layout "installs" by itself. RRS feed

  • Question

  • Hello, I'm experiencing a problem with the keyboard input languages, though I'm not sure if said problem would be better posted under the miscellaneous sections.

    I have 2 languages set up as input, English US and Greek. Both work fine and I'm able to use the Alt+Shift combination to cycle through them.

    Recently when switching from Greek back to English US my keyboard layout gets mixed up (i.e. a->q and vice versa) and I have to Alt-Shift once more to get it working. I normally have the language bar hidden but turned it on for troubleshooting and noticed that it now cycles through English US, Greek and French. I checked under the Installed Services section, in Text Services and Input Languages, and French is not installed. It just shows English US and Greek.

    If I manually add French and then remove it the problem goes away for some time until something triggers it again. I've noticed that the game Dark Messiah triggers this (if I launch the game the input bugs out when I return to windows) but I've also had this happen at random. I haven't installed anything recently apart from some games that I've used in the past without problems, with the exception of the aforementioned Dark Messiah which is a new digital copy. I've checked Dark Messiah forums but no users seem to have similar problems and the game doesn't seem to have any kind of localization. I also don't have any 3rd party input/language programs that I know of.

    Any help would be greatly appreciated. Thanks in advance.

     

    Edit : Forgot to mention that I've applied a kind of "makeshift" fix. I deleted the French layout in the registry under HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layouts. It doesn't activate now, even when running Dark Messiah. This however is not optimal so if there's an "official" fix I'd prefer it.


    Tuesday, July 5, 2011 6:48 AM

All replies

  • Hi,

     

    I suspect this would be related to some programs which  requires French language. As this issue has gone away, it is hard to find the which program cause this issue.

     

    If this issue occurs again, we can try to uninstall the recently installed programs to check the result.

     

    By the way, thanks for sharing your solution.  

     

    Regards,

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, July 7, 2011 7:18 AM
  • I can easily replicate it again by enabling french through the registry.

    What kind of program would enable a French language input and how come it doesn't appear under Installed services?

    Thursday, July 7, 2011 4:05 PM
  • Hi,

     

    This depends on the software installed on your computer; you could try to perform Clean Boot to eliminate this software conflict.

     

    Regards,

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, July 11, 2011 1:42 AM
  • As I previously said, I have not installed any programs before this started with the exception of some games (that I've also used in the past).

    Also what kind of program would have a behavior like this? I can understand a program requiring French input installing the service by itself but as I already mentioned French doesn't show up in Installed services.

    Monday, July 11, 2011 3:40 PM
  • This is a rather old topic, but I just ran into this problem with Dark Messiah as well. For the sake of those who find this page like I did there is a real fix.
    Control Panel > Region and Language > Keyboards and Languages > Change Keyboards...

    Advanced Key Settings > (Select Between Input languages) Change Key Sequence...

    Set both to "Not Assigned"

    Turns out hitting Alt + Shift (by default) was causing the keyboard shift to french.

    • Proposed as answer by Daerogami Tuesday, June 5, 2012 11:05 PM
    Tuesday, June 5, 2012 8:56 PM