locked
exe File association RRS feed

  • Question

  • All my "exe" files have an icon that looks like a blank piece of paper with a corner fold. I have tried to change to the windows default icons, but the exe files are still the same. I also tried a program called "Default exe" which is a reigistry hack, still did not work. when i open "default programs>>>>Associate a file type with a program" the icon is an "Unknown program".



    [URL=http://img31.imageshack.us/i/12339394.png/][IMG]http://img31.imageshack.us/img31/880/12339394.th.png[/IMG][/URL]








    My specs are:

    E6700 CPU
    X1950 pro 500Mb Graphics card using Windows 7 default driver
    3 x 300Gb SATA HDD's
    Vista Ultimate (32bit) Windows 7 RC build 7100  (dual booting - each O.S. on its own HDD) with Windows 7 as "C" drive Vista as "D" drive
    GA-EP45-DS3  Motherboard

    Is there a way to get the default exe icon back.

    thank you
    John
    Sunday, August 2, 2009 12:33 AM

Answers

  • I have the same trouble but cant resolve it :(
    Thank you all for the Help.....I finally solved it.  mso54 do/did you have a Stardock program called Icon Packager installed ?. and if so have you uninstalled it. I had it installed and uninstalled it without resetting the default icons option in Icon Packager, and that was the cause of my problem. To fix it i had to reinstall Icon Packager (do not run it) then i downloaded a fix from Stardock called "odnt_zapper.exe" run this program and tick the Icon packager box, and say Yes to any pop-ups that appear.

    You can go hereand view the result. it worked for me.
    http://forums.stardock.com/331217
    Hope this helps.

    cheers

    • Edited by linutsSmith Tuesday, August 4, 2009 12:59 AM Solved
    • Marked as answer by linutsSmith Tuesday, August 4, 2009 1:00 AM
    Tuesday, August 4, 2009 12:58 AM

All replies

  • I have the same trouble but cant resolve it :(
    Sunday, August 2, 2009 10:50 AM
  • So is this a "bug" in Windows 7 or Something else ?.

    cheers
    Monday, August 3, 2009 4:46 AM
  • Try going in to the registry and modifying this string:


    HKEY_CLASSES_ROOT\exefile\DefaultIcon



    First export the key if you need to restore it.
    Now delete the value for default icon and press ok.
    • Edited by ONE ZERO Monday, August 3, 2009 5:17 AM
    Monday, August 3, 2009 5:11 AM
  • Try going in to the registry and modifying this string:


    HKEY_CLASSES_ROOT\exefile\DefaultIcon



    First export the key if you need to restore it.
    Now delete the value for default icon and press ok.
    Thank you for the information, i deleted the value %1, I have a feeling that the problem is because a lot of the programs i installed are in the  Program files (x86) and not in the Program files folder. The (x86) seems to be the default folder when installing programs. Is it possible to move these programs to the Programs Files Folder without re-installing them.

    cheers

    • Edited by linutsSmith Monday, August 3, 2009 12:53 PM syntax
    Monday, August 3, 2009 6:38 AM
  • Try going in to the registry and modifying this string:


    HKEY_CLASSES_ROOT\exefile\DefaultIcon



    First export the key if you need to restore it.
    Now delete the value for default icon and press ok.
    Thank you for the information, i deleted the value %1, I have a feeling that the problem is because a lot of the programs i installed are in the  Program files (x86) and not in the Program files folder. The (x86) seems to be the default folder when installing programs. Is it possible to move these programs to the Programs Files Folder without re-installing them.

    cheers


    i want to tell you that you're using windows 7 64bit (x64) so, in 64bit windows there are 2 program files folder, on where 64bit apps were installed and other i.e. x86 for simulated 32 bit apps get installed. the only way to move them to program files folder is to instlled the 64bit version of the app if available.....

    in btw, to solve the icons wrongly displayed problem, use ultimate windows tweaker v2.0, download it from http://www.thewindowsclub.com/
    My Blog | http://windows4life.blogspot.com
    Monday, August 3, 2009 6:46 PM
  • Hi, I think this can do the trick, navigate to HKEY_CLASSES_ROOT\exefile\DefaultIcon node in the registry editor. Now, double click the Default value to modify it. Change %1 to

    %SystemRoot%\System32\imageres.dll,-15 . System restart is necessary for this to work.

    Hey this worked for me after the system restart. Take a look at this pic. I change the JPEG file Icon to Exe file icon.


    Click to enlarge

    If this answered your question please Mark it as answered.

    Best Regards Gopal Adhikari
    Visit My Blog at: http://hacktheugly.wordpress.com
    • Proposed as answer by HyperCoder Monday, August 3, 2009 9:01 PM
    Monday, August 3, 2009 8:44 PM
  • I have the same trouble but cant resolve it :(
    Thank you all for the Help.....I finally solved it.  mso54 do/did you have a Stardock program called Icon Packager installed ?. and if so have you uninstalled it. I had it installed and uninstalled it without resetting the default icons option in Icon Packager, and that was the cause of my problem. To fix it i had to reinstall Icon Packager (do not run it) then i downloaded a fix from Stardock called "odnt_zapper.exe" run this program and tick the Icon packager box, and say Yes to any pop-ups that appear.

    You can go hereand view the result. it worked for me.
    http://forums.stardock.com/331217
    Hope this helps.

    cheers

    • Edited by linutsSmith Tuesday, August 4, 2009 12:59 AM Solved
    • Marked as answer by linutsSmith Tuesday, August 4, 2009 1:00 AM
    Tuesday, August 4, 2009 12:58 AM