locked
Windows Installer disabled after reboot on Windows 7 RRS feed

  • Question

  • Gentlemen and Ladies, We just did a company wide upgrade to windows 7 32bit from Windows XP and are having this nagging issue over and over. All of the machines for some reason have the windows installer service completely disabled, and if you go into services to re-enable it, it will work as long as the machine is on as far as we can tell. However whenever you reboot the service returns to disabled status and you have to go back to services and re-enable it if you need to install something. While this is a mild annoyance right now, it has the potential soon to become a big problem with almost 80 machines in the field being looked at for an upgrade. We are currently running a Windows Server 2003R2 domain with AD running and I am wondering if there is some group policy that is causing this or something else. Have done some research online and found an entry about 7 x64 version having a problem with a misnamed reg key. I looked on one of these machines and yes under HKLM\SYSTEM\CurrentControlSet\services i have an entry for msiserver however these are 32 bit machines so not sure right now if that's the issue. Any help will be welcome. Thanks again.
    Monday, January 10, 2011 4:13 PM

Answers

  • Hi,

     

     

    I suggest you check the Windows Installer settings in Group Policy:

     

    Computer Configuration/Administrative Templates/Windows Components/Windows Installer

     

    You could disable policy Disable Windows Installer, and then do GPUPDATE /FORCE on your clients.

     

    Meanwhile, due to this is related Windows server 2003, it is also recommended to post to Windows server forum for further help:

     

    Windows Server Forum

     

    Hope it helps.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Cloud_TS Monday, January 17, 2011 7:45 AM
    Wednesday, January 12, 2011 10:16 AM

All replies

  • Hi,

     

     

    I suggest you check the Windows Installer settings in Group Policy:

     

    Computer Configuration/Administrative Templates/Windows Components/Windows Installer

     

    You could disable policy Disable Windows Installer, and then do GPUPDATE /FORCE on your clients.

     

    Meanwhile, due to this is related Windows server 2003, it is also recommended to post to Windows server forum for further help:

     

    Windows Server Forum

     

    Hope it helps.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Cloud_TS Monday, January 17, 2011 7:45 AM
    Wednesday, January 12, 2011 10:16 AM
  • Sorry for the delay, for some reason was never informed of the reply via email. Checked the group policy and that policy is not enabled. Should also note that we do have one or two XP machines still on the network for now and they do not have this issue. it is only on windows 7 and doesnt matter if its 64bit or 32bit as the problem happens on both.
    Thursday, March 17, 2011 3:52 PM