none
GPO and Map Network Drive

    Question

  • A little help would be much appreciated.  I've tried this 100 times and am getting nowhere fast.

    Environment:

    • trying to map network drives on windows 7 and 10 via gpo
    • steps taken can be found here
    • share settings are set to authenticated users/full control 
    • ntfs permissions are set for users and groups to have full control

    i can access the share from windows explorer.  i can manually map the network drive but it just won't map via the gpo.  any help would be GREATLY appreciated.

    Tuesday, December 13, 2016 8:10 PM

All replies

  • First of all use GPO Prefreneces to map the drive as the blog writes about. But you don't have to apply security filtering on the GPO itself. Only apply security filtering on the drive-mapping (within the GPO Preference). Also configre the drive-mapping to run in so called 'user mode'. Make sure you re-login on your client, do not count on a gpupdate /force.

    Boudewijn Plomp | Conclusion FIT

    Please remember, if you see a post that helped you please click "Vote as Helpful", and if it answered your question, please click "Mark as Answer". This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, December 13, 2016 9:47 PM
  • Hey Boudewijn,

    Yep

    • i used gpo preferences to map the drive
    • did not apply security filtering on the gpo
    • by user mode do you mean "run in logged-on user's security context (user policy option)?"
    • every time i change the gpo i run "gpupdate /force" AND restart the pc but nothing works

    any other thoughts?

    Tuesday, December 13, 2016 10:21 PM
  • Hi,
    Please run gpresult /h command to view the details group policy report and check if the GPO is applied successfully or not. Or any related event logs could also help.
    And you could check if MS16-072 is installed on clients and domain controllers which might cause user group policy not working, if that is the case, please use the Group Policy Management Console (GPMC.MSC) and add the Authenticated Users group with Read Permissions on the Group Policy Object (GPO). If you are using security filtering, add the Domain Computers group with read permission. Please see: https://support.microsoft.com/en-sg/kb/3163622
    Best regards,
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, December 14, 2016 3:46 AM
    Moderator
  • Hey Boudewijn,

    Yep

    • i used gpo preferences to map the drive
    • did not apply security filtering on the gpo
    • by user mode do you mean "run in logged-on user's security context (user policy option)?"
    • every time i change the gpo i run "gpupdate /force" AND restart the pc but nothing works

    any other thoughts?

    Yes I mean "run in logged-on user's security context".

    I don't have a GPO in front of me now. But what you can do is play around with the 're-connect' and om the other tab "remove drive when policy is removed" or something like that. You will notice the icon changes color because it switches to "Update" and that kind of thing. I have had situaions where this seems to work or not work. Sorry, for the confusion, don't have a console on front of me right now. But I think you know what I mean.


    Boudewijn Plomp | Conclusion FIT

    Please remember, if you see a post that helped you please click "Vote as Helpful", and if it answered your question, please click "Mark as Answer". This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, December 15, 2016 6:41 PM