none
Clearing Enterprise Custom Fields (MSP 2010 Pro) RRS feed

  • Question

  • We're using an Enterprise Custom Field in MSP 2010 Pro that uses a selection list of Yes/No. If the user selects "Yes" then the field appears with a checkmark. If the user selects "No" then the field is blank. We are trying to clear all the checkmarks from the Enterprise Custom Field by selecting the field, clearing it, and clicking save. When we re-open MSP 2010 the checkmarks re-appear. We have tried clearing them by selecting the column and pressing Ctrl-D, selecting Cut, and by using the Delete key. In all cases it looks like the checkmarks are gone but when we re-open the project they re-appear.

    Interestingly, if we do a Save As after clearing the checkmarks and overwrite the existing project and then re-open it, the checkmarks are then gone.

    We can't figure out why Save does not clear the checkmarks and Save As does.

    Does anyone know what is preventing Save from actually saving the cleared checkmarks or have a suggestion for getting around this issue other than using Save As?

    Thanks in advance!

    Mark

    Tuesday, June 18, 2013 5:33 PM

Answers

  • Mark I think the issue could be that you made the NO option display blanks. I could be wrong but I would try this: Change the lookup table so that NO displays NO. Open a file and see that it applied NO where it should. Now try deleting the values using any of the methods. Then save, close, and open the file.

    I'd also see if you can patch to the latest CU. It *might* just be a bug.

    Please let everyone know how this worked out.

    • Proposed as answer by Quized again Thursday, June 20, 2013 3:14 PM
    • Marked as answer by MSKramer Thursday, June 20, 2013 3:22 PM
    Tuesday, June 18, 2013 11:41 PM

All replies

  • MSKramer,

    Since this is a Project Server question, you will probably get a better answer if you post to the Project Server forum at:

    http://social.technet.microsoft.com/Forums/en-US/projectserver2010general

    This forum is dedicated to question/issues about the stand alone installations of Project.

    John

    Tuesday, June 18, 2013 6:28 PM
  • Oops. Rookie mistake. Thank you, John.
    Tuesday, June 18, 2013 7:19 PM
  • MSKramer,

    No problem. We just want to make sure you get the best help as quickly as possible. Although some of the people that respond on this forum are very conversant in Project Server, the Project Server forum is the better bet.

    John

    Tuesday, June 18, 2013 8:52 PM
  • Mark I think the issue could be that you made the NO option display blanks. I could be wrong but I would try this: Change the lookup table so that NO displays NO. Open a file and see that it applied NO where it should. Now try deleting the values using any of the methods. Then save, close, and open the file.

    I'd also see if you can patch to the latest CU. It *might* just be a bug.

    Please let everyone know how this worked out.

    • Proposed as answer by Quized again Thursday, June 20, 2013 3:14 PM
    • Marked as answer by MSKramer Thursday, June 20, 2013 3:22 PM
    Tuesday, June 18, 2013 11:41 PM
  • It worked! My user followed your suggestion and gave it a thumbs up. Thank you!

    • Marked as answer by MSKramer Wednesday, June 19, 2013 10:57 PM
    • Unmarked as answer by MSKramer Thursday, June 20, 2013 3:22 PM
    Wednesday, June 19, 2013 10:49 PM
  • Please mark my answer as the answer. I appreciate it. I am glad I could help!
    Thursday, June 20, 2013 3:14 PM