locked
Exchange 2016 - Autodiscover with Outlook 2016 password prompt RRS feed

  • Question

  • Good morning everybody.

    I have only one forest with one domain. The functionnal level is Windows Server 2008 R2.

    I have 2 Exchange 2010 server : One mailbox and one CAS. The version is Exchange 2010 SP3 Rollup Update 14.

    I add an Exchange 2016 server on a Windows Server 2016 because I want to migrate from 2010 to 2016.

    The URL used actually by the Exchange 2010 will not be the same in Exchange 2016. I need to change all the URL to use a unique URL that is not the case now.

    Now I have these URL in Exchange 2010 :

    For Exchange 2016, all the URL are mail.domain.com (for internal autodiscover too)

    OWA, ActiveSync and Outlook works fine.

    With Outlook 2010 and 2013 on a computer join to domain log in with AD account that have a mailbox on Exchange 2016, when I launch Outlook for the first time, it automatically detects the mailbox and configure the profil with autodiscover. I don't need to do anything, it works fine. But with Outlook 2016, when I do the same thing, at this point, it ask me for credential :

    I enter the password and it works fine. Then when I open Outlook, I never need to enter password. It's only on the configuration profile.

    Then when I'm in Outlook, if I do a test configuration for autodiscover, I doesn't ask me for credendial.

    Can somebody help me please ? I don't know where to find. All Windows updates is done on Outlook 2016.

    Thank you so much for your help.

    Best Regards


    • Edited by user_007 Thursday, December 15, 2016 10:22 AM
    Thursday, December 15, 2016 10:21 AM

Answers

  • Hi everybody,

    I wish you a happy new year !

    I shutdown our Exchange 2010 servers and very good new, no prompt for the password with autodiscover in Outlook 2016 !

    There is an interaction between Exexchange 2010 and Exchange 2016, but what ? No idea. But everything will be solved during the migration.

    I close this post. Thank you for all you help and tests.

    Have a nice day.

    • Marked as answer by user_007 Friday, January 6, 2017 7:56 AM
    Friday, January 6, 2017 7:56 AM

All replies

  • Hi

    For your Outlook 2016 credential prompt, there is a similar thread you may check: 

    https://social.technet.microsoft.com/Forums/en-US/dff92319-5424-4e26-a1d9-c693b0e87567/microsoft-outlook-2016-keeps-asking-for-a-password?forum=outlook

    Thanks

    Thursday, December 15, 2016 10:42 AM
  • Hello,

    if you are sure that your certificate and FQDNs are correct, there is one more possibility. Depending on your Exchange version and cummulative update version MAPIoverHTTPS can cause problems: Exchangeserverpro - unexpected Outlook prompts

    Greetings Steve

    Thursday, December 15, 2016 10:48 AM
  • Hi everybody,

    PK Sarangi, thank you but it's not my case. I don't always have the prompt for password, only during the creation of the profil.

    AlphaRonin, thanks for the information. In the Exchange 2016, I use a wildcard certificat *.domain.com to iis.

    Thanks for your help and ideas for this problem.

    Thursday, December 15, 2016 12:23 PM
  • Hi everybody,

    PK Sarangi, thank you but it's not my case. I don't always have the prompt for password, only during the creation of the profil.

    AlphaRonin, thanks for the information. In the Exchange 2016, I use a wildcard certificat *.domain.com to iis.

    Thanks for your help and ideas for this problem.

    Do you have any load balancers between the clients and servers?  If so what happens if you use a host file and route around them?

    What are the authentication settings on your virtual directories?  Specifically MAPI?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread

    Thursday, December 15, 2016 2:36 PM
  • No I don't have load balancer.

    Configuration of Mapi virtual directory :

    Outlook anywhere virtual directory :

    Do you need an other ?

    Thank you so much for your help.

    Thursday, December 15, 2016 2:43 PM
  • Hi

    Yeah, when I test in my lab, it is asking for the password and I doubt it is by design because Outlook 2016 connectivity method is MAPI over HTTP. The basic authentication method changed to Active Directory Authentication Library (ADAL) authentication method. And it is designed to work with O365, so might be the first time authentication is by design, and it saves the credential separately in Credential Manager.


    Thanks


    • Edited by PK Sarangi Thursday, December 15, 2016 6:39 PM
    Thursday, December 15, 2016 6:39 PM
  • Friday, December 16, 2016 6:31 AM
  • Hi,

    I made a test in my exchange 2016 lab.

    When using outlook 2013, it automatically detects the mailbox and configure the profile with autodiscover.

    When using outlook 2016, I have the same situation as the picture below displayed:

    As Pk explains, it seems this is by design. We need not to have too many concerns about this.


    Best Regards,
    David Wang
    TechNet Community Support


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    • Edited by David Wang_ Friday, December 16, 2016 7:11 AM
    • Proposed as answer by David Wang_ Monday, December 19, 2016 5:41 AM
    • Unproposed as answer by David Wang_ Thursday, December 22, 2016 8:12 AM
    • Proposed as answer by StaceyBranham Thursday, December 22, 2016 2:50 PM
    Friday, December 16, 2016 7:06 AM
  • Good morning everybody,

    Thank you for all your tests.

    That reassures me not to be the only person to have this problem. But I don't think it's normal. There should be a problem somewhere, but where ?

    Monday, December 19, 2016 7:52 AM
  • Good morning,

    Does anyone have a solution ?

    Thank you so much.

    Thursday, December 22, 2016 8:08 AM
  • Hi,

    In your first screenshot, I notice it has two account, exch2 and exch1, I understand the account you want to configure is exch2, but the account that keeps prompting is exch1.

    so I suggest you try to login a PC with the Windows account exch2, then open Outlook to auto-configure profile (it will auto use Exch2 to configure Outlook profile).

    In addition, it seems you are using outlook 2016 in Windows, also try to use outlook 2016 in Windows 10 for test, then check if the same issue persists.


    Best Regards,
    David Wang
    TechNet Community Support


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, December 23, 2016 3:20 AM
  • Hi,

    Thank you for your answer.

    I do the test with Windows 10 and I have the same problem.

    What is Strange is when I have this :

    If I click Cancel, the configuration finish well and Outlook works fine without prompting password.

    After the Holidays, I will try to shutdown our Exchange 2010 servers to see if it changes something.

    Thank you so much for your help.

    Best regards

    Friday, December 23, 2016 9:11 AM
  • Ok, just wait for your updates.


    Best Regards,
    David Wang
    TechNet Community Support


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, December 26, 2016 1:44 AM
  • Hi everybody,

    I wish you a happy new year !

    I shutdown our Exchange 2010 servers and very good new, no prompt for the password with autodiscover in Outlook 2016 !

    There is an interaction between Exexchange 2010 and Exchange 2016, but what ? No idea. But everything will be solved during the migration.

    I close this post. Thank you for all you help and tests.

    Have a nice day.

    • Marked as answer by user_007 Friday, January 6, 2017 7:56 AM
    Friday, January 6, 2017 7:56 AM