locked
Exchange 2007 to 2013 Public Folder Migration Stalled RRS feed

  • Question

  • Hello. I am in the process of migrating from Exchange 2007 Standard SP3 RP10 to Exchange 2013 Standard. I have Exchange 2013 Standard CU2-v2 installed on two Server 2012 Standard systems. The two new exchange servers are members of a DAG.

    I am in the process of migrating Public Folders.  I have two Exchange 2007 servers, each with a replica of the public folders. 

    I have executed the New-PublicFolderMigrationrequest command on one of the Exchange 2013 servers. Initially, the process advanced quickly, reaching 25% complete in a few minutes.  Since then I have run the following command many times.

    Get-PublicFolderMigrationRequest | Get-PublicFolderMigrationRequestStatistics

    The command returned a StatusDetail of StalledDuetoReadUnknown at 25% complete.  Running the following command provided more details about the status of the process.

                    Get-PublicFolderMigrationRequest | Get-PublicFolderMigrationRequestStatistics -IncludeReport | FL

    Several occurrences of “Transient error ResourceUnhealthyException has occurred” were reported. While researching this, I continued to monitor the progress of the migration request.  At different times the StatusDetail was reported as each of the following. 

    CopyingMessages

    InitialSeeding

    StalledDuetoHA

    StalledDuetoReadUnknown

    The two most common results that are returned are CopyingMessages and StalledDueToreadUnknown.  The PercentComplete has increased to 26%.

    Please explain to me what is happening here.  If I need to take action to ensure a successful public folder migration, please provide me with details on the steps required.  Thanks!!

    Tuesday, November 19, 2013 5:54 PM

Answers

  • Through a support case with Microsoft, it was verified that this was an issue with workload management and throttling.  Microsoft executed several commands to temporarily disable the components that were causing the  public folder migration to stall.  Once the migration has completed successfully, they reversed those changes.
    • Marked as answer by vltdiv Wednesday, January 8, 2014 4:18 PM
    Wednesday, January 8, 2014 4:18 PM

All replies

  • Hi

    Do you have enough resources on your server?

    Friday, November 29, 2013 12:30 PM
  • Yes.  This issue appears to be due to workload management policies.  I'm troubleshooting that.
    Tuesday, December 10, 2013 11:27 PM
  • Through a support case with Microsoft, it was verified that this was an issue with workload management and throttling.  Microsoft executed several commands to temporarily disable the components that were causing the  public folder migration to stall.  Once the migration has completed successfully, they reversed those changes.
    • Marked as answer by vltdiv Wednesday, January 8, 2014 4:18 PM
    Wednesday, January 8, 2014 4:18 PM
  • What parts of the workload policy did they change?

    Looks like I've got the same problem with Exchange 2013 public folder migration stalling...

    Thanks

    Saturday, March 1, 2014 1:27 AM
  • Are you running CU2?

    CU2 had a bug that prevented PF migration from completing. It was fixed in CU3

    Thursday, March 6, 2014 5:07 PM
  •  Does  anyone have a  solution on what commands to temporarily disable the componets   i'm have  the the same  problem of  just for 3 mailboxes  out like 50
    Thursday, October 2, 2014 3:14 PM