locked
Problem with connecting to the database when creating a report in Performance Point’s Dashboard Designer RRS feed

  • Question

  • I have a problem when creating a report in Performance Point's Dashboard Designer. I am able to create a data source and the connection is successful but when I create a report using this data source I get the following error:

    "The PerformancePoint Server could not connect to the specified data source. Verify that either the current user or application pool user has Read permissions to the data source, depending on your security configuration. Also verify that all required connection information is provided and correct."

    I didn't have this problem while the database I was using was on the local server, and now it's on another server. I tried googling the problem but the solutions that are there for this problem are not working. I make all the neccessary settings for the application pool in IIS - I set as an identity a user that has full permission to the database, which is usually the solution to the problem that gives this error, but I still get the error. 
    Does anyone know what might be the problem?
    Wednesday, July 7, 2010 7:39 AM

Answers

  • Have you switched the Application Pool to a domain account? 

    Does the account have read permission to the cube that you are trying to access (assuming you are using a SSAS source)? 

    Are you still using the default security with PPS that utilizes the identity of the Application Pool?

    Make sure you are using a domain account since the data source is no longer local and setup on the same server as PPS, verify that the domain account has read permissions to the source if you are still leveraging the default PPS security, if you are using PerUser security then you are either going to have to utilize Kerberos in your environment or look at the CustomData setup with SSAS.

    Take a look and review Nick Barclay's blog posting here http://nickbarclay.blogspot.com/2007/11/pps-data-source-connection-problems.html for some more details in regards to this issue.


    Dan English's BI Blog
    Wednesday, July 7, 2010 10:51 AM