none
HostedNetwork is Set up, Android device is unable to obtain IP Address

    Question

  • I have set up my connection as per the following article

    http://www.siyge.com/2013/03/24/create-hotspot-in-windows-8-adhoc-network/

    The netsh commands I used are:

    netsh wlan set hostednetwork mode=allow ssid=MyWlan key=qwertyui keyUsage=persistent

    netsh wlan start hostednetwork

    The difference is:

    a) I am sharing a USB modem connection

    b) I have turned off Windows Firewall ( I use Comodo nternet Security)

    I have a dell n5010 laptop using Windows 8.

    When I tried to connect my Android device to it, the device simply gets stuck at the "Obtaining IP address step"

    I decided to use a Blackberry device and the same error occurred.

    To be doubly sure, I even used another Laptop running Windows XP SP3 to connect to the hostednetwork, even it got stuck at the "Obtaining IP address" part for some time. Then it got connected with "Limited or no connectivity" status.

    Tuesday, December 24, 2013 3:16 AM

Answers

  • The following procedure worked for me.

    1) Disable Internet Connection Sharing from your modem connection -> properties -> Sharing Tab

    2) Enable it again.

    3) Disconnect from the Internet.

    4) Reconnect again

    5) Restart ICS service from the "services.msc" window.

    6) Stop the hostednetwork

    7) Start the hostednetwork

    8) Internet Sharing is now enabled and everything gets resolved.

    • Marked as answer by Vekool Saturday, December 28, 2013 6:01 AM
    Saturday, December 28, 2013 6:01 AM

All replies

  • The following procedure worked for me.

    1) Disable Internet Connection Sharing from your modem connection -> properties -> Sharing Tab

    2) Enable it again.

    3) Disconnect from the Internet.

    4) Reconnect again

    5) Restart ICS service from the "services.msc" window.

    6) Stop the hostednetwork

    7) Start the hostednetwork

    8) Internet Sharing is now enabled and everything gets resolved.

    • Marked as answer by Vekool Saturday, December 28, 2013 6:01 AM
    Saturday, December 28, 2013 6:01 AM
  • This procedure dont work for me.

    I do this :

    netsh wlan set hostednetwork mode=allow ssid=MyWlan key=qwertyui

    netsh wlan start hostednetwork

    I share my lan connection.

    When i try to connect my android phone is unable to obtain an IP adresse

    I make this CMD :

    netsh wlan show hostednetwork

    and i seen

    "nombres de clients : 1

    e4 :b0 : 21 :b5 :3c :00     Authentifié"

    My device is authentified but it don't obtained IP adress.

    Wednesday, February 26, 2014 11:22 AM
  • I looked everywhere for a solution to this, and finally something worked!! Thank you!
    Thursday, May 14, 2015 4:07 PM
  • Hi Vekool, I was also facing the same problem with my Samsung S4 and by following the first 4 steps above it got resolved. I think by disabling and enabling the Internet sharing feature it got resolved. Though it is an old thread but still thanks!!!
    Friday, June 19, 2015 11:08 PM
  • Thanks a lot for sharing. It works for me :D
    Monday, December 7, 2015 8:49 PM
  • Thank you so much! This solved my problem with hosted network. I'm curious how you figured this out?
    Sunday, May 8, 2016 12:57 AM
  • Thanks so much! :) Tried everything else but only this worked. Not sure why this method is so underrated.
    Thursday, June 16, 2016 10:08 PM
  • The following procedure worked for me.

    1) Disable Internet Connection Sharing from your modem connection -> properties -> Sharing Tab

    2) Enable it again.

    3) Disconnect from the Internet.

    4) Reconnect again

    5) Restart ICS service from the "services.msc" window.

    6) Stop the hostednetwork

    7) Start the hostednetwork

    8) Internet Sharing is now enabled and everything gets resolved.

    I know this is an old thread. but this do resolved my problem. thanks a lot!
    Tuesday, June 28, 2016 1:35 PM
  • the first 2 steps were enough to solve my problem it seems
    Wednesday, October 5, 2016 8:10 PM
  • Hurray, your answer solved my problem!

    I could see that my android device was successfully authenticated but it failed to obtain an IP address. I tried everything but --

     5) Restart ICS service from the "services.msc" window previously. So, I assume that item was the key!! 

    So I assume that was the key. Thanks so much, Vekool!



    • Edited by JiyeonKwon Thursday, October 6, 2016 9:02 AM
    Thursday, October 6, 2016 8:58 AM
  • How to do the first step ? Where to go ?
    Friday, October 7, 2016 11:28 AM
  • Hi

    i am still facing a same problem...

    can you tell me how you solved it please....

    Monday, October 24, 2016 12:27 PM
  • Man tried everthing, and finally found something that work. Your my hero man. Thumbs up! Thank you!
    Tuesday, December 13, 2016 6:11 AM
  • Hi,

    If you are facing connection problem, before doing anything check the following. 

    1. Go to existing network connection properties. -> go to sharing tab, and check "Home network connection". This tab should have the newly created hosted network such as "Local Area Connection*13" (this was in my case.). In my case, the existing connection was shared but the "Home network connection" was showing "Wi-Fi", and I guess this is the problem. 

    Disable the sharing connection by unchecking "Allow other network.....connection", and click Ok.

    now again go to current network properties, sharing tab and click on "Allow other network.....connection". You would be able to see list of available connections. select "Local Area Connection*13" (this was in my case. You would have something different), and click Ok. Now try to connect the wifi form your device. 

    Sunday, July 9, 2017 8:38 PM
  • Hi,

    If you are facing connection problem, before doing anything check the following. 

    1. Go to existing network connection properties. -> go to sharing tab, and check "Home network connection". This tab should have the newly created hosted network such as "Local Area Connection*13" (this was in my case.). In my case, the existing connection was shared but the "Home network connection" was showing "Wi-Fi", and I guess this is the problem. 

    Disable the sharing connection by unchecking "Allow other network.....connection", and click Ok.

    now again go to current network properties, sharing tab and click on "Allow other network.....connection". You would be able to see list of available connections. select "Local Area Connection*13" (this was in my case. You would have something different), and click Ok. Now try to connect the wifi form your device. 

    Thank you, it worked! The first solution didn't work for me but this one was perfect, thanks!
    Friday, May 11, 2018 3:50 PM
  • It worked :)

    Thanks

    Monday, June 25, 2018 12:48 PM
  • Thanks! This method worked for me.
    Wednesday, June 27, 2018 3:28 PM
  • Thank you very much, I have struggled with this problem for a long time and decided to ignore it until today when I decided I will have to finish this once and for all, I wouldn't have done it without your solution. I created a new account just to thank you.
    Thursday, August 30, 2018 12:27 AM
  • Worked perfectly Thanks!
    Saturday, February 9, 2019 7:38 AM