locked
CMD cannot see network disk RRS feed

  • Question

  • I have a server ZFS based, I can mount disks from the file manager, access and read/write them; the same disks cannot be accessed from CMD and from some tools
    Sunday, June 28, 2020 3:12 PM

All replies

  • Sunday, June 28, 2020 5:25 PM
  • Hi,

    In regard to your issue of ‘CMD cannot see network disk’, I want to confirm these information:

    1. In your description of ‘mount disks from the file manager’, does it mean that you have successfully map a network dive?
    2. What exact CMD command did you use to access the disk? 
    3. If you have mapped a network dive in your local network location, you can use CMD command ‘ net use’ to see mapped network drives.



    Please refer to the following link:
    How to Map Network Drives From the Command Prompt in Windows
    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Hope my answer will help you, thanks!

     

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Gloria Gu Thursday, July 2, 2020 1:29 AM
    Monday, June 29, 2020 6:54 AM
  • no, I didn't run CMD as administrator;

    I used the procedure "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System" but this didn't work
    Monday, June 29, 2020 8:25 PM
  • I mounted the network disk with the same letter as that used by the file manager way

    net use w:\\<server-name>\<disk-name>

    and this worked

    it is strange to me that the same letter must (can) be used two times to map the same disk in two different ways on the same account, this means that I can use a letter for a network disk from file manager and the same letter for another disk from CMD (I didn't check this); but this fixed the problem

    thank you!

    Monday, June 29, 2020 8:32 PM
  • no, I didn't run CMD as administrator;

    I used the procedure "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System" but this didn't work

    Did you reboot?

    Detail to configure the EnableLinkedConnections" registry entry

    1. In Registry Editor, locate and then click the following registry subkey:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
    2. Right-click Configuration, click New, and then click DWORD (32-bit) Value.
    3. Name the new registry entry as EnableLinkedConnections.
    4. Double-click the EnableLinkedConnections registry entry.
    5. In the Edit DWORD Value dialog box, type 1 in the Value data field, and then click OK.
    6. Exit Registry Editor,and then restart the computer.

    Tuesday, June 30, 2020 12:14 AM
  • Hi,

    Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, June 30, 2020 8:33 AM
  • Hi,

    Just want to confirm the current situations. Please feel free to let us know if you need further assistance.

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, July 2, 2020 1:29 AM
  • I checked again,
    the procedure "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System" works but before accessing to the disk through the CMD I have to check that the same disk is accessible through the file manager (after the system turns on the file manager mapped disk are not accessible, I have to use it to make it available)

    thank you!

    Thursday, July 2, 2020 4:53 PM
  • Hi,
     
    Just want to confirm the current situations.
     
    Please feel free to let us know if you need further assistance.

    Best regards,
    Gloria

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, July 31, 2020 8:13 AM