locked
Stsadm command line error while deploying web part in MOSS RRS feed

  • Question

  • Hi Folks,

    I am trying to install Office Pivot Chart in my development box to prepare bar chart. I got the CAB file while following instruction from this site and now I am getting command line error while running below command:

    > stsadm.exe -o addwppack -filename "C:\microsoft.sharepoint.solutions.greatplains.cab" -globalinstall -force

    I ran above command in my virtual PC and it ran successfully.

    Please guide.

    Thx

    • Moved by Mike Walsh FIN Tuesday, March 8, 2011 10:30 AM stsadm questions are admin (From:SharePoint - Development and Programming (pre-SharePoint 2010))
    Tuesday, March 8, 2011 10:04 AM

Answers

  • Hi All,

    SOLUTION

    Thx for all your suggestion.

    I got the solution. I was running command with System Account but with Restricted Access. So, i follow below steps:

    1. Right Click command prompt.
    2. Click Run as
    3. Click Current User option and give your System Account credentials.
    4. (Important) Uncheck Run this program with restricted access.
    5. Ok
    So i ran below command successfully.

    > stsadm.exe -o addwppack -filename "C:\abc.cab" -globalinstall

    Thanks,
    Chintan

     

    • Marked as answer by Paul Galvin Wednesday, March 9, 2011 11:13 AM
    Wednesday, March 9, 2011 8:02 AM

All replies

  • Please post what error you are getting?


    Thanks & Regards, Neerubee
    Tuesday, March 8, 2011 10:07 AM
  • Hi Neerubee,

    Thx for reply. I am getting below error msg in command prompt:

    Command Line Error.

    Thats it...:(

    Note: I am having System Account privilege and DB is also store in same Dev. box.

    Thx

     

    Tuesday, March 8, 2011 10:37 AM
  • Can you copy/paste the command window here? 

    The -force option may hide errors.

    Which account are you using to run the command?  It must be an account with db priveleges, although you would probably get a different error if that were the issue.


    --Paul Galvin, BrightStarr
      Microsoft MVP - SharePoint
      Blogging @ http://www.mstechblogs.com/paul
      Twitter @ http://www.twitter.com/pagalvin
    Tuesday, March 8, 2011 11:46 AM
  • Is the File name in .CAB format? if so, kindly change it to .cab. The STSADM command doesnt like the .CAB (capital letter extension).

     

    let me know if that helps.

     

    REgards,

    SSM

    Tuesday, March 8, 2011 1:30 PM
  • Usually you get that error when there is a syntax issue with the command.

    Did you happen to copy and paste this command from a Word file or a website?  Sometimes the "-" in the commands gets replaced with a different character if you copy and paste.   If you did copy and paste, try typing out the commands instead.

    Tuesday, March 8, 2011 7:24 PM
  • Hi All,

    SOLUTION

    Thx for all your suggestion.

    I got the solution. I was running command with System Account but with Restricted Access. So, i follow below steps:

    1. Right Click command prompt.
    2. Click Run as
    3. Click Current User option and give your System Account credentials.
    4. (Important) Uncheck Run this program with restricted access.
    5. Ok
    So i ran below command successfully.

    > stsadm.exe -o addwppack -filename "C:\abc.cab" -globalinstall

    Thanks,
    Chintan

     

    • Marked as answer by Paul Galvin Wednesday, March 9, 2011 11:13 AM
    Wednesday, March 9, 2011 8:02 AM