locked
Issues with previously mapped drives and USB RRS feed

  • Question

  • Under our GPO, there was a mistake made. A drive was mapped to the first available drive letter (call it E).  As a note, this is hidden drive.

    When a user then tried to insert a USB key, they did not get a mapping and thus could not see the USB drive.  Normally, it would have used E (but that is now used by the GPO mapping).

    We changed the GPO to correct the mistake, so the GPO was deleted and recreated to use F:

    This didn't seem to solve the issue though. While the GPO mappings were corrected, users still cannot see their USB disks.
    When inserted, they just see nothing.  If I go into Disk Management, I can see the drive sitting there with E label, but the drive is essentially hidden.  I can change the drive letter and then it appears, but if I change back (or insert a different USB disk), E is still not visible.

    The other odd thing I am seeing is that even after gpupdate, I am getting a message to the effect that the system could not reconnect mapped drives at logon time - even though the mapped drive (F) is connected.

    anythoughts?

    Tuesday, July 14, 2015 8:56 AM

Answers

  • Did you set the GPO to delete the Mapping. I always find it best when using GPO preferences to map drives to set it to delete the mapping for a while before removing the GPO.
    Tuesday, July 14, 2015 9:24 AM

All replies

  • You probably left the "persistent" attribute on. This command should fix the problem:

    net  use E:  /del

    Tuesday, July 14, 2015 9:19 AM
  • Did you set the GPO to delete the Mapping. I always find it best when using GPO preferences to map drives to set it to delete the mapping for a while before removing the GPO.
    Tuesday, July 14, 2015 9:24 AM
  • Did you set the GPO to delete the Mapping. I always find it best when using GPO preferences to map drives to set it to delete the mapping for a while before removing the GPO.

    Good advice on this.  I did exactly that and now things are working.  Thanks!
    Tuesday, July 14, 2015 9:51 AM
  • No worries, glad it helped.
    Tuesday, July 14, 2015 10:48 AM