none
Neither crawling nor docpush works due to some processing error, it seems RRS feed

  • Question

  • After installation of FAST Search Server 2010 and Content SSA in SharePoint, as per Technet articles, crawling fails with message The Content Plugin received a "Processing Error" response from the backend server for the item [snip] for each item.

    At the FAST server, trying to load a document with docpush.exe, I get a similar error message:  Test Reported error with http://cohowinery.com/C:\[path to document]: processing:N/A:ProcessorDeploymentException: For pipeline 'Office14 (webcluster)', creating processor CompanyExtractorInclusionAny failed: ConfigurationError: CompanyExtractorInclusionAny: Failed to access or parse configuration file 'etc/resources/matching/configuration.companyextractor.inclusion.any.xml'.

    In Event Viewer at the FAST server, I get serveral Event ID 1000 Errors when running the docpush command, sources FAST Search ProcServer and FAST Search FacaLib; mostly about a "matcher", for instance Failed to parse 'matcher' tag.

    My troubleshooting shows that most things are in order, such as:

    • All FAST Services in Windows runs as they should.
    • The nctlr status command shows that all processes are running.
    • The certificate for communications between SharePoint and FAST is in order; if I run Ping-SPEnterpriseSearchContentService I get the expected result (as per 'Working with Microsoft FAST Search Server 2010 for SharePoint', p. 98).
    • Port 13391 and others are open as they should be (though anyhow I don't think the communication between servers is the problem because of the docpush result.)
    • All relevant service accounts are members of local group FASTSearchAdministrators, and that group has access to all relevant files.
    • I've created the group FASTSearchKeywordAdministrators as per the recommandation of 'Working with Microsoft FAST' authors and others.
    • Commands like Get-FASTSearchContentCollection -name sp and Get-FASTSearchDocumentProcessingPipeline works.
    • The site and application pool on the FAST server is up and running, in adequate security context.

    However, if I create a new Content Collector and use docpush on it, I get the same error message, as I get on the default Content Collector.

    What I'm hoping from the community is troubleshooting tips, because I've run out of ideas.

    PS. I've had a similar problem last year on another FAST implementation.

    Thursday, August 16, 2012 1:35 PM

All replies

  • >>'etc/resources/matching/configuration.companyextractor.inclusion.any.xml'

    Did you see if such a file exist? If yes, then was it modified? if you have the stock file then you should not be seeing that error.

    FAST Search\var\log\porcserver log should tell you more. Post back.

    What other FAST related config files where changed before you started seeing this error?


    Freddie Maize ..A story with Glory is History. Doesn’t matter whether Glory rest in the world of Demon or God. Lets create History..


    Thursday, August 23, 2012 7:20 AM
  • Thank you for the answer. The file is there and the permissions are as they should. No FAST config files have been changed. I've only installed the product, and then tried to crawl a test area. That's it. It's a fresh install, by the book, everything went smooth up to my crawl test (followed by a docpush test), which doesn't work due to some processing error, and nothing have been added, edited or deleted.
    Tuesday, August 28, 2012 11:57 AM
  • Like you assume you should not be seeing this error if a proper installation was done. Was the install proper? Also what are the chances of trying a re-install?

    Try this one out,

      • In your TEST ENVIRONMENT (NOT IN YOUR PRODUCTION) try this
      • Take a back up of etc\pipelineconfig.xml
      • Find <processor name="CompanyExtractorInclusionAny"/> in your pipelineconfig,xml and comment it.
      • Stop all your procservers.
      • Clear all the procserver logs
      • Start only one procserver
      • docpush a conent and see if you are still seeing the error.
      • rollback the change and post back the test results.

    This is not going to slove your issue but will figure out if "CompanyExtractorInclusionAny" is the only stage that is brining up the issue


    Freddie Maize ..A story with Glory is History. Doesn’t matter whether Glory rest in the world of Demon or God. Lets create History..

    Thursday, August 30, 2012 6:55 AM
  • Thank you for your time. I'm going for SharePoint Enterprise Search instead.
    Thursday, August 30, 2012 7:33 AM