locked
Set windows 8.1 Logon/Lock Screen to English RRS feed

  • Question

  • Hi

    I have an issue with Windows 8.1 64bit Enterprise. I have 2 languages installed on my computers, English and Hebrew.

    I set the default input language to English and copied the settings over to the welcome screen using Region (and I also tried the trick of going through the language bar) and yet when I lock my computer, the language is set to whatever I had on last, so if I had Hebrew set at that moment it will go to Hebrew at the lock screen and I will have to change languages.

    Is there a way to set a fixed language for the logon screen and lock screen? My users keep locking their accounts for this.

    Thanks.

    Itzik.


    • Edited by MercuryZ Sunday, July 5, 2015 10:50 AM
    Sunday, July 5, 2015 9:48 AM

Answers

  • Hi MercuryZ,

    Please check this configuration:

    Control Panel\Clock, Language, and Region\Language\Advanced settings


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.



    Hi MeipoXu

    In that same screen there's a check box labled "Let me set a different input method for each app window", as it turns out, this was the answer. It fixes the lock screen which is now locked to English.

    It does also cause a bit of a change in how language works in Windows as now users will need to get used to each window retaining it's own language setting, but that's preferable to them constantly locking their user accounts.

    • Marked as answer by MercuryZ Thursday, July 16, 2015 9:12 AM
    Thursday, July 16, 2015 9:12 AM

All replies

  • Hi MercuryZ,

    As far as I know, the "Administrative" option included in the Region control panel is used to change the welcome screen language.

    To change the Lock Screen language, we could refer to the following link:
    Lock Screen Clock Date Language - Change in Windows 8
    http://www.eightforums.com/tutorials/47919-lock-screen-clock-date-language-change-windows-8-a.html

    NOTE: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites.

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, July 7, 2015 9:22 AM
  • Unfortunately this isn't what I'm looking for. The guide you linked speaks of changing the display language of the clock and date in lock screen. My issue is the keyboard language which changes to Hebrew causing users to lock their accounts and get frustrated that their password isn't working.

    I just need to know if there's a way to lock the keyboard (typing) language to English in all lock screens always. I don't really get why there's an option to change languages in lock screen anyways. Users and Passwords are always English....

    Tuesday, July 7, 2015 10:11 AM
  • Hi MercuryZ,

    The issue is that it will not be available to input the password correctly due to the keyboard, right?
    How many languages package you have installed in this machine?

    If we have English language package installed, we could choose the English language during the inputting password screen. We also could add an US input method for the Hebrew language if it is possible(Control Panel\All Control Panel Items\Language\Options of the Hebrew\Add an input method).

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.



    Wednesday, July 8, 2015 9:10 AM
  • The issue is that it doesn't default to English at the lock screen. When a user locks his computer the language stays on whatever he used last. He then tries to input the password and gets it wrong since it's not English.

    Now of course it's possible to change the language to English be it through alt-shift or clicking the language bar, but users simply do not notice the language is not English and input the password again and again until the user gets locked.

    In Windows 7 for instance, the lock screen automatically defaulted to English which fixed all this. I want to do the same with Win 8.1.

    Wednesday, July 8, 2015 9:39 AM
  • Hi Mercury,

    Check this configuration:

    Control Panel\Clock, Language, and Region\Language\Advanced settings


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, July 10, 2015 1:21 AM
  • Hi MercuryZ,

    Please check this configuration:

    Control Panel\Clock, Language, and Region\Language\Advanced settings


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.



    Friday, July 10, 2015 1:21 AM
  • Hi MercuryZ,

    Please check this configuration:

    Control Panel\Clock, Language, and Region\Language\Advanced settings


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.



    Hi MeipoXu

    In that same screen there's a check box labled "Let me set a different input method for each app window", as it turns out, this was the answer. It fixes the lock screen which is now locked to English.

    It does also cause a bit of a change in how language works in Windows as now users will need to get used to each window retaining it's own language setting, but that's preferable to them constantly locking their user accounts.

    • Marked as answer by MercuryZ Thursday, July 16, 2015 9:12 AM
    Thursday, July 16, 2015 9:12 AM