locked
DPM backup Issues and VSS Errors RRS feed

  • Question

  • Hi All,

    Wondering if you can help, we've had a few backups failing recently on DPM, it’s not
    affecting all the backups just 3 random VM's on a cluster.

    In DPM we get the following error:

    Description: Recovery
    point creation jobs for Microsoft Hyper-V \Backup Using Child Partition
    Snapshot\SCORCH2012 on SCVMM SCORCH2012 Resources.VMCluster.domain.net have
    been failing. The number of failed recovery point creation jobs = 1.

     If the data source protected has some dependent data sources (like a
    SharePoint Farm), then click on the Error Details to view the list of dependent
    data sources for which recovery point creation failed. (ID 3114)

     Cannot create a recovery point because of a transient problem. (ID 215
    Details: VssError:The shadow copy provider had an error. Check the System and
    Application event logs for more information.

     (0x80042306))

     More information

    Recommended action: 1) Check recent records from the VolSnap source in the
    Application Event Log to find out why the problem occurred. 2) Retry the
    operation.

     Create a recovery point...

    Resolution: To dismiss the alert, click below

     Inactivate

    I’ve looked in the Event log for both the VM and the host and there are no sign of errors
    and the VSS writers are all healthy.

    When looking in the event log for the DPM server there are quite a few errors saying the following
    for multiple volumes:

    Volume Shadow Copy Service error: Unexpected error
    DeviceIoControl(\\?\Volume{4f5540ee-c345-11e2-93f9-001b21497499} -
    00000000000002A4,0x0053c008,0000005901259070,0,000000590125A080,4096,[0]). 
    hr = 0x80820001, The bootfile is too small to support persistent snapshots.

    I have tried to remove the protected machine form DPM and selecting to delete the
    replicas on the disk. When re-adding the first snapshot will work fine then the
    second snapshot it will go back to the original error.

    I cannot see any reported errors of a disk issue.

    Any suggestions will be greatly appreciated.



    Thursday, May 23, 2013 3:33 PM

All replies

  • Before implementing Veeam Backup and Replication as our primary solution for backing up/replicating virtual infrastructure, we used to have similar errors with DPM (that, honestly, was deployed just for a brief period fo time in our environment).

    At that time we were unable to make any restore point, kept receiving errors related to VSS snapshot. However, we managed to rectify the aforesaid issue by running chkdsk /r which corrected existing problem.

    Additionally, as far as I know, under certain circumstances third party security software might also cause similar problems.

    Kind regards, Leonardo.



    Friday, May 24, 2013 1:59 PM
  • Hi Leonardo,  I've found a few posts also suggesting a chkdsk /r but i have an issue that i cannot find the drive its reporting about, in disk management it does not give the full volume name.

    Wednesday, May 29, 2013 7:44 AM
  • I have tried running checkdsk /r on the VM experiencing this error - no joy, has anyone else encountered this problem?

    Wednesday, June 19, 2013 7:54 AM