none
Limit set to incoming attachments at 25 mb but my exchange server is not allowing to come through and giving NDR RRS feed

  • Question

  • I have never had this happen before, but this is now happening to my Exchange 2003 Server.  I have had an outside vendor who is sending me sample emails with different size attachments.  My global setting is set for max of 25 mb incoming messages.  My vendor sent me an email with attachment for 5 mb and that one came through OK.  He sent me a bunch more at size from 8mb to 15mb and all of those got bounced back to him.  They are reaching my exchange server but are not being processed.  I have looked at my Message Tracking Center and there is not a lot of information.  I have not made any changes to my Exchange Server. 

    Does anyone have any ideas where else I could look to see why my exchange server is not accepting these emails with attachments.

    Thank you in advance

    Greg Smith


    Greg Smith
    Tuesday, December 20, 2011 6:14 PM

Answers

  • Hello,

     

    There are several settings to limit the message size, please see:

     

    http://www.msexchange.org/tutorials/set-size-limits-messages.html

     

    In addition, as you may know, when Exchange encoding the outbound message, the size of message usually will be increased 33%.

     

    Thanks,

    Simon

    Thursday, December 22, 2011 6:51 AM
    Moderator
  • On Thu, 22 Dec 2011 17:38:44 +0000, golforfood wrote:
     
    >Here is what I found:
    >
    >Size=2097152
     
    That's 2MB. It's pretty small! Are you sure it isn't 20971520 (i.e.
    20MB)?
     
    Have a look at your "Message Delivery" properties (in the Global
    Settings), and click on the "Defaults" tab. If you want 20MB (instead
    of 2MB) put 20480 in the Sending and Receiving message size boxes.
     
    Then have a look at your SMTP Virtual Server's property page. Select
    the "Messages" tab and make sure that the "Limit message size" is
    unchecked (it may be set to a value smaller than the global values).
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Thursday, December 22, 2011 10:09 PM

All replies

  • On Tue, 20 Dec 2011 18:14:01 +0000, golforfood wrote:
     
    >
    >
    >I have never had this happen before, but this is now happening to my Exchange 2003 Server. I have had an outside vendor who is sending me sample emails with different size attachments. My global setting is set for max of 25 mb incoming messages. My vendor sent me an email with attachment for 5 mb and that one came through OK. He sent me a bunch more at size from 8mb to 15mb and all of those got bounced back to him. They are reaching my exchange server but are not being processed. I have looked at my Message Tracking Center and there is not a lot of information. I have not made any changes to my Exchange Server.
    >
    >Does anyone have any ideas where else I could look to see why my exchange server is not accepting these emails with attachments.
     
    Attachments are encoded using base64. Those messages will grow by a
    factor of approximately 1.4. So that 8MB attachment will become 11.2MB
    of message size. If you use the Exchange default of a 10MB maximum
    message size you'll refuse to accept those messages.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Tuesday, December 20, 2011 10:43 PM
  • Rich

    Thank you for the quick response, but I have my exchange set to a max of 25mb and I can't even get 8 or 10 mb attachments to be successful.  Is there something else that I might look at?

    Thanks
    Greg Smith


    Greg Smith
    Tuesday, December 20, 2011 11:04 PM
  • On Tue, 20 Dec 2011 23:04:12 +0000, golforfood wrote:
     
    >Thank you for the quick response, but I have my exchange set to a max of 25mb and I can't even get 8 or 10 mb attachments to be successful. Is there something else that I might look at?
     
    So it's just this one vendor that can't send you "large" messages?
     
    Are there any other SMTP gateways, proxies, etc. between the Internet
    and your Exchange server?
     
    Have a look at the SMTP Receive log and find the beginning of a ESMTP
    session (i.e. one that begins with EHLO). Do you see your server send
    the SIZE keyword? Is there a value associated with that keyword? Is it
    25MB (the value will be in bytes)?
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Wednesday, December 21, 2011 2:17 AM
  • Rich,

    I don't have any smtp gateways or proxies between the internet and our exchange server.  When I looked at the log this is what I found:

    EHLO - 250

    Thanks


    Greg Smith
    Wednesday, December 21, 2011 10:34 PM
  • On Wed, 21 Dec 2011 22:34:40 +0000, golforfood wrote:
     
    >I don't have any smtp gateways or proxies between the internet and our exchange server. When I looked at the log this is what I found:
    >
    >EHLO - 250
     
    Oh, yeah . . . Exchange 2003. Sorry, you won't see the response your
    server sends. But all is not lost. From the machine's keyboard,
    "telnet 127.0.0.1 25" and after you get the 220 banner, enter "EHLO".
    You'll see the responses then.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Thursday, December 22, 2011 2:05 AM
  • Hello,

     

    There are several settings to limit the message size, please see:

     

    http://www.msexchange.org/tutorials/set-size-limits-messages.html

     

    In addition, as you may know, when Exchange encoding the outbound message, the size of message usually will be increased 33%.

     

    Thanks,

    Simon

    Thursday, December 22, 2011 6:51 AM
    Moderator
  • Simon,

    Thank you for the link to the article.  I will take a look and make sure all of my settings are correct.

    Greg


    Greg Smith
    Thursday, December 22, 2011 4:30 PM
  • Here is what I found:

    Size=2097152

    Thanks
    Greg


    Greg Smith
    Thursday, December 22, 2011 5:38 PM
  • On Thu, 22 Dec 2011 17:38:44 +0000, golforfood wrote:
     
    >Here is what I found:
    >
    >Size=2097152
     
    That's 2MB. It's pretty small! Are you sure it isn't 20971520 (i.e.
    20MB)?
     
    Have a look at your "Message Delivery" properties (in the Global
    Settings), and click on the "Defaults" tab. If you want 20MB (instead
    of 2MB) put 20480 in the Sending and Receiving message size boxes.
     
    Then have a look at your SMTP Virtual Server's property page. Select
    the "Messages" tab and make sure that the "Limit message size" is
    unchecked (it may be set to a value smaller than the global values).
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Thursday, December 22, 2011 10:09 PM