none
Public folder not receiving mail from internal contact

    Question

  • Hi,

    I am doing a lab with Exchange 2013 and public folders. I create 1 PF by the book, mail enabled it, gave anonymous users contributor role. Problem is when I send a mail from my test user to a PF, PF stays empty. The user that I am sending mail from is the Owner of the PF. Mail address of the PF is SMTP.

    This option to reject messages from all senders is there from the start, is that wrong?

    Edit: not receiving NDR as well.

    Thanks


    • Edited by Tonito Dux Wednesday, October 21, 2015 6:02 PM
    Wednesday, October 21, 2015 6:01 PM

Answers

  • Hi Ed,

    thank you for you suggestion. In the end it turns out after I restarted my Exchange server yesterday two Exchange services did not start and that caused all the comotion. Sometimes it is the simplest things that get the best of us.

    Cheers!

    • Proposed as answer by Roger Lu Thursday, October 22, 2015 7:22 AM
    • Marked as answer by Tonito Dux Monday, October 26, 2015 9:04 AM
    Thursday, October 22, 2015 6:23 AM

All replies

  • The Permissions tab determines who has access via Outlook or OWA to the folder and what they can do.  Message Delivery Restrictions controls transport delivery, i.e., e-mail delivery to the folder.  I think you want to select "Only senders in the following list" and leave the list blank.  That will allow anyone to send mail to the folder.  You can manage the lists under each option if you want to better control who can send to the public folder.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Thursday, October 22, 2015 12:40 AM
    Moderator
  • Hi Ed,

    thank you for you suggestion. In the end it turns out after I restarted my Exchange server yesterday two Exchange services did not start and that caused all the comotion. Sometimes it is the simplest things that get the best of us.

    Cheers!

    • Proposed as answer by Roger Lu Thursday, October 22, 2015 7:22 AM
    • Marked as answer by Tonito Dux Monday, October 26, 2015 9:04 AM
    Thursday, October 22, 2015 6:23 AM
  • Hi Tonito,

    Check if message restriction settings on normal mailboxes also present same options.

    For me it says 'No Senders' instead of 'All Senders' under reject.

    Wondering if Public Folders settings are different or its EAC messing it up for you.

    #Find Message Restrictions on Mailbox
    Get-Mailbox SatyaTest1 | fl Name, *MessagesOnlyFrom*, *MessagesFrom*
    
    #Find Message Restrictions on PublicFolder
    Get-MailPublicFolder PF1 | fl Name, *MessagesOnlyFrom*, *MessagesFrom*

    References:

    Set Message Send and Receive Restrictions on Individual Mailboxes:

    https://technet.microsoft.com/en-us/magazine/ff381459.aspx

    Set-MailboxPublicFolder:

    https://technet.microsoft.com/en-us/library/bb123707.aspx


    Regards,

    Satyajit

    Please“Vote As Helpful” if you find my contribution useful or “MarkAs Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.


    • Edited by Satyajit321 Thursday, October 22, 2015 8:48 AM
    Thursday, October 22, 2015 8:38 AM
  • Hi Satyajit,

    thank you for your input.

    This is what message restrictions look like:

    When i run the two powershell commands i see nothing out of the ordinary that would implicate, but like said above, the Microsoft Exchange Frontend Transport service was not starting so I had to fix that.


    Cheers

    Friday, October 23, 2015 7:18 AM
  • Thanks Tonito. Guess service was messing up the options, once started its back to normal.

    Please mark the answer and close this thread.


    Regards,

    Satyajit

    Please“Vote As Helpful” if you find my contribution useful or “MarkAs Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.


    • Edited by Satyajit321 Monday, October 26, 2015 4:20 AM
    Monday, October 26, 2015 4:20 AM