none
Cannot join a Windows 7 Homegroup RRS feed

  • Question

  • Hello.  I have been trying to get my new desktop PC and my laptop on a homegroup but have thusfar been unsuccessful (hence my posting here).  I have both computers connected to my home wireless network as well as running an ethernet cable between the two.  I originally looked and saw that both of my computers had homegroups already created.  So to not hassle with it (since I wasn't using the homegroups before) I just removed both homegroups.  I then created one on my desktop and went to join it on my laptop, but in Control Panel > Network and Sharing Center > Homegroup, it only gives me the option to "Create a homegroup", not join one.  I also tried it the other way, creating it on my laptop trying to join on the desktop, also unsuccessfully.  I read an article online telling me to set the IP as the same on both computers for the LAN connection, so I tried setting both LAN IP addresses to 192.168.0.1 and the subnet mask to 255.255.255.0 on both computers (those are what it said to set them to), but that didn't work either.  What can I do to get this working?  Please help.
    Wednesday, August 17, 2011 2:44 AM

Answers

  • Hi,

     

    According the issue, I suspect that this problem may be caused by networking. Such as your computer cannot detect a home group in LAN.

     

    From these pictures, I think there something wrong in your IP configuration. Here is my suggestion:

     

    1.       Change the IP configuration of your NIC to “Obtain an IP address automatically” and “Obtain DNS server address automatically”.

    2.       Use “ipconfig -all” to export the IP configuration form you desktop. And take a screenshot for Network Sharing Center from you desktop. Then use Insert/ edit image function to post these picture here.

    3.       I see that pictures of Network Sharing Center and IP configuration. I know you connect the laptop to a wireless router. Could you let me the network environment of your desktop?

    4.       Here is some video of Windows Home group, please refer:

    http://windows.microsoft.com/en-US/windows7/help/homegroup-from-start-to-finish

     

    Hope that helps


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Robinson Zhang Tuesday, September 6, 2011 7:23 AM
    Friday, August 19, 2011 9:32 AM

All replies

  • What version of Windows 7 do you have on each computer? Some cheaper versions of Windows 7 do not allow you to create homegroups, just join existing ones.

    Anyway... go through this detailed tutorial and check also the section "Known Issues & Solutions". It describes a possible solution that might work for you.

    The HomeGroup Feature & How it Works

    If this still doesn't help, try to disable the security solutions you have on both computers and see if joining the homegroup works. I found that some security solutions (such as Norton for example), if not configured correctly, they can make the Homegroup feature to malfunction.

     

    Wednesday, August 17, 2011 1:22 PM
  • In order for two computers to communicate, their IPs on a subnet must be distinct. So, let the IP address of one computer be 192.168.0.1 and configure the IP address of the other computer to 192.168.0.2 leaving the subnet mask as it is.

    Then, make sure the network profile of the LAN is "Home" on both the computers. You can only join a HomeGroup if your network profile is "Home". Check the connectivity between the computers using the ping command. If both computers can communicate, then the setup is just fine. Now create a new HomeGroup on any computer and attempt to join the other computer to it. This should work.

    Note: You cannot create a HomeGroup on a Windows 7 Home Basic edition, you can only join one.

    If this does not solve your problem, post the screenshots of results that you see on the screen after C:\> ipconfig /all and C:\> ping 192.168.0.x where the IP address followed by the ping command is of the remote computer that you're trying to connect to. Hope it helps!


    Kunal D Mehta - a Windows Server Enthusiast.


    Wednesday, August 17, 2011 8:10 PM
  • What version of Windows 7 do you have on each computer? Some cheaper versions of Windows 7 do not allow you to create homegroups, just join existing ones.

    Anyway... go through this detailed tutorial and check also the section "Known Issues & Solutions". It describes a possible solution that might work for you.

    The HomeGroup Feature & How it Works

    If this still doesn't help, try to disable the security solutions you have on both computers and see if joining the homegroup works. I found that some security solutions (such as Norton for example), if not configured correctly, they can make the Homegroup feature to malfunction.

     

    The desktop is running 7 Professional, and the laptop is running 7 Home Premium.  I thought all versions could join and some (including those two, because I have done it) could create.  I have also tried disabling my computer security (Microsoft Security Essentials) and that still didn't work.
    Thursday, August 18, 2011 9:28 AM
  • In order for two computers to communicate, their IPs on a subnet must be distinct. So, let the IP address of one computer be 192.168.0.1 and configure the IP address of the other computer to 192.168.0.2 leaving the subnet mask as it is.

    Then, make sure the network profile of the LAN is "Home" on both the computers. You can only join a HomeGroup if your network profile is "Home". Check the connectivity between the computers using the ping command. If both computers can communicate, then the setup is just fine. Now create a new HomeGroup on any computer and attempt to join the other computer to it. This should work.

    Note: You cannot create a HomeGroup on a Windows 7 Home Basic edition, you can only join one.

    If this does not solve your problem, post the screenshots of results that you see on the screen after C:\> ipconfig /all and C:\> ping 192.168.0.x where the IP address followed by the ping command is of the remote computer that you're trying to connect to. Hope it helps!


    Kunal D Mehta - a Windows Server Enthusiast.


    Alright, I changed the IP of the LAN connection, but I do not know how to change the network profile since it is an "Unidentified Network" (picture http://i.imgur.com/DV79A.png).  I also wasn't exactly sure what you meant my using the "ping" command, but this (picture http://i.imgur.com/XCIzD.png) is what I get when I run "ping" in the command prompt.  

    Here are the two screenshots you asked for.  "ipconfig/all" (http://i.imgur.com/9ReLd.png) and "ping 192.068.0.1" (http://i.imgur.com/xhYjh.png).

    I realized that I also wouldn't mind these computers being "homegrouped" via my house's wireless internet.  If you know of any reasons why they can't join each other from the wireless network, that would also be a help.

    Thanks!

    Thursday, August 18, 2011 9:57 AM
  • Type C:\> ping 192.168.0.1 in the computer with IP address 192.168.0.2

    and

    Type C:\> ping 192.168.0.2 in the computer with IP address 192.168.0.1

    If you get replies like in the above picture, then the connectivity between the computers is successful. This step is important to conclude that the two computers are able to talk to each other.

    Next would be to change the network profile to "Home". This setting should be configurable in either one of the two computers. Then, create a HomeGroup on the same computer and join the other computer to it. Revert back here if you face any more issues. Hope it helps!


    Kunal D Mehta - a Windows Server Enthusiast.
    Thursday, August 18, 2011 10:54 AM
  • Hi,

     

    According the issue, I suspect that this problem may be caused by networking. Such as your computer cannot detect a home group in LAN.

     

    From these pictures, I think there something wrong in your IP configuration. Here is my suggestion:

     

    1.       Change the IP configuration of your NIC to “Obtain an IP address automatically” and “Obtain DNS server address automatically”.

    2.       Use “ipconfig -all” to export the IP configuration form you desktop. And take a screenshot for Network Sharing Center from you desktop. Then use Insert/ edit image function to post these picture here.

    3.       I see that pictures of Network Sharing Center and IP configuration. I know you connect the laptop to a wireless router. Could you let me the network environment of your desktop?

    4.       Here is some video of Windows Home group, please refer:

    http://windows.microsoft.com/en-US/windows7/help/homegroup-from-start-to-finish

     

    Hope that helps


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Robinson Zhang Tuesday, September 6, 2011 7:23 AM
    Friday, August 19, 2011 9:32 AM