locked
Promise Ultra133 TX2 ATA/133 Driver RRS feed

  • Question

  • Hey everyone.

    After I got a reply from Promise that this card is eol, I've been looking online a lot and I'm not able to find a driver for this card that will work with Vista. Does anyone know how to get it to work. I run Windows Vista Ultimate 64bits. I tried to manually select the old drivers from the Promise website, but it rejects them. Hopefully anyone here can help me or show me where to find the file. Please send an email to Skating_vinceREMOVETHIS AT hotmail dot com. Thank you very much!

    Wednesday, February 7, 2007 8:00 AM

All replies

  • Vincent1985,

    Please review the thread attached I also had the same issue with the promise drivers when in beta. http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=544583&SiteID=17

    I found the only way that Vista would see it was to install the drive from the CD that came with my card on installation of Vista. Try this and see if it work.. when I installed RTM 6000 I also had the same issues. Tried to install the OEM (shelf copy) on its own to see if it would find anything and it would not.

    Chris

    Thursday, February 8, 2007 4:11 PM
  • Hi all,

    If someone take beta (or release) driver from Promise support, please send to me - spencer@perm.raid.ru

    Sunday, February 18, 2007 9:31 AM
  • I was able to get the drivers for the card to install (its not pretty, but may resolve your situation until proper drivers are manuf'd). Do the following:

    1. Goto http://www.promise.com/product/product_detail_eng.asp?segment=Non-RAID%20HBAs&product_id=87
    2. Click on the download link on the bottom right side.
    3. Under the driver section, select "Ultra133 TX2 Windows Driver" dated 2003/10/15 (Should be version 2.00.0.43) - Hint, in most cases I have found that forcing XP drivers will work about 90% of the time, as I said above, its not pretty, but it will work until vista drivers are developed.
    4. Reinstall the driver for the "Mass Storage Controller" and select specify a driver, browse to the loaction you extracted the drivers to and there you go. You will get a warning about the signing or WHQL status of the driver, just ignore the warning and the card will install, your drives will be viewable.

    Good luck, hope this helps,

    - John.

    Sunday, February 18, 2007 11:52 AM
  • Tried all that, but that doesn''t work on Windows Vista 64 bits... Windows tells me that the driver does not contain a valid x64 driver. Anyone been able to build a driver for this issue?
    Sunday, February 18, 2007 5:58 PM
  • Hi Promise currently have Window Vista Beta 32 Bit driver available for the Ultra133 TX2 controller. This driver will require you to sign a beta disclaimer form so if you are interested I will need you to contact our support at 1-408-228-1400 option 4 for support and we will assist you. Thanks
    Monday, March 5, 2007 5:48 PM