locked
Out of Office not working on Exchange 2007 (server 2003) RRS feed

  • Question

  • I know there have been several posts on this issue and I have tried quite a few things:

    For years we had no problems, but about two weeks ago this started.  In Outlook, trying to set OOF you get the error, "Your automatic reply settings cannot be displayed because the server is currently unavailable.  Please try again later".  Setting OOF through OWA works fine.

    Highly unlikely this is a client issue as it happens on multiple versions of Outlook and even off terminal server sessions.  However,  I have tried to redo profiles, disable client side IPv6,  and even create new accounts,  all to no avail.

    On the server,  I have rebooted several times,  ran updates, (undid updates,  then redid updates again). No IPv6 to disable on 2003 but I tried a few things with IP with no luck. I've checked and rechecked Autodiscover (from the client) a hundred times and that passes, I've even removed the Autodiscover virtual directory and recreated it per a post and still, the error remains.  I've checked and tried every kind of security in iis I could find and only managed to make things worse for a bit until I undid all of that.

    It seems to me this may still be some kind of permissions or security thing because when I try to go the site <a href="https://.<domain>.com/EWS/Exchange.asmx">https://<servername>.<domain>.com/EWS/Exchange.asmx I get a 404 error 'file or directory not found'.  That's a big lie because I can surely find it in Explorer!  

    I am probably missing something obvious, but I am out of good ideas and hopefully someone can help.  Thanks much in advance!

    Tuesday, December 3, 2013 7:39 PM

Answers

All replies

  • With Outlook running, hold the Ctrl key down, click the Outlook icon in the system tray, select Test E-mail Autoconfiguration.  Enter your information, clear both Guessmart checkboxes and click Test.  Note the Availability Service URL; this is where Outlook manages out-of-office and free-busy data, among some other things.  If this URL isn't correct, you'll need to fix it with the Set-WebServicesVirtualDirectory cmdlet.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Tuesday, December 3, 2013 10:41 PM
  • Thanks for the reply. When I go to that URL it prompts for username/password.  I enter that then I do get a page of XML code and no errors.  I believe I may have been entering the incorrect URL in my testing from the previous post where I got the 404 error.  So that all appears to work,  however,  OOF still laughs at me with the same "...reply settings cannot be displayed.." error.
    Wednesday, December 4, 2013 6:45 PM
  • Of course it does, it requires authentication.  But you won't find anything by opening the URL with a browser as it's not a web page.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Wednesday, December 4, 2013 7:05 PM
  • Yes,  I know all that. But is that not telling me the Availability Service URL is functioning ok and the problem lies elsewhere?
    Wednesday, December 4, 2013 8:02 PM
  • It might be telling you that, if you're ending up at the right endpoint.  Can you verify that?

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Wednesday, December 4, 2013 8:03 PM
  • Hi,

    Please check your IIS log and find the detail error message about error code 404.

    Regards,


    Rebecca Tu
    TechNet Community Support

    Thursday, December 5, 2013 1:11 AM
  • First off,  thanks for the replies, it's been helpful and is greatly appreciated.

    Rebecca, I think the 404 error was an error on my part for mistyping the URL. It actual appears to "see" it and point the correct location, as far as I can tell, that is.

    Grasping at straws here,  it almost seems like an odd permissions issue because it works ok for a few brief moments after you do an iisreset.  But again,  when I altered authentication I only managed to make things worse. 

    I read that this was fixed in Exchange 2010.  Perhaps the ultimate answer is to upgrade at some point.

    Ed,  I guess I don't really know what you mean by "endpoint"  save that the configured URLs at least appear to be working as one would expect. 

    Note OWA still works so we're not unable to set OOF, so no huge rush here.  But any other thoughts are welcome.

    Thursday, December 5, 2013 4:56 PM
  • Hi,

    Please locate the OOF url in the Result tab of Test E-mail AutoConfiguration, then type it in your IE address and access it.

    If there is an error code, check in your IIS log and find the detail error message about the error code.

    Regards,


    Rebecca Tu
    TechNet Community Support

    Friday, December 6, 2013 1:33 AM
  • Rebecca,

    I located the URL,  which in this case is https://es.colorink.local/EWS/exchange.asmx ,  and that comes up to a page with XML code.  I understand that is what I should be expecting.  I don't see any errors in the IIS log.  It appears to be working as expected,  but still,  the same error trying to set OOF.

    Jon

    Friday, December 6, 2013 8:22 PM
  • You don't have anonymous access enabled on that VD, do you?

    Get-WebServicesVirtualDirectory | fl *authentication*

    What about certificates? Does yours have the correct name(s)? Is it expired?

    Are you logged on to your machine with an account different to the credentials you used to open the mailbox? There was a problem that was fixed on MS Office in SP2. Of course, if you're not doing that it won't help (at least not with this problem) :-)

    Is DNS correct? Is there an "A" record for the server (or for the server in the domain you use for e-mail)?

    Any patches installed on the machine between the time it worked and the time it stopped working? Check for .Net SP2 or 3.51 SP1.

    See if this helps:

    http://social.technet.microsoft.com/Forums/exchange/en-US/7dfdbc80-8a65-447a-be38-3f4ec5379927/out-of-office-assistant-settings-cannot-be-displayed-for-outlook-2007-clients?forum=exchangesvrclientslegacy

    These are some of the links in that thread:

    http://support.microsoft.com/kb/952883/en-us

    http://support.microsoft.com/kb/959209/en-us


    --- Rich Matheisen MCSE&I, Exchange MVP

    Saturday, December 7, 2013 7:29 PM
  • Rich, much appreciated the reply.

    I checked much of what you suggested. There is currently no anonymous access, though like I said,  I managed to make things much worse when I was playing with authentication! The certificate looks like it expires in 2015. There is a DNS entry that looks correct. There was a patch to .Net SP2 from early November. I removed it, but no change. From one of the links I am thinking maybe this is a .Net issue. I could try to uninstall/reinstall 3.51 perhaps. I'll try to get to that this week (when I can convince them to let me take the server down for a bit).

    Monday, December 9, 2013 3:55 PM