none
How to enable hibernation in Windows 10 Fall Creator update without disable Guarded Host? RRS feed

Answers

  • What about using registry method.

    Open registry editor and navigate to the following key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power

    Give HibernateEnabled a value of 1 to enable Hibernation.

    Good luck

    Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    The solution not solve the problem, I found other solution:

    I found in registry the follow key:
    Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Power\ForceHibernateDisabled

    And found "GuardedHost" with value 1, and set to 0, and Hibernation came back. :)

    It good solution?

    Tuesday, December 12, 2017 5:24 PM

All replies

  •   That message seems clear to me. Guarded mode disables hibernation.

    Bill

    Monday, December 11, 2017 12:54 AM
  •   That message seems clear to me. Guarded mode disables hibernation.

    Bill

    Guarded mode has been enable for more than a month, and not disables hibernation, it disable hibernation two days ago.

    See "Managing attestation policies" in "Default policies":
    https://docs.microsoft.com/en-us/windows-server/virtualization/guarded-fabric-shielded-vm/guarded-fabric-manage-hgs#managing-attestation-policies

    Most commands available in Windows Server 2016 only and not in Windows 10, I want to disable "Hgs_NoHibernation", how to do it?

    The command:
    https://docs.microsoft.com/en-us/powershell/module/hgsattestation/Disable-HgsAttestationPolicy?view=win10-ps

    Disable-HgsAttestationPolicy can disable Hgs_NoHibernation, and the command exist in Windows Server 2016 only...


    • Edited by ArieLub Monday, December 11, 2017 1:22 PM
    Monday, December 11, 2017 10:44 AM
  • What about using registry method.

    Open registry editor and navigate to the following key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power

    Give HibernateEnabled a value of 1 to enable Hibernation.

    Good luck

    Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, December 12, 2017 7:18 AM
    Moderator
  • What about using registry method.

    Open registry editor and navigate to the following key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power

    Give HibernateEnabled a value of 1 to enable Hibernation.

    Good luck

    Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    The solution not solve the problem, I found other solution:

    I found in registry the follow key:
    Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Power\ForceHibernateDisabled

    And found "GuardedHost" with value 1, and set to 0, and Hibernation came back. :)

    It good solution?

    Tuesday, December 12, 2017 5:24 PM
  • Of course, Facts speak louder than words.

    Glad to hear that you fixed problem by yourself, please mark your reply to close this case, this way can help other people find out useful information


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, December 14, 2017 8:35 AM
    Moderator