locked
Registry is all wrong in WIN2K3 RRS feed

  • Question

  • Hi,


    We are facing a problem with the registry with our Windows Server 2003 - DataCenter Edition server machine. This machine is a high end machine with 8 CPU's and 16 GB RAM.

    Strangely, all the registry entries under the HKCU except for the software are gone. Also most of the entries under the HCKU\software\Microsoft\Windows\CurrentVersion are also gone.

    This is happening for one particular user of the machine, who has administrative rights.

    The Event viewer mentions the following


    Event Type:    Error
    Event Source:    Userenv
    Event Category:    None
    Event ID:    1508
    Date:        2/9/2009
    Time:        1:16:39 PM
    User:        MYMACHINE\SomeUser
    Computer:    MYMACHINE
    Description:
    Windows was unable to load the registry. This is often caused by insufficient memory or insufficient security rights.

     DETAIL - Access is denied.  for C:\Documents and Settings\SomeUser.MYMACHINE\ntuser.dat

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.



    Event Type:    Error
    Event Source:    Userenv
    Event Category:    None
    Event ID:    1502
    Date:        2/9/2009
    Time:        1:17:10 PM
    User:        MYMACHINE\Someuser
    Computer:    MYMACHINE
    Description:
    Windows cannot load the locally stored profile. Possible causes of this error include insufficient security rights or a corrupt local profile. If this problem persists, contact your network administrator.

     DETAIL - Access is denied.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


    Event Type:    Error
    Event Source:    Userenv
    Event Category:    None
    Event ID:    1505
    Date:        2/9/2009
    Time:        1:17:41 PM
    User:        MYMACHINE\SomeUser
    Computer:    MYMACHINE
    Description:
    Windows cannot load the user's profile but has logged you on with the default profile for the system.

     DETAIL - The parameter is incorrect.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


    However if the server is rebooted, the entries reappear and seems to be fine. But this is not acceptable for us.

    Any help on this regards would be greatly appreciated. lastly I am not sure this is the right forum.

    Thanks in advance

    Tuesday, February 10, 2009 4:53 AM

Answers

All replies

  • Where does Visual C++ fit into the picture?
    Tuesday, February 10, 2009 6:32 AM
  • Is there a forum where I can move it to?
    I will say general Windows OS behavior.
    Tuesday, February 10, 2009 6:36 AM
    • Marked as answer by Vic Vega Tuesday, February 17, 2009 3:33 AM
    Tuesday, February 10, 2009 6:45 AM
  • Thanks. I will reply with the scenario where it crashed using COM+.
    Tuesday, February 10, 2009 7:25 AM