Usertemplates location not being treated as trusted RRS feed

  • Question

  • We have recently noticed that some word documents are requiring us to click to enable content. The documents themselves do not contain any code, but there is code in the template's they attach to. The locations containing the template and the document are both trusted locations (which are set through group policy).

    Some documents based on the same template open without any problem, even when they are opened from the same folder as other documents which fail. After some investigation it appears that the documents that open without any problem were created using a copy of the same template located in our workgroup templates location, even though it attaches itself to the copy in the usertemplates location when it is opened. We know that Word documents store the path of the template they were created from, although this doesn't really help to explain why we are seeing this behaviour.

    If I open any template directly from the usertemplate location I don't have to enable content on that template. If we remove the template from the usertemplate's location, the problematic documents attach to the same template located in the workgroup template location when opening and don't require enabling of content.

    Does anyone have any insight as to why this would be happening? How is this possible when the locations are trusted? We are wondering whether an update has been applied that has caused this this behaviour to start happening as we think it's unlikely it has been behaving like this since we upgraded to Office 2010.



    Wednesday, July 10, 2013 2:07 PM

All replies

  • When get the prompt, click File, and click the Enable Content button in the Info tab, click Advanced Options, there we will find out that, the template attached in the document is actually opened from the temp folder - Temporary Internet Files, which is not supposed to be a Trusted Location, and that's why the content has been blocked.

    To solve this, in the Macros Security settings, set the option as "Disable all macros exept digitally signed macros", and sign your macros with your digital signature. Or set the option as "Enable all macros", which is not recommended.

    Max Meng
    TechNet Community Support

    • Edited by Max Meng Friday, July 12, 2013 3:40 AM add info
    • Marked as answer by Max Meng Tuesday, July 16, 2013 3:18 AM
    • Unmarked as answer by RichardJAndrew Wednesday, August 7, 2013 3:27 PM
    Friday, July 12, 2013 3:21 AM
  • Thanks for the response, but this doesn't really make sense to me. You are correct that the template is getting opened from the temp folder (I checked following your instructions), but why would this be the case? It makes even less sense that this happens only when the template is in both the user and workgroup template locations and not if it is in just the workgroup template location. If I open one of the documents with this problem in notepad I can see that the original template path is our usergroup templates folder, so why is it attaching to a template in the temp folder? Creating new documents using a template in the usergroup template location also display this problematic behaviour.

    Our environment is locked down so enable all macros setting is not available. The "Disable all macros exept digitally signed macros" is not an option as it would have to be set company wide and would cause result in a big disruption to our users and a lot of work to sign all existing macros.

    Wednesday, August 7, 2013 3:27 PM