locked
No auto-rotation on Windows 10 [Lenovo Yoga 3-14] RRS feed

  • Question

  • Hello!

    I'm having this problem since I installed Win10 on this machine. Before anybody would suggest anything I'd like to say that I've already done nearly everything what I found on the internet, so let's not dwell on things like turning off the auto-rotate-lock button because it's quite hilarious, I suppose.

    So here's the things I've done:

    1. Tried to update every driver I could using the official Lenovo's site for Yoga 3-14.

    2. I tried setting things in the register and in the services (setting things like sensors from manual to auto).

    3. Deleting, reinstalling and so on every device included in the device manager.

    4. Reinstalling the whole system several times and updating the system straight from Win8.1 to Win10 (Windows 8.1 worked fine - auto rotate, tablet mode and so on were working just out of the box).

    I can't find the solution and I'm trying to fix this thing for like weeks. Also I can mention that one of the Linux distros (Fedora) was working fine, including the auto-rotate - so it can't be the hardware. So as I mentioned - Win8.1 also was working fine. I really need help on this one - maybe I'm missing something, like some crucial update, driver maybe. I'm using pretty fresh install of Win10 - the only thing I did for now was to install the browser and drivers for Nvidia and Intel graphics.

    Thursday, July 20, 2017 11:37 AM

All replies