locked
Alert Template Issue RRS feed

  • Question

  • I went into the hive and copied alerttemplates.xml and saved it as customalerttemplates.xml

    In the copy, I added a few list field names to the following two xml tags to have them removed from the alerts:

    <ImmediateNotificationExcludedFields>< /ImmediateNotificationExcludedFields>

    <DigestNotificationExcludedFields></DigestNotificationExcludedFields>

    I then ran the following STSADM command:
    STSADM.EXE -o updatealerttemplates -url https://www.sitename.com -f C:\PROGRA~1\COMMON~1\MICROS~1\WEBSER~1\12\TEMPLATE\XML\customalerttemplates.xml

    I then did an iisreset and restarted the“SharePoint Timer Services”

    This worked perfectly the first time.

    I now need to go back in and add a few more list field names to be removed from the alerts. But when I do it, and rerun all of the commands I used prior, it doesn’t do anything. It’s acting like I never even made any changes.

    Can anyone think of anything I might be missing?

    • Moved by Mike Walsh FIN Wednesday, June 1, 2011 7:26 PM q involves stsadm so admin not general (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Wednesday, June 1, 2011 6:03 PM

Answers

  • Hi ,

     

    I understand that you make a copy of the alerttemplate.xml and change the alter template not to show list fields which you don’t want them to appear .Then use stsadm.exe to upgrade alerttemplates . Since it worked for the first time ,so there isn’t anything you have missing .I have a test based on these understanding . And the alert works properly both the times .So I suggest you having a test again .

    1.       Make a copy of the alerttemplates.xml and rename it .

    2.       Make the all the changes you want  in the new XML file then save it .

    3.       Use stsadm.exe to update alerttemplates to the new XML file .

     

    Will it work this time?

     

    If you have any more questions ,please feel free to ask .

     

    Thanks,


    Regards, Rock Wang Microsoft Online Community Support
    Thursday, June 2, 2011 10:44 AM

All replies

  • HI Brian,

    PLease let us know what have you changed ?  

    "now need to go back in andadd a few more list field names to be removed from the alerts"

    Thursday, June 2, 2011 9:20 AM
  • Hi ,

     

    I understand that you make a copy of the alerttemplate.xml and change the alter template not to show list fields which you don’t want them to appear .Then use stsadm.exe to upgrade alerttemplates . Since it worked for the first time ,so there isn’t anything you have missing .I have a test based on these understanding . And the alert works properly both the times .So I suggest you having a test again .

    1.       Make a copy of the alerttemplates.xml and rename it .

    2.       Make the all the changes you want  in the new XML file then save it .

    3.       Use stsadm.exe to update alerttemplates to the new XML file .

     

    Will it work this time?

     

    If you have any more questions ,please feel free to ask .

     

    Thanks,


    Regards, Rock Wang Microsoft Online Community Support
    Thursday, June 2, 2011 10:44 AM
  • This one was my fault. I left the @ symbols on the new fields I added.

    Tuesday, June 7, 2011 8:23 PM