locked
Some Resource Rooms Not Booking RRS feed

  • Question

  • I have a few resource rooms that aren't booking correctly. When someone tries to book a room, nothing happens, there is no response from the room with either an accept or a decline. I have identified three so far, but most still appear to be working correctly. I have compared a get-mailboxcalendarsettings between working and non-working rooms, and they are identical, so that doesn't appear to be the issue. I've disabled and re-enabled AutoAccept. I have recycled the MSExchangeMailboxAssistants service, that didn't help. I even rebooted both servers in the CCR cluster, testing on both servers after being rebooted, problem still happens on both servers. I cranked up logging for the four MSExchangeMailboxAssistants items to expert, but that didn't tell me anything. When you try to book to a room that's not working, nothing gets logged. I've enabled and disabled the AD accounts, and that didn't help. I've compared the properties in the EMC and AD to see if I could find something, but they all look the same as working rooms. I've also tried moving a non-working room to a new storage group, and that didn't help either.

    I'm out of ideas and would really appreciate some suggestions.

    Friday, January 27, 2012 4:03 PM

All replies

  • Always post the version, service pack and rollup hotfix level of Exchange you are running.
    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Friday, January 27, 2012 4:34 PM
  • Sorry, Exchange 2007, SP3, no rollups since SP3 yet.
    Friday, January 27, 2012 4:36 PM
  • If these are mailboxes you moved from Exchange 2003, you might consider deleting and recreating them.  I've seen that fix autoaccept problems.
    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Friday, January 27, 2012 4:40 PM
  • Yes, they were migrated from 2003. These rooms are booked solid for months, and asking people to rebook all their meetings, especially the executives, isn't really an option, I just need to have the existing rooms start working again.

    Friday, January 27, 2012 5:03 PM
  • Make sure you don't still have Direct Booking enabled on the room calendars.

    Make sure that you don't have any recurring meetings without expiry dates as those can cause trouble.

    Is there anything in the event log?


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Friday, January 27, 2012 5:17 PM
  • I checked, and Direct Booking has been turned off. There is nothing in the eventlog, even though I cranked up the MSExchangeMailboxAssistants event logging to expert. I will have to check on recurring meetings without expiration dates and report back.
    Friday, January 27, 2012 5:25 PM
  • Ok, there are some recurring meetings with no end dates, should I just put in an end date? Does it matter how far out?

    Friday, January 27, 2012 5:27 PM
  • I can't promise that it will fix your problem but it will help avoid future ones.  Set an end date of, say 31 December, and see if it fixes anything.
    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Friday, January 27, 2012 5:37 PM
  • That didn't seem to help. Any other ideas?
    Friday, January 27, 2012 10:31 PM
  • Hi Aubrey,

    Please make a try as below:
    1. Move the affected resource mailbox back to Exchange 2003 if possible. If Exchange 2003 no longer exists, please proceed to do followings
    2. Ensure the user account for the affected mailbox is enabled. Configure an outlook profile for the affected resource mailbox, then logon to the resource mailbox
    3. Clear the following option in Outlook
    - Automatically accept meeting requests and process cancellations
    - Automatically decline conflicting meeting requests
    - Automatically decline recurring meeting requests
    4. If we found above options are not checked yet, please select the checkbox to enable “direct booking” again.
    5. Quit configuration and test to ensure direct booking works fine. Then uncheck the 3 boxes. And grant “Reviewer” permission group to “Default”

    6. Move the mailbox to Exchange 2010 and run following command:
    Set-Mailbox -Identity "room" -type Room
       Set-CalendarProcessing -Identity "room" -Automateprocessing Autoaccept

    Regards!

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Gavin

    TechNet Community Support

    Monday, January 30, 2012 10:00 AM
  • Unfortunately, we no longer have 2003 and do not yet have 2010, so that's not really something I can try at this time.
    Monday, January 30, 2012 4:08 PM
  • Hi Aubrey,

    I would suggest that you could create new room mailbox  instead of the issue ones.

    Regards!

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contacttngfb@microsoft.com
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Gavin

    TechNet Community Support

    Tuesday, January 31, 2012 3:28 AM