none
Failed to build OLAP cube, file is corrupted RRS feed

  • Question

  • Hi all,

    Recently all of our OLAP cube jobs started failing with the following error.

    Failed to build the OLAP cubes. Error: Failed to connect to the Analysis Services server https://olap.project.com/olap/msmdpump.dll. Error: File system error: The following file is corrupted: Physical file: \\?\E:\Program Files\Microsoft SQL Server\MSAS10_50.MSSQLSERVER\OLAP\Data\test BI.0.db\Resource Is Team.0.dim\1.Resource Is Team.Resource Is Team attribute.dstore. Logical file .
    Errors in the metadata manager. An error occurred when loading the Resource Is Team dimension, from the file, '\\?\E:\Program Files\Microsoft SQL Server\MSAS10_50.MSSQLSERVER\OLAP\Data\test BI.0.db\Resource Is Team.1.dim.xml'.
    Errors in the metadata manager. An error occurred when loading the Resource Non Timephased cube, from the file, '\\?\E:\Program Files\Microsoft SQL Server\MSAS10_50.MSSQLSERVER\OLAP\Data\test BI.0.db\Resource Non Timephased.1.cub.xml'.


     I have been searching around and have not been able to find a solution.  Any help you could give us is greatly appreciated.

    Thanks!

    Mike
    Wednesday, November 16, 2011 11:06 PM

Answers

  • HI there,

    A similar thread might help you. It seems that OLAP data cube "test BI" is corrupted:
    http://social.msdn.microsoft.com/Forums/en-US/sqlanalysisservices/thread/3ca9b804-9e4c-4351-88d2-c39bea48dfd4
    Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82
    • Marked as answer by rix87 Friday, November 18, 2011 4:49 PM
    Thursday, November 17, 2011 8:51 AM
  • Hi all,

    Rebuilding the Analysis Data folder did the trick.  However for some reason the IUSR account needed to be added to the analysis server permissions as well as the folder.  This was not the case prior to this issue happening and we are not sure why it was needed afterwards.  However all in all everything is back working as it should.  Thank you all very much for your help.

    Mike

     

    • Marked as answer by rix87 Friday, November 18, 2011 4:50 PM
    Friday, November 18, 2011 4:48 PM

All replies

  • Hello Mike,

    Are you able to build another cube?

    Thanks,

    Hrishi

     

    Wednesday, November 16, 2011 11:38 PM
    Moderator
  • Hi there,

    Thank you for the quick response.  No I am not able to build any cubes old or new.  We are at a loss as to what has happened.  No changes have been done recently.

    Thanks!

    Mike

     

    Thursday, November 17, 2011 12:02 AM
  • Hi Mike,

    Try to process the cube manually from Analysis server.

    1. Open SQL server management studio

    2. Connect to Analysis Service

    3. Right click on the cube and select process.

     

    If you are not able to process the cube from AS, then issue is with Analysis Service.

    Also did you perform reporting database refresh recently?

     

    Thanks,

    Hrishi

     

    Thursday, November 17, 2011 12:06 AM
    Moderator
  • Are you using Project 2007 or 2010?

     

    Thursday, November 17, 2011 12:12 AM
    Moderator
  • Hi there,

    None of the OLAP cubes will process.  Receive the following error:

     

    TITLE: Microsoft SQL Server Management Studio
    ------------------------------

    Cannot show requested dialog.

    ------------------------------
    ADDITIONAL INFORMATION:

    File system error: The following file is corrupted: Physical file: \\?\E:\Program Files\Microsoft SQL Server\MSAS10_50.MSSQLSERVER\OLAP\Data\test BI.0.db\Resource Is Team.0.dim\1.Resource Is Team.Resource Is Team attribute.dstore. Logical file .
    Errors in the metadata manager. An error occurred when loading the Resource Is Team dimension, from the file, '\\?\E:\Program Files\Microsoft SQL Server\MSAS10_50.MSSQLSERVER\OLAP\Data\test BI.0.db\Resource Is Team.1.dim.xml'.
    Errors in the metadata manager. An error occurred when loading the Resource Non Timephased cube, from the file, '\\?\E:\Program Files\Microsoft SQL Server\MSAS10_50.MSSQLSERVER\OLAP\Data\test BI.0.db\Resource Non Timephased.1.cub.xml'.
     (Microsoft.AnalysisServices)

    We have not done any db refreshes lately as far as I know.

    Any ideas?

    Thanks!

    Mike

     

    Thursday, November 17, 2011 12:36 AM
  • Project Server 2010

    Thursday, November 17, 2011 12:37 AM
  • msmdpump.dll entry indicates that you are using http pump method to reach analysis server, is that correct?

    Execute following query on reporting database

    EXEC sp_MSforeachtable 'UPDATE STATISTICS ? WITH FULLSCAN'

     

    Thursday, November 17, 2011 1:27 AM
    Moderator
  • HI there,

    A similar thread might help you. It seems that OLAP data cube "test BI" is corrupted:
    http://social.msdn.microsoft.com/Forums/en-US/sqlanalysisservices/thread/3ca9b804-9e4c-4351-88d2-c39bea48dfd4
    Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82
    • Marked as answer by rix87 Friday, November 18, 2011 4:49 PM
    Thursday, November 17, 2011 8:51 AM
  • Hi all,

    Rebuilding the Analysis Data folder did the trick.  However for some reason the IUSR account needed to be added to the analysis server permissions as well as the folder.  This was not the case prior to this issue happening and we are not sure why it was needed afterwards.  However all in all everything is back working as it should.  Thank you all very much for your help.

    Mike

     

    • Marked as answer by rix87 Friday, November 18, 2011 4:50 PM
    Friday, November 18, 2011 4:48 PM