locked
event ID 1080 errors RRS feed

  • Question

  • So recently I used the Set-ExchangeServer command to exclude an AD controller because we were in the process of retiring an AD controller, and we wanted Exchange to no longer use it.  We have used this same command dozens of times before in the past to temporarily exclude AD controllers when we are doing maintenance on them.

    For some reason this time though, after issuing that command, we started receiving 1080 errors.  Specifically, here is the KB article describing the exact problem I am experiencing:

    http://support.microsoft.com/kb/948047

    "An event ID 1080 message is logged in the System log every three seconds after you run the Set-ExchangeServer command to set the static domain controllers on an Exchange 2007 cluster node"

    The article suggests installing Update Rollup 2 for Exchange Server 2007 SP1.   The problem is, we are on Exchange 2007 SP 2 - Version: 08.02.0254.000, which I would think would already include that rollup.

    So what do I do?  According to the article, it's just missing a regkey.  Can I manually recreate it?  If so, how?  Should I try installing the latest rollup for Exchange SP 2?

    Other than my system logs filling up with those errors, nothing seems to be actually broken.  I have tried failing over the server, but that did not clear out the problem.

    Tuesday, November 2, 2010 2:21 PM

Answers

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchange ADAccess

     

    right click " MSExchange ADAccess" new subkey.

    then type  "Instance0"

     

    we are not creating a value


    Dhruv
    • Marked as answer by Yavicleus Monday, November 8, 2010 1:28 PM
    Tuesday, November 2, 2010 4:40 PM
  • Just wanted to report back.  After re-adding the missing registry key on all three nodes of my SCC cluster, and restarting the cluster services, the error has cleared up.

    So if anybody else runs into the same error:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchange ADAccess

     

    right click " MSExchange ADAccess" new subkey.

    then type  "Instance0"

     

    Then restart all cluster services and it's good to go.

    • Marked as answer by Yavicleus Monday, November 8, 2010 1:30 PM
    Monday, November 8, 2010 1:29 PM

All replies

  • IF you want  avoid a DC from being selected by exchange Directory Access. the good idea is to always decrease the SRV record WEIGHT .

    yes, you already have roll up included,you can try creating the instance0 reg key. better idea is to always keep your server updated with latest service pack

     

     

     


    Dhruv
    Tuesday, November 2, 2010 3:05 PM
  • I currently have Update Rollup 4 for Exchange Server 2007 Service Pack 2 installed, which is the latest rollup for SP2.  I'd rather like to avoid moving to SP3 if at all possible.

    I can create the reg key, but what should it be? i.e. should the value be set to anything?

    Tuesday, November 2, 2010 3:49 PM
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchange ADAccess

     

    right click " MSExchange ADAccess" new subkey.

    then type  "Instance0"

     

    we are not creating a value


    Dhruv
    • Marked as answer by Yavicleus Monday, November 8, 2010 1:28 PM
    Tuesday, November 2, 2010 4:40 PM
  • Thanks!

    I've added the missing registry key, and will estart the cluster services this weekend during our maintenance interval.

    Wednesday, November 3, 2010 12:45 PM
  • Just wanted to report back.  After re-adding the missing registry key on all three nodes of my SCC cluster, and restarting the cluster services, the error has cleared up.

    So if anybody else runs into the same error:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchange ADAccess

     

    right click " MSExchange ADAccess" new subkey.

    then type  "Instance0"

     

    Then restart all cluster services and it's good to go.

    • Marked as answer by Yavicleus Monday, November 8, 2010 1:30 PM
    Monday, November 8, 2010 1:29 PM