none
Hyper-V backup Oracle VSS writer error VSS-00044 RRS feed

  • Question

  • Hi.

    I have a Windows Server 2012 R2 Hyper-V with a VM guest Windows 2012 installed. Oracle is installed in that VM and when I'm trying to run a Hyper-V backup I get this Oracle VSS error:

    VSS-00044: Database in NOARCHIVELOG mode must be in a consistent state for backup.  
    Cause : The database was open read/write or mounted after a SHUTDOWN IMMEDIATE or SHUTDOWN ABORT.  
    Action : Either mount the database in a consistent state or open it read-only to back up the database files.  
    Additional info :
    Oracle Database 11g Release 11.2.0.4.0 - 64bit Production
    Oracle VSS writer version 11.2.0.2.0 Production
    Error at line : 4576
    Failure on PrepareForBackup event

    What is best practice and how do I configure this setup if I want to keep the Oracle VSS writers. Should I configure something in Oracle or on the Windows Servers.

    Regards
    MHem

    Wednesday, June 18, 2014 7:18 AM

Answers

  • Hi, try this one

    You need to add a registry entry inside the Guest so VSS does not include the application writers during a virtual machine backup.  This will allow other backup applications running in the guest to make the SQL backup.

    How to enable the Hyper-V VSS writer to ignore the VSS application writers

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Virtualization\VssRequestor

    2.Create a registry entry of the REG_DWORD type.
    3.Set the name of the registry entry to BackupType.
    4.Set the value of the registry entry to 1.

    Note If you set the value to 0, the Hyper-V VSS writer does not ignore the VSS application writers on the VMs.


    Seidl Michael | http://www.techguy.at | twitter.com/techguyat | facebook.com/techguyat

    • Proposed as answer by Michael Seidl (MVP)MVP Wednesday, June 18, 2014 10:41 AM
    • Marked as answer by MHem Wednesday, June 18, 2014 10:45 AM
    Wednesday, June 18, 2014 10:41 AM

All replies

  • Hi, try this one

    You need to add a registry entry inside the Guest so VSS does not include the application writers during a virtual machine backup.  This will allow other backup applications running in the guest to make the SQL backup.

    How to enable the Hyper-V VSS writer to ignore the VSS application writers

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Virtualization\VssRequestor

    2.Create a registry entry of the REG_DWORD type.
    3.Set the name of the registry entry to BackupType.
    4.Set the value of the registry entry to 1.

    Note If you set the value to 0, the Hyper-V VSS writer does not ignore the VSS application writers on the VMs.


    Seidl Michael | http://www.techguy.at | twitter.com/techguyat | facebook.com/techguyat

    • Proposed as answer by Michael Seidl (MVP)MVP Wednesday, June 18, 2014 10:41 AM
    • Marked as answer by MHem Wednesday, June 18, 2014 10:45 AM
    Wednesday, June 18, 2014 10:41 AM
  • You need to change the Oracle DB mode. It should be in ArchiveLog mode for the Oracle VSS writer to be able to quiesce the database so that the backup can happen.

    Ask your DBA to change the setting in Oracle.

    More info here: See the section "Backing Up a Database in ARCHIVELOG Mode" here:

    http://docs.oracle.com/cd/B28359_01/win.111/b32010/vss.htm#BABFEIFJ

    PS: It does not makes any sense to me to "...Hyper-V VSS writer to ignore the VSS application writers". Why? Oracle has provided a fully functioning VSS writer. Use it! :-) If you don't use it. your Oracle DBs will be in an inconsistent state when you back them up.


    -Rajeev rajdude.com

    • Proposed as answer by rajdude2 Tuesday, March 31, 2015 5:01 PM
    Tuesday, March 31, 2015 5:01 PM