Vista feature regression: "security tab" missing for multiple selections in Explorer properties RRS feed

  • Question

  • Pre-emptive disclaimer: This is not a vista-sucks rant. I am using Vista Business in good faith and intend to continue using it. I am after a solution or, at worse, I want to cajole the Vista team into fixing this issue in a hotfix.


    There is a major feature regression in Windows Explorer for all professional-class versions of Vista (probably also present in Windows Server 2008, as well). After selecting multiple items in Explorer and opening the "properties" pane, the "security" tab (or property sheet) is not present. If I only select one item in Explorer and open the "properties" pane, the "security" tab is present. I have tried this on several computers running Vista Business, with the same result. I do not like to assume the worst, but past experiences have led me to be cynical. In my opinion there is no justification for the removal of such a feature due to "security concerns" since the same thing can be done with the command line. That being said, I do not want to use the command line. Thus my request:

    1. What is the rationale for the removal of this feature?
    2. Is there a registry override (or similar hack) to turn the "security" tab back on for multiple selections?
    3. If there is no way for the end-user to enable this, then with all due respect, Microsoft needs to fix this feature regression.

    I do not think it unreasonable to expect such simple, useful functionality in Vista when it was in Windows 2000, XP, and 2003. To reiterate, I am well aware of the existence of icacls and friends, but that isn't the point nor is it what I want. I have my reasons. Using the visual interface for precise selection is much less prone to error than relying on the command-line to progmatically expand arguments. And even more so when used on the results of a file search query.

    Tuesday, March 25, 2008 1:56 PM

All replies




    Yes I agree with everything here wholeheartedly.   It makes a very simple task very labourious. HOTFIX PLEASE ASAP!



    Tuesday, March 25, 2008 4:46 PM
  • What a disgrace! This is still not fixed in the Windows 7 Release Candidate and Microsoft shows no commitment to fixing it in RTM or a hotfix for Vista SP2.

    Sunday, May 24, 2009 7:45 AM
  • Please for heaven's sake make a hotfix available for Vista SP2 and Windows 7 RTM. Can anyone open a support case/design change request hotfix thru technical support?
    Monday, October 26, 2009 4:24 PM
  • I can't believe they removed this.

    The workaround was to put files into a folder and then applyh the permissions to the folder and then move the files back out of a folder to where they were.

    It made a simple two minute task take so much longer.

    I can confirm that this regression still exists in Windows 7 SP1 RTM.

    Please reinstate the feature!

    I beleive its removal has something to do with UAC and the possibility that one of the changes would trigger a UAC prompt. However could we not right-click explorer and run that as administrator and then no more UAC prompts should be required and the security tab could be re-enabled?




    Robin Wilson
    Wednesday, February 23, 2011 6:59 AM
  • I will add my voice to this.  It has driven me nuts for years.  On a related notE, why don't shared folders on Server 08 R2 and newer use a different icon so an admin can easily tell what folders are shared. 

    Ian Matthews www.urtech.ca  www.commodore.ca

    Friday, September 21, 2012 4:35 PM
  • Hello Ian

    Yes that would be a really good idea or if there was a way to search for shared folders. You can obviously navigate to \\computername but that still doesn't help you locate the physical path of the folders.

    I can confirm the permissions issue on multiple folders has not been "fixed" in windows 8 either so the workaround of sticking everything into a certain folder, applying the permission and putting it back seems to be the only way unless CALCS is used in cmd (which I think would be another way).

    Robin Wilson

    Saturday, September 22, 2012 3:36 PM
  • Hi Robin;

    \\hostname will not work for any of the shares I create because, with precious few exceptions, I only create hidden shares ie \\hostname\legal$ .  I need this icon to easily identify the shares... and no I don't want to spend the time going through the SHARES tools.


    Ian Matthews www.urtech.ca www.commodore.ca

    Monday, January 14, 2013 11:52 PM