none
Internet Works, No Local Network Discovered RRS feed

  • Question

  • I have a local network that is setup using workgroup on Windows 7 64-bit machines.  I have about 4 machines set up, all have the same network configuration.  One computer has lost all local network access but still has internet access.  I have tried just about everything, removing the network adapter drive and reinstalling, toggling network setup parameters on and off, etc.  Nothing seems to be able to restore the local network access.  The strange thing is the other computers can see this computer and access the shared drives.  I am at a loss short of reinstalling Windows 7 which I really do not want to do at this point.  Anyone know what could possibly be causing this?  Thank you, 
    Thursday, August 10, 2017 5:28 PM

All replies

  • First of all, you should make sure all computers in the same network segment and has same subnet mask.

    Friday, August 11, 2017 3:35 PM
  • I am on DSL.  The modem and router are integrated.   Out of the router each of the computers I use the most is connected through a 5-port unmanaged switch (2 switches).  The reason for two switches is how the office and wired and where the modem is.  Both are set to obtain DHCP and IP from the gateway automatically.  Yesterday I reset the router and now the development computer can see the while LAN but the Accounting computer cannot see the LAN.  This is backwards of the way it started out yesterday morning. So I guess I do not know how the switches are affecting the routing and/or segments.  When I check each computer (ipconfig) they show subnet masks of 255.255.255.0 each.  All addresses are between 192.168.0.2 and 192.168.0.5 (counting my notebook and phone on wireless).
    Friday, August 11, 2017 8:11 PM
  • I guess my big question here is, WHY?  I have been running this same setup for nearly 8 years.  I did not change anything recently but am just now having issues.  It all cropped up in the last couple weeks.  Not sure what Microsoft updates I have loaded since they are so obscure now (June Rollup, no details).  The only thing I can think of is that Microsoft changed something in the updates that made my Windows 7 machines start to act screwy like this.
    Friday, August 11, 2017 8:51 PM
  • It's possible that your switch is showing its age. Have you tried replacing it?
    Monday, August 14, 2017 12:55 PM
  • I have not tried replacing the modem/router.  The switches seem fine, especially since the two computers changed places as far as seeing the local net or not.  The modem/router is from CenturyLink and is going to be expensive but I may try.  It seems strange it would cause the problem though, I would think it would work or not work.
    Monday, August 14, 2017 1:48 PM
  • Hi,

    What’s your meaning that  “The PC has lost all local network access”? Does it means that  you can’t see other computer in file explorer->network or you can see other computer but can’t access the resources.

    If it can’t see other computer in Network, you could check if network discovery is turned on.

    If it can see other computer but can’t access the resources, please try to ping other PCs’ IP address. If it can ping, please check if server service is started and running fine. Please check if it has installed Microsoft Network Client. Open file explorer->right click network -> properties -> change adapter settings -> right click local Area connection -> properties -> choose Microsoft Network Client-> install.

    Which way do you attempt to access resources, Start -> RUN IP or file explorer->network? If it can’t access resources, it may be caused by permission or firewall, please use administration account or turn off firewall temporarily for test.

    Tuesday, August 15, 2017 6:26 AM
  • When I select network in file Explorer nothing shows up.  Network discovery is turned on.  The other computer on the network can see all the resources on the network (the computer that does not see the local network and my NAS).  From the other computer I can access the drives on the computer that does not see anything under Network.  I have tried turning off the firewall with no different results.  Microsoft Network Client is installed.  Any chance IPv6 is causing me any problems with NetBIOS?  Thank you,
    Tuesday, August 15, 2017 1:39 PM
  • Oh, one other thing.  If I open the network & sharing center and click on "see full map" everything is mapped, other computer and NAS, but it does not show up in file Explorer under Network. 
    Tuesday, August 15, 2017 1:45 PM
  • Is there any error message when you access resources through Start -> Run IP/hostname?


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, August 18, 2017 7:04 AM
  • Nothing has helped so far.
    Friday, August 18, 2017 5:28 PM
  • Do you attempt to access resources through Start -> Run IP/hostname?

    If yes, is there any error message?

    If no, please try to do.

    It may help to solve the problem.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, August 22, 2017 9:22 AM
    • To open a command prompt, select Start and then type cmd in the Search programs and files box.
    • Under Programs, right-click the CMD.exe icon, and then select Run as administrator.
    • When the User Account Control box appears, select Yes.
    • At the command prompt, enter the following command, and then press Enter:
      netsh int ip reset c:\resetlog.txt 
      Note If you don't want to specify a directory path for the log file, run the following command instead:
      netsh int ip reset resetlog.txt 
    • Restart the computer.
    Tuesday, August 22, 2017 9:29 AM
  • Sorry, don't understand the command I am suppose to run. "IP" does not show up.  Don't understand about accessing resources.  In Network And Sharing Center, if I click "see full map" everything shows up.  I just cannot get anything to show up in file Explorer.  Also, I always get mapped connections to my NAS as w:,x:, y: for each of the shares.  I have done everything I can find on the next to stop these from showing up after a reboot but they always come back. 
    Tuesday, August 22, 2017 1:54 PM
  • This did nothing.  Not sure what I am suppose to see.  Am I suppose to check a log file?
    Tuesday, August 22, 2017 3:09 PM
  • Hello there,

    above commands will reset the TCP/IP stack .

    See the output that I got -

    Run this command in command prompt-

    netsh int ip reset

    Output should be like this below-

    Reseting Global, OK!
    Reseting Interface, OK!
    Reseting Unicast Address, OK!
    Reseting Route, OK!
    Restart the computer to complete this action.

    Restart the computer and check

    Note - You have to do IP configuration again so keep a note of the IP address, subnet mask & default gateway, DNS server if you have static IP address .

    thanks

    prashant



    Wednesday, August 23, 2017 12:55 AM
  • Yes, command completed just as you got. Restarted computer, still can only see my local net when I click on "see full map".  Nothing shows up in file Explorer I can access.  My NAS & modem do show up under "other devices" and my modem/router unit shows up under Network Infrastructure.
    Wednesday, August 23, 2017 2:02 PM
  • Hello Ritchey,

    Please try below -

    Go to services-

    there will be one service named "Function Discovery Resource Publication"

    set this service to automatic and then restart the services.

    Try this on all the all the computers.

    If still issue is there, set all the below services to automatic and restart it.

    · DNS Client
    · Function Discovery Provider Host
    · Function Discovery Resource Publication
    · Peer Networking Grouping
    · HomeGroup Provider
    · HomeGroup Listener
    · SSDP Discovery
    · UPnP Device Host

    If still it doesn't help then enter the command "net view" and see if you see all the computers or any error message.



    Thursday, August 24, 2017 2:51 AM
  • Thank you but no difference.  net view did not show computers on the local net on the computer I am having issues with.  All other computers saw all computers on the net including the one that sees nothing.
    Thursday, August 24, 2017 1:55 PM
  • I think these links will help you.

    Windows 7 not showing other computers on network:

    https://superuser.com/questions/134965/windows-7-not-showing-other-computers-on-network

    Windows 10: Network Devices not Showing with File Explorer:

    https://www.tenforums.com/network-sharing/34589-network-devices-not-showing-file-explorer.html




    • Edited by BEE-F Saturday, September 2, 2017 4:09 PM
    Saturday, September 2, 2017 4:09 PM
  • Thanks, but went through both these.  Some things I had tried, the others I had not tried I attempted but with no luck.  My engineering computer still does not see the accounting computer or the notebook, both running Win7.  I use a workgroup, all computers are set to the same workgroup.  Network discover and sharing is turned on.  Have tried perturbations of other settings, no luck.
    Saturday, September 2, 2017 4:57 PM